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Preface 

Scope and standards 
This  document is part of the Engineering System Handling documentation package. 

Scope of validity 
This manual applies to SIMOTION SCOUT in association with the SIMOTION CamTool 
option package for product version V4.1. 

Sections in this manual 
The following is a list of chapters included in this manual along with a description of the 
information presented in each chapter. 
● Overview 

This chapter provides the user with an overview of the SIMOTION SCOUT engineering 
system. 

● Installing software 
This chapter contains the system requirements for SIMOTION SCOUT, describes the 
procedure for installing and uninstalling it, and provides important information on the 
communications link to the SIMOTION device. 

● Functions 
This chapter explains the basic steps required for the operation of SIMOTION SCOUT. 
There is an explanation of the SIMOTION SCOUT workbench. An important aid is, for 
example, the online help for SIMOTION SCOUT. Important information is provided on this 
topic. Additional functions such as the licensing of the runtime components and the 
replacement of the SIMOTION device are also described. 

● Product combinations 
This chapter describes topics such as compatibility and data carriers as well as STEP 7, 
NetPro, Drive ES, HMI and other interfaces. 

● Diagnostics 
This chapter provides information on how to operate the diagnostics with SIMOTION 
SCOUT and introduces the diagnostic functions. 

● FAQs 
This chapter describes how the user can commission drives. It contains general 
information and special applications. 

● Index 
Index 
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SIMOTION Documentation 
An overview of the SIMOTION documentation can be found in a separate list of references.  
This documentation is included as electronic documentation with the supplied SIMOTION 
SCOUT. 
The SIMOTION documentation consists of 9 documentation packages containing 
approximately 60 SIMOTION documents and documents on other products 
(e.g. SINAMICS).  
The following documentation packages are available for SIMOTION V4.1: 
● SIMOTION Engineering System 
● SIMOTION System and Function Descriptions 
● SIMOTION Diagnostics 
● SIMOTION Programming 
● SIMOTION Programming - References 
● SIMOTION C2xx 
● SIMOTION P350 
● SIMOTION D4xx 
● SIMOTION Supplementary Documentation 

Hotline and Internet addresses 
If you have any technical questions, please contact our hotline (worldwide):  
A&D Technical Support: 
● Phone: +49 (180) 50 50 222 
● Fax: +49 (180) 50 50 223 
● E–mail: adsupport@siemens.com 
● Internet: http://www.siemens.de/automation/support-request 
If you have any questions, suggestions, or corrections regarding the documentation, please 
fax or e-mail them to: 
● Fax: +49 (9131) 98 63315 
● E–mail: docu.motioncontrol@siemens.com 
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Siemens Internet address 
The latest information about SIMOTION products, product support, and FAQs can be found 
on the Internet at: 
● General information: 

– http://www.siemens.de/simotion (German) 
– http://www.siemens.com/simotion (international) 

● Product support: 
– http://support.automation.siemens.com/WW/view/en/10805436 

Additional support 
We also offer introductory courses to help you familiarize yourself with SIMOTION. 
Please contact your regional training center or our main training center at D-90027 
Nuremberg, phone +49 (911) 895 3202. 
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Description 1
1.1 Description 

The SIMOTION SCOUT Configuring Manual is a general description of the software. Not all 
the possible functions of the software are described in this document. All detailed, subject-
specific information can be found in the context-sensitive online help and the corresponding 
documentation. 
Important notes and information on the SIMOTION Motion Control system are contained in 
Catalog PM 10. 

1.2 SIMOTION SCOUT engineering system: General 

Introduction 
While the Motion Control system SIMOTION provides a wide variety of preprogrammed 
functions, it is also parameterizable and programmable for individual requirements. High 
performance tools, which provide optimum support and ease of use for the necessary 
engineering steps, are required for this. 
The SIMOTION SCOUT engineering system is the basis for the uniform automation of 
production machines with SIMOTION and integrates into the SIMATIC environment in 
accordance with TIA (Totally Integrated Automation). 
SCOUT provides a uniform, function-oriented view for your automation task and at the same 
time is very easy to use. 
The possible SIMOTION applications range from simple, parameterizable, speed-controlled 
single axes through to complex, mechatronically-coupled and programmable multi-axis 
machines. Therefore, SIMOTION SCOUT provides views adapted to the task and can be 
expanded with additional tools (e.g. tool for the graphic creation of cams). 
SIMOTION SCOUT is the engineering system for SIMOTION integrated in STEP 7 and 
provides all the required tools for the  
● Configuration 
● Parameterization 
● Programming 
● Testing 
● Diagnostics. 
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The following tasks are graphically supported with operator guidance: 
● Creation of the hardware and network configuration 
● Creation, configuration and parameter assignment of technology objects  

such as axes, output cams and cams. 

+

 
Figure 1-1 SIMOTION system overview 

The automation topology is specified in the first engineering steps. The hardware and 
network configuration is created by parameterizing the required components and networks. 
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1.3 Procedure for creating the project 

Steps to create a project 
Machine automation is implemented step-by-step as the project is created as follows: 
● First, you create a new project. 
● Create the device (SIMOTION D, SIMOTION C, SIMOTION P). 
● Then, you create the system configuration that describes the structure of the automation 

topology: 
– Which hardware components (drives, SIMOTION hardware platform, I/O) are you 

going to use? 
– How are they interconnected? 

● The basic parameterization of the hardware components and networks is then performed. 
SIMOTION SCOUT does this using two field-proven STEP 7 programs: HW Config and 
NetPro. 

● In the next step, the technology objects are configured, supported by wizards. 
● Select the programming language for the programming (MCC, ST, LAD/FBD). 
● A download is made into the device and 
● test the machine application. 

1.4 Workbench 

What is the SIMOTION SCOUT workbench?  
The SCOUT workbench is the common framework for all other tools of the engineering 
system. The workbench is thus the navigation center for the individual engineering steps. It 
is used to create and manage SIMOTION projects and provides a uniform and integrated 
view of all data and programs.  

Workbench features 
The workbench is: 
● An integrated and intuitively operated engineering system 
● Enables central data and program management, even for distributed systems 
● A function-oriented, technological project structure with filterable views 
● Enables quick access to individual engineering tools, such as configuration, 

programming, and commissioning 
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1.5 Technology packages and technology objects 

Technology packages in SIMOTION SCOUT 
Technology packages combine software functions which are required for automation in 
mechanical engineering in various sectors.  
The following technology packages are provided for SIMOTION: 
● TControl - temperature controller 
● CAM - cam with positioning and synchronous operation functions 
● CAM_EXT - cam incl. additional technology objects 
● OADPM - Direct Product Motion technology package (option) 
● DCC - interconnection of the drive-related control functions 
● Track - track interpolation 
Access to the technology package functions is carried out via additional language 
commands and system variables. Programming of motional sequences is therefore simple 
and integrated. 
The Motion Control Basic, Position and Gear technology packages were available for earlier 
versions.  
As from SIMOTION SCOUT Version V3.2, they are contained in the Cam technology 
package. 
Once the basic project structure has been created by the system configuration, the next step 
is to define the technology objects (axes, output cams, cams, etc.) required for the 
automation task. This defines the volume of project data that must be assigned parameters 
for the purpose of commissioning. 

Technology objects in SIMOTION SCOUT 
The technology objects are inserted directly into the folders provided in the project navigator. 
These are completed with the associated parameterization tool or commissioning tool.  
The next step is to program the SIMOTION devices. The SIMOTION SCOUT engineering 
system provides user-friendly and efficient programming languages to describe the individual 
functions of the machine process. 
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Additional references 
Please refer to the following documents on these subjects 
● SIMOTION Motion Control, Basic Functions, Description of Functions 
● SIMOTION Motion Control, Basic Functions, Description of Functions for modular 

machines 
● SIMOTION Motion Control, TO axis, Electric/Hydraulic, TO externalEncoder, Description 

of Functions 
● SIMOTION Motion Control, TO followingObject, TO cam, Description of Functions 
● SIMOTION Motion Control, Technology Objects for Output Cams and Measuring Inputs, 

Description of Functions 
● SIMOTION Motion Control, TO track interpolation, Description of Functions 
● SIMOTION Communication, System Manual 
● SIMOTION Motion Control, Supplementary Technology Objects, Description of Functions 
● Configuring Manual SIMOTION CamTool 
● SIMOTION TemperatureControl, Description of Functions 
and the online help. 
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1.6 Programming languages 

1.6.1 Programming languages in SIMOTION SCOUT 
Access to the technology packages and functions is carried out in the same way as access 
to the SIMOTION Kernel via language commands from the user program.  
The programming languages in SCOUT provide all of the language commands required to 
implement the functions simply and quickly. The SIMOTION runtime system also supports 
cyclic, sequential, time-controlled, and event-driven programming. 
The programming languages are: 
● Motion Control Chart (MCC) 

If you want to program graphically, you can use MCC for sequential flowchart-oriented 
programming.  

● Ladder Logic / Function Block Diagram (LAD/FBD) 
The familiar programming methods with LAD/FBD are also available in the SCOUT 
engineering system for user-friendly logic programming, supplemented with motion 
control functions via PLCopen function blocks.  

● Structured Text (ST) 
If you prefer a high-level language for your automation task, ST is available as an efficient 
and IEC 61131-3-compliant text-based language.  

● Drive Control Chart (DCC) 
Many applications require a combinatorial logic that combines several states (e.g. access 
control, plant states) to form a control signal (e.g. ON command) for controlling the drive 
system. 
In addition to the logical operations, arithmetic operations and storing elements are 
increasingly required in drive systems. 
This functionality is available as Drive Control Chart (DCC) on drive objects of the 
SINAMICS drive system and the SIMOTION control system. 
The Drive Control Chart Editor (DCC Editor), based on CFC, can be used to graphically 
configure SIMOTION controllers and SINAMICS drives.  
For additional information, see DCC Programming System section 

A variety of programming languages can be combined in a single project. 
The user program is executed in various tasks. A task is a job which is executed in a certain 
chronological sequence. The advantage of the task system is that processes hung in the 
appropriate task levels can run in parallel.  
The SIMOTION motion control system uses high-performance CPUs on which a realtime 
operating system suitable for fast control processes is implemented. Each task is allocated a 
slice of the computing time. The organization of the task sequences is performed by the 
operating system. A differentiation is made between user and system tasks that are 
independent of one another. 
Various debug functions are possible in the programming languages. Please refer to the 
appropriate programming manuals for more detailed information. 
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1.6.2 Graphics-based flowchart programming with MCC 

Motion Control Chart 
The idea behind MCC is to formulate the process sequences in the machine using simple 
and logical expressions. The result is one or more flowcharts showing the chronological 
sequence of the individual actions. As production machines are primarily concerned with 
controlling the motion of a large number of individual axes, MCC particularly supports the 
simple description of these motion sequences with powerful Motion Control commands. 
To control the machine, commands are available for awaiting the fulfillment of conditions and 
for formulating computations, as well as for executing various control structures, such as 
polling (IF), case determination (CASE), and loops (FOR, WHILE, UNTIL). Several MCC 
programs may be created to describe different process situations. For example, you can 
create one MCC program to bring the machine to a defined initial state when it is switched 
on, a second MCC program for the normal production sequence, and a third MCC program 
to specify what the machine is to do in the event of a fault. 
All commands are available in toolbars, sorted according to command groups. Clicking a 
command in the toolbar automatically incorporates it at the position marked in the flow chart. 
Double-clicking a command in the flow chart opens a specific dialog box for assigning 
parameters to this command. 
Performance features: 
● Easy-to-use due to graphics-based representation in flowcharts. 
● Hierarchical command library for Motion Control, PLC, and technology functions. 
● Control structures (IF, WHILE, CASE, etc.) 
● Conditions can be created in different languages. The chart can then be displayed in an 

arbitrary language. Plain text can be created in an MCC with the ST zoom. 
● Structuring based on command modules, i.e. combination of command sequences to 

create a command module. Clicking the command module invokes the corresponding 
command sequence. 

● Easy-to-use debug functions for online testing and diagnostics: E.g. single-step or 
program status mode for easier troubleshooting (debugging). 

Additional references 
Please refer to the following document on this subject 
● SIMOTION MCC (Motion Control Chart), Programming Manual 
and the online help. 
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1.6.3 Graphics-based programming language with LAD/FBD 

Ladder Logic / Function Block Diagram 
LAD/FBD stand for ladder logic and function block diagram. LAD/FBD are graphics-based 
programming languages. The statement syntax corresponds to a circuit diagram. LAD/FBD 
enable simple tracking of the signal flow between power rails via inputs, outputs, and 
operations. LAD/FBD statements consist of elements and boxes, which are graphically 
connected to networks. LAD/FBD operations follow the rules of Boolean logic. 
The programming language provides all the elements required for the creation of a complete 
user program. LAD/FBD features an extensive command set. This includes the various basic 
operations with a comprehensive range of operands and how to address them. The design 
of the functions and function blocks enables you to clearly structure the LAD/FBD program. 
The LAD/FBD programming package is an integral part of the basic SIMOTION software. 
Easy-to-use debug functions for online testing and diagnostics are available: E.g. monitoring 
of the variable values, program status and stopping points. 

Additional references 
Please refer to the following document on this subject 
● SIMOTION LAD/FBD, Programming Manual 
and the online help. 
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1.6.4 High-level language programming in ST 

Structured Text 
ST is a high-level, PASCAL-based programming language. This language is based on the 
IEC 61131-3 standard, which standardizes programming languages for programmable 
controllers (PLC). 
The basic command scope is sufficient for the implementation of everything related to data 
management, arithmetic functions, control structures, and I/O access. The addition of 
technology packages for Motion Control expands the scope of commands by further 
comprehensive, extremely flexible Motion Control commands (e.g.: _pos(..) for axis 
positioning). 
In addition, applications can be subdivided into any number of sections. Such a section 
might be a program allocated to a runtime level, an instantiatable function block with its own 
memory, or a function without its own memory. In this case, the function blocks and functions 
are not allocated to a runtime level, but are instead called in programs. 
● Motion control, PLC and technology functions in a single language 
● Well structured programs with comment capability 
● Powerful editing functions, such as syntax coloring and automatic indenting 
● Easy-to-use debug functions for online testing and diagnostics: e.g. display of up-to-date 

variable content of the code sequence selected in the editor (program status) and 
stopping points. 

Additional references 
Please refer to the following document on this subject 
● SIMOTION ST (Structured Text), Programming Manual 
and the online help. 

1.7 CamEdit cam editor 

 
CamEdit can be used to describe curves by means of either interpolation points or 
segments. A combination is not possible. If the curve is to be created from segments using 
polynomials, SIMOTION SCOUT provides the VDI wizard to assist in creation of the curve. 
Cam geometries are created in offline mode. 
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Installing software 2
2.1 System requirements 

2.1.1 Installing the interface card 

Installing the interface card in the PG/PC 
An interface card must be installed in the PG/PC so that the SIMOTION device can 
communicate with the PG/PC. This applies only to PROFIBUS. 
To use Ethernet, an Ethernet connection must be present on the PC.  
The PG/PC is used for the configuration, parameterization and testing.  
● Install the interface card in the PG/PC according to the installation guide provided. 
● Install the appropriate drivers on the PG/PC. 
● Connect the interface card to the interface of the SIMOTION device indicated below using 

a suitable cable. 

Table 2-1 Interface assignment for SIMOTION devices 

SIMOTION device Interface As delivered 
SIMOTION C2xx X8 DP1 

X9 DP2/MPI 
 
X7 (Ethernet) 

PROFIBUS address 2, baud rate 1.5 Mbit/s 
PROFIBUS address 2, baud rate 1.5 Mbit/s 
 
IP address: 169.254.11.22 
Subnet: 255.255.0.0 

SIMOTION P350 X101 DP1 
X102 DP2/MPI 
 
Ethernet 

PROFIBUS address 2, baud rate 1.5 Mbit/s 
PROFIBUS address 2, baud rate 1.5 Mbit/s 
 
IP address: 169.254.11.22 

SIMOTION P350-3 X101 DP1 
X102 DP2 / MPI
 
2 Ethernet 
interfaces 
(Ethernet 1 + 
Ethernet 2) 

PROFIBUS address 2, baud rate 1.5 Mbit/s (optional) 
PROFIBUS address 2, baud rate 1.5 Mbit/s (optional) 
 
IP address: 169.254.11.22 
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SIMOTION device Interface As delivered 
SIMOTION D4x5 X126 DP1, 

X136 DP2/MPI 
 
X120 IE1/OP 
(Ethernet) 
 
X130 IE2/NET 
(Ethernet 

PROFIBUS address 2, baud rate 1.5 Mbit/s 
PROFIBUS address 2, baud rate 1.5 Mbit/s 
 
IP address: 192.168.214.1 
Subnet: 255.255.0.0 
 
IP address: 169.254.11.22 
Subnet: 255.255.0.0 

SIMOTION D410 DP X21 DP PROFIBUS address 2, baud rate 1.5 Mbit/s 
SIMOTlON D410 PN X200 and X201

(1 PROFINET – 
interface with 
2 ports) 

IP address: 192.168.1.2 
Subnet: 255.255.255.0 

 

2.1.2 Configuring the interface card 

Configuring the interface card 
Proceed as follows:  
1. Start SIMOTION SCOUT. 
2. Select the menu Tools > Set PG/PC interface. 

The Set PG/PC Interface window opens. 

 
Figure 2-1 Set PG/PC interface (example) 

3. Select the access point of the application. 
4. Click Select. 

The Install/Uninstall Interfaces window appears. 
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Figure 2-2 Installing / deinstalling interfaces 

5. Select the module to be installed. 
6. Click Install. 
7. Click OK to confirm any messages. 
8. Click Close. 
9. Confirm the settings by clicking OK. 

Installing / deinstalling other interfaces 
Proceed as follows to install or uninstall additional interfaces: 
1. In the Set PG/PC Interface window, select S7ONLINE as the access point of the 

application. 
2. Click Select under Add/remove interfaces. 
3. In the left-hand field, select the interface that you want to install and click Install. 

Or select the interface that you want to uninstall in the right-hand field and click Uninstall. 
4. Click Close. 
5. Select the interface to be used in the Used interface parameterization field. 

The list of the used interface parameterization will be taken from SIMATIC STEP 7. 
With the PC Adapter (Auto) setting, the interface to which the PG/PC is connected is 
examined. This function automatically determines the current parameterization of the 
respective interface.  
Detailed information on the individual interfaces of the SIMOTION devices can be found 
in the relevant commissioning manuals. 

6. Click Properties to parameterize the interface. 
7. Click OK to confirm. 
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2.1.3 Defining the interface 

Defining the interface 
The interface is defined uniquely when you insert a SIMOTION device. If you make changes 
to the project so that the interface is no longer unique, you can modify the setting. 

 

 Note 
SIMOTION devices have two PROFIBUS connections. Defining the associated PROFIBUS 
connection speeds up online operation with the device. 

 
Proceed as follows in offline mode: 
1. Open the project. 
2. Select the SIMOTION device, e.g. C230-2, in the project navigator. 
3. Right-click and select Target device > Online access... in the context menu. 

The Properties - Program (Online) window opens. 
If you have defined the interface uniquely, you cannot make any settings in this window. 

4. Click the Module addresses tab. 
5. Set the address of the used connection. 
6. Click OK to confirm. 
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2.1.4 Communication via PROFIBUS DP 
PROFIBUS is a powerful, open, and robust bus system, which guarantees trouble-free 
communication. The system is fully standardized, which enables trouble-free connection of 
standardized components from a variety of manufacturers. Configuration, commissioning, 
and troubleshooting can be carried out from any side. This results in user-defined 
communication relationships that are very versatile, simple to implement, and easy to 
change.  
The high-speed, cyclic exchange of data with field devices (distributed I/O) is carried out via 
the PROFIBUS DP protocol. Expansion of the protocol to include isochronous mode also 
integrates the drive components into communication via PROFIBUS DP. The connection of 
the individual components can be performed via the integrated interfaces, connections, 
interface modules or communication processors. 
Important information on the communication with PROFIBUS is contained in the SIMOTION 
Motion Control System PM10 Catalog. 
The following PROFIBUS DP subnet applications are possible: 
● PROFIBUS DP isochronous 

Compatible extension to the standard PROFIBUS DP: 
– Equidistance (constant synchronous bus cycle clock) enables synchronized time 

slices for master/slave applications. 
– Data exchange broadcast enables slave-to-slave communication. 
Digital drives (e.g. SIMODRIVE 611U, MICROMASTER 4xx, SINAMICS) can be 
connected via PROFIBUS DP. 
In order to be able to operate the SIMOTION device with two isochronous 
PROFIBUS DP subnets, isochronous mode and the same bus cycle must be set. The 
cycle clock of the subnet of the second PROFIBUS interface is synchronized to the cycle 
clock of the subnet of the first PROFIBUS interface. 
If the bus cycle does not agree, the second PROFIBUS interface of the SIMOTION 
device will be operated as a PROFIBUS DP subnet. 

● PROFIBUS DP (MPI) 
Standard PROFIBUS DP with DP-V0 and optional DP-V1 or DP-V2 functionality. 
– For the connection of distributed I/Os 
– For connection to a higher-level automation system 
– For the connection of HMI devices 
– For connection to the SCOUT engineering system 
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2.1.5 Ethernet communication 
SIMOTION devices can also be connected to a PG/PC via Industrial Ethernet. Industrial 
Ethernet is a communication network with a transmission rate of 100 Mbit/s. For additional 
information, refer to the SIMATIC NET, Industrial Twisted Pair and Fiber Optic Networks 
manual. For the order number, refer to References.  
Examples for the use of Industrial Ethernet: 
● For the connection of HMI devices 
● For connection to the SCOUT engineering system 
● For communication via UDP (User Datagram Protocol) 
● TCP/IP 
● IT DIAG 

2.1.6 Communication via PROFINET 
SIMOTION devices can be connected to a PROFINET subnet via interface modules. With 
PROFINET IO IRT/RT, IT services can be performed in parallel to realtime communication 
via an Ethernet cable. The PROFINET modules CBE20, CBE30 and MCI-PN-BOARD are 
available. These PROFINET modules support the parallel operation of:  
● IRT (isochronous realtime Ethernet) 
● RT (realtime Ethernet) 
● TCP/IP, UDP, http . . . (standard Ethernet services) 
● For mixed operation of IRT and RT it has to be observed that the IRT-compatible devices 

must form an IRT domain, i.e. there must not be any non-IRT devices on the data 
transmission link between the IRT devices. 

Additional references 
Please refer to the following documents on this subject 
● SIMOTION D4x5 Commissioning and Hardware Installation Manual 
● SIMOTION D410 Commissioning Manual 
● Commissioning and Hardware Installation Manual SIMOTION P350 and Panel Fronts 
● Operating Instructions SIMOTION C2xx 
● SIMOTION Communication, System Manual 
and the online help. 
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2.2 System requirements for SCOUT and SCOUT Standalone 

Minimum requirements of the system 

Table 2-2 System requirements for SIMOTION SCOUT and SCOUT Standalone 

 Minimum requirement 
Programming device or PC • Processor: Intel Pentium III or compatible,  

1 GHz (Windows XP) 
• 512 MB RAM 
• Screen resolution: 1024 x 768 pixels 
• 16-bit color depth 
• * main memory with at least 1 GB is recommended 

If you process more comprehensive SIMOTION projects 
with several modules, you should use a programming 
unit or PC with the state-of-the-art performance. 

• For the installation of WinCC flexible (ES) 
Pentium IV 2.5 GHz / 1024 MB RAM (Windows XP) 

• One of the following cards must be used as software 
access point (CP5511, etc.): 
– A CP5611 PROFIBUS card for a standard PC 
– An integrated PROFIBUS card for a programming 

device or 
– An Ethernet connection 

Operating system • Microsoft Windows XP Professional  
Service Pack 2 

Software required for 
SIMOTION SCOUT 

• Microsoft Internet Explorer Version 6.0 
• SIMATIC STEP 7 Version 5.4 SP1  

(not PROFINET) 
• For PROFINET connection SIMATIC STEP 7  

Version 5.4 SP2 
Software required for 
SIMOTION SCOUT Standalone 

• Microsoft Internet Explorer Version 6.0 

 
 

 Note 
Simultaneous operation of SIMOTION SCOUT, Starter and SIMATIC S7-Technology on one 
PC is not intended and is not possible. 
SIMATIC S7-Technology is integrated in SIMOTION SCOUT V4.0 and higher. 
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2.3 To install the software 

2.3.1 Installing SIMOTION SCOUT 

Requirements: 
● SIMATIC STEP 7 is installed. 
● You are logged on to the operating system with administrator rights. 

 

  Note 
Read the readme file and important information on the Add-On CD supplied with SCOUT.

To install SIMOTION SCOUT 
1. Insert the CD with SIMOTION SCOUT into the CD-ROM drive. 
2. Start Windows Explorer and select the CD-ROM drive. 
3. Open the ScoutSA_V41/CD1 directory. 
4. Double-click Setup.exe. 
5. Now follow the instructions in the installation program. 

The installation program prompts you to insert the authorization diskette into the diskette 
drive. You can install the authorization during this setup. Or install the authorization after 
the installation of SIMOTION SCOUT with the Automation License Manager.  
Information on this can be found in the section "To install the authorization". 

6. If a restart of the PC is required during the installation, carry this out. 
After the restart of the operating system, log on at least as main user. 

7. After the installation:  
Restart the PC and log on at least as main user. 

All users who are logged on as main user are now able to start and operate 
SIMOTION SCOUT. 

 

 Note 
Simultaneous operation of SIMOTION SCOUT, STARTER and SIMATIC S7-Technology on 
one PC is not intended and is not possible. STARTER is part of Drive ES Basic. 
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Language setting of the SIMOTION SCOUT 
SIMOTION SCOUT uses the language default setting in the SIMATIC Manager. Make 
changes to this setting in the SIMATIC Manager in the Options > Settings... > Language 
menu. 
German, English, French and Italian languages are currently available in SIMOTION 
SCOUT. If a different language is set in the SIMATIC Manager, SIMOTION SCOUT uses the 
English setting. 

 

 Note 
Only those languages installed in STEP 7 are available. 

 

2.3.2 Installing SIMOTION SCOUT Standalone 

Prerequisite 
● No SIMATIC STEP7 may be installed for SIMOTION SCOUT Standalone! 
● You are logged on to the operating system with administrator rights. 

 

  Note 
Read the readme file and important information on the Add-On CD supplied with SCOUT.

To install SIMOTION SCOUT Standalone  
1. Insert Disk1 with SIMOTION SCOUT Standalone into the CD-ROM drive. 
2. Start Windows Explorer and select the CD-ROM drive. 
3. Open the SCOUT_V41/Disk1 directory. 
4. Double-click Setup.exe. 
5. Now follow the instructions in the installation program. 

The installation program prompts you to insert the authorization diskette into the diskette 
drive. You can install the authorization during this setup. Or install the authorization after 
the installation of SIMOTION SCOUT with the Automation License Manager. Information 
on this can be found in the section "To install the authorization". 

6. A restart of the PC is required during the installation, carry this out. You are requested to 
insert CD"/". 
After the restart of the operating system, log on at least as main user. 

7. After the installation:  
Restart the PC and log on at least as main user. 

All users who are logged on as main user are now able to start and operate 
SIMOTION SCOUT. 
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2.4 To install the authorization 

Installing the authorization for SIMOTION SCOUT 
Along with the product CD, you will be supplied with an authorization disk for the use of 
SIMOTION SCOUT. It contains the license key for the engineering system SIMOTION 
SCOUT.  

To install the authorization for SIMOTION SCOUT 
1. Insert the authorization disk with the license key into the disk drive. 
2. Start the Automation License Manager: 

– via the start menu Start > SIMATIC > License Management > Automation License 
Manager or 

– double-click the Automation License Manager icon 
3. Click Drive A. The license key is displayed in the right pane. 
4. Mark the license key and drag this with drag-and-drop to the target drive. 
5. Exit the Automation License Manager. 
6. Remove the disk from the disk drive. 

 

  Note 
Notes on the operation of the Automation License Manager and the transfer of the license
key can be found in the online help of the Automation License Manager. 

To install the authorization for SIMOTION SCOUT Standalone  
Install the authorization for SIMOTION SCOUT Standalone as described in the Installing 
authorization for SIMOTION SCOUT section.  

To upgrade the authorization for SIMOTION SCOUT 
1. Insert the authorization disk with the license key into the disk drive.  
2. Start the Automation License Manager. 

– Via the start menu Start > SIMATIC > License Management > Automation License 
Manager or 

– Double-click the Automation License Manager icon 
3. Select the existing license key on the hard disk. 
4. Click License Key -> Upgrade in the menu bar. 

The previously selected license key is upgraded to the newer version. 
5. Exit the Automation License Manager. 
6. Remove the disk from the disk drive. 
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2.5 Saving and moving the license key 

Saving and moving the license key 
You can transfer the license key to a removable disk. This is useful when you want to save 
the license key when reinstalling a PC or when you want to use it on another PC. A copy of 
the license key is not created during this operation, it is moved. 

2.6 To uninstall the software 

Prerequisite:  
You are logged on to the operating system with administrator rights. 

 

 Note 
Note that the SIMATIC STEP7 must be uninstalled separately. 

 

To uninstall SIMOTION SCOUT from the hard disk 
1. Open the system control via Start > Settings > System control. 
2. Double-click Software. 
3. Select SIMOTION SCOUT x.x and click Change/Remove or Add/Remove. Follow the 

instructions. 
4. Once the above software has been uninstalled, restart the computer. 

Uninstalling SIMOTION SCOUT Standalone 
Uninstall SIMOTION SCOUT Standalone as described in the Uninstalling SIMOTION 
SCOUT section. 

2.7 Software upgrade 
 

 Note 
Install a SIMOTION SCOUT upgrade as described in the To install the software section.  
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Functions 3
3.1 Getting to know the workbench 

Additional references 
Please refer to the following documents on this subject 
● SIMOTION Motion Control, Basic Functions, Function Manual 
● SIMOTION Motion Control, TO axis, Function Manual 
● SIMOTION Motion Control, TO followingObject, TO cam, Function Manual 
● SIMOTION Motion Control, Supplementary Technology Functions, Function Manual 
● SIMOTION Motion Control Output Cams and Measuring Inputs, Function Manual 
● SIMOTION Motion Control, TO Track Interpolation, Function Manual 
and the SIMOTION SCOUT online help. 

 

 Note 
We recommend that you run through Getting Started with SIMOTION SCOUT in the online 
help. This is a series of guided steps which teaches you how to work with SIMOTION 
SCOUT. For example, how to create, compile and save a project, create a SIMOTION 
device, add and configure a technology object and create a program.  
When you have worked through all these steps, you will be able to create more complex 
projects. 

 
 Note 

It is not recommended that you open one SIMOTION SCOUT project twice. This application 
case can result in malfunctions and is not supported by SIMOTION SCOUT. If you want to 
open two different projects, you must open SIMOTION SCOUT twice. 
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The SIMOTION workbench 
The SCOUT workbench is the common framework for all other tools of the engineering 
system. The workbench is thus the navigation center for the individual engineering steps. It 
is used to create and manage SIMOTION projects and provides a uniform and integrated 
view of all data and programs.  
The SCOUT workbench offers a basic display split into three views: 
● Project navigator (left Workbench area) 

The project navigator shows the technical tree structure of the project. 
● Working area (right-hand area of the workbench) 

All editing tools of the engineering system, e.g. parameterization dialog boxes, program 
editors etc. are available in the working area as snap-ins. 
A snap-in is a program that is automatically integrated in the working area of the 
SIMOTION SCOUT workbench. Snap-ins provide functions for the editing of 
SIMOTION SCOUT projects. Snap-ins are displayed in the working area of the 
workbench as working windows. Several snap-ins can be opened in order to be able to 
work in these. The opened snap-ins are displayed as tabs in the working area. The active 
snap-in is visible in the foreground. Examples are:  
– Program editors: 
– Wizards for the configuration of technology objects 
– Device diagnostics 
– Drive navigator 

● Detail view (lower area of the workbench) 
The detail view displays data and messages that vary according to the situation. 
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Figure 3-1 Workbench view 
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Workbench elements 
The elements of the Workbench are:  
● Menu bar: 

You call the functions of SIMOTION SCOUT via the menus in the menu bar.  
● Toolbars: 

Frequently used menu commands are also available in toolbars, which can be activated 
or deactivated as required. These provide quick access to the functions. The toolbars can 
be undocked from the top and relocated to a different position (right, left, lower border or 
as a window).  

● Project navigator: 
The project navigator provides an overview of the entire project. All defined elements, 
such as devices, drives, axes, etc., are displayed here in a tree structure.  

● Working area: 
The task-specific windows are displayed in the working area. In these windows, you can 
perform the configuration with wizards for the axis configuration and drive configuration. 
You also create programs in the working area. Further information about the active 
window in the working area is provided in the detail view.  

● Detail view 
More detailed information about the element selected (marked) in the project navigator or 
the active window in the working area is displayed in the detail view. For example, 
variables of a program, system variables of a technology object or logs during the 
compilation of program sources.  
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3.2 Menu structure 

3.2.1 Main menus 
The SIMOTION SCOUT menus are divided into different main menus.  
● Main menus that are primarily used to control the workbench or a project are always 

displayed. These main menus are also called static menus. 
● In addition, the Edit and Insert  main menus are continually displayed if a project has 

been loaded. 
● The main menu in the second position, between Project and Edit, is a dynamic menu.  

Each snap-in supplies its own specific main menu to be displayed in this position. Always 
the main menu that has been selected in the project navigator and therefore active in the 
working area is displayed.  
In addition, each snap-in can incorporate its own menu items in the static main menus, 
primarily in the Edit and Insert main menus. 

Table 3-1 Structure of the menu bar 

Menu Comment 
project Static menu, always visible 
(Dynamic menu) See Dynamic menus table 
Edit Static menu, visible only when project has been loaded 
Insert Static menu, visible only when project has been loaded 
Target system Static menu, always visible 
View Static menu, always visible 
Options Static menu, always visible 
Window Static menu, always visible 
Help Static menu, always visible 

 

Table 3-2 Dynamic menus 

Dynamic menu Comment 
Axis 
Output cam 
Measuring input 
Synchronous operation 
Cam 
External encoder 
Sensor 
Controller object 
Drive 

Visible only when a project has been loaded and the associated 
snap-in is active in the working area. 
They appear in the menu bar in the second position between 
Project and Edit. 



Functions  
3.2 Menu structure 

 SIMOTION SCOUT 
40 Configuration Manual, 03/2007 Edition 

Dynamic menu Comment 
Fixed gear 
Formula object 
Addition object 
Drive control panel 
MCC unit 
MCC chart 
ST source file 
LAD/FBD source 
LAD/FBD program 
Trace 

 

3.2.2 Keyboard action and shortcuts 
 

 Note 
There are various keyboard assignments and shortcuts for the menu items to facilitate your 
work in SIMOTION SCOUT. 

 
The following table provides an overview of the keyboard assignments and shortcuts that 
you can use for SIMOTION SCOUT.  

Table 3-3 Keyboard action 

Keyboard action / shortcuts Meaning 
Workbench: Change window... 
ALT+0 Project navigator 
ALT+1 Working area 
ALT+2 Detail view 
CTRL+F6 Next window in the working area 
CTRL+F11 Minimize/maximize working area in relation to the whole 

desktop 
CTRL+F12 Minimize/maximize detail view in relation to the whole desktop 

 
 

Project navigator 
Left mouse button Selects the tree object at the cursor position; 

detail view displays the associated details 
Double-click with left mouse button Selects the tree object at the cursor position; 

detail view displays the associated details; 
corresponding snap-in is opened 
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Project navigator 
Right mouse button Selects the tree object at the cursor position; 

detail view displays the associated details; 
context menu is opened 

UP/DOWN arrow keys Selects the tree object at the cursor position 
"Return" Snap-in for the selected tree object opens 
"Context menu key" Context menu for the selected tree object opens 

 

3.2.3 Menu items 
You can use the shortcuts listed in the table to call the menu items available in 
SIMOTION SCOUT.  

Table 3-4 Menu items in SIMOTION SCOUT 

Shortcuts Menu item Reaction 
Project... 
CTRL+N New Creates a new project 
CTRL+O Open Opens a project 
Ctrl+S Save Saves a project 
CTRL+ALT+K Check consistency Checks project consistency 
CTRL+P Print Prints the selected window 
ALT+F4 Exit Exits the SIMOTION SCOUT program 

 
 

Shortcuts Menu item Reaction 
Edit... 
Ctrl+Z Undo Undoes the last action 
Ctrl+Y Redo Redoes the last action 
Ctrl+X Cut Cuts the selection 
Ctrl+C Copy Copies the selection 
Ctrl+V Paste Inserts the clipboard contents 
Del Delete Deletes the selection 
F2 Rename Renames the selected tree object 
ALT+Enter Object properties Displays the properties of an object in the 

project tree 
CTRL+ALT+O Open object Opens a new object of the selected tree object 
Ctrl+A Select all Selects the entire contents in the ST and MCC 

snap-ins 

 
 

CTRL+F Find Opens the Find window 
CTRL+SHIFT+F Searching in the project Opens the Find window 



Functions  
3.2 Menu structure 

 SIMOTION SCOUT 
42 Configuration Manual, 03/2007 Edition 

 
 

CTRL+H Replace Opens the Replace window 
CTRL+J Display next position  

 
 

Shortcuts Menu item Reaction 
Target system... 
CTRL+L Download / target device Downloads to individual target device 
CTRL+D 
Only possible in online 
mode 

Device diagnostics Opens device diagnostics 

CTRL+I 
Only possible in online 
mode 

Control operating mode Opens the dialog box for control of the 
operating mode 

 
 

Shortcuts Menu item Reaction 
View... 
CTRL+F11 Maximize working area Maximizes and minimizes the view of the 

working area 
CTRL+F12 Maximize detail view Maximizes and minimizes the view of the detail 

view 
CTRL+Num+ 
(Plus key on the numeric 
keypad) 

Zoom in Magnifies the diagram in MCC 

CTRL+Num- 
(Minus key on the 
numeric keypad) 

Zoom out Reduces the diagram in MCC 

F5 Refresh Refreshes the view 

 
 

Shortcuts Menu item Reaction 
Options... 
CTRL+ALT+E Settings Opens the Properties window 

 
 

Shortcuts Menu item Reaction 
Window... 
CTRL+SHIFT+F5 Arrange cascading 
CTRL+SHIFT+F2 Arrange horizontally 
CTRL+SHIFT+F3 Arrange vertically 

Arranges the opened windows in the working 
area 
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Shortcuts Menu item Reaction 
Snap-in menu... 
CTRL+F4 Close Closes the selected window 
CTRL+B Accept and compile Compiles the active object 
CTRL+E Expert list Opens the expert list for the current technology 

object 

 
 

Shortcuts Menu item Reaction 
ST source file 
F4 Breakpoints/Active Debug 
CTRL+F7 Program status On/Off Switches monitoring on/off 

 
 

Shortcuts Menu item Reaction 
MCC 
CTRL+F4 Close Closes the MCC unit 
ALT+Enter Properties Opens the MCC Unit Properties window 
CTRL+R Insert MCC chart Insert a new MCC chart 
CTRL+F7 Program status Switches monitoring on/off 
CTRL+F8 Monitor  
CTRL+F9 Single-step  
CTRL+F10 Next step  
Return – Opens the MCC configuration dialog 
Arrow keys – Changes within the tab 

 
 

Shortcuts Menu item Reaction 
LAD/FBD (source or program) 
CTRL+F4 Close Closes the MCC unit 
ALT+Enter Properties Opens the MCC Unit Properties window 
CTRL+R LAD/FBD source: Insert 

LAD/FBD program 
LAD/FBD program:  
Insert network 

Inserts a new LAD/FBD program 

CTRL+L Jump label On/Off Switches jump labels on and off 
CTRL+SHIFT+K Display/comment On/Off Switches comments on and off 
CTRL+SHIFT+B All box parameters Displays all box parameters 
CTRL+T Symbol check and type 

update 
Performs symbol check and type update 

CTRL+F7 Program status Switches monitoring on/off 
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Shortcuts Menu item Reaction 
LAD/FBD (source or program) 
F2 for LAD 
 
F2 for FBD 

Insert element / Insert 
make 
contact element / AND 
box 

Inserts a make contact 
 
Inserts an AND box 

F3 for LAD 
 
F3 for FBD 

Insert element / Insert 
break 
contact element / OR 
box 

Inserts a break contact 
 
Inserts an OR box 

F7 for LAD 
 
F7 for FBD 

Add element/Add coil 
Add element/Assignment

Adds a coil 
 
Adds an assignment 

F8 for LAD 
 
 
F8 for FBD 

Insert element / Insert 
Open branch 
element / Insert binary 
input 

Inserts an Open branch 
 
 
Inserts a binary input 

F9 for LAD 
 
 
F9 for FBD 

Insert element / Insert 
Close branch 
element / Invert binary 
input 

Inserts a Close branch 
 
 
Inverts the binary input 

ALT+F9 Insert element / empty 
box 

 

Ctrl + 3 
Ctrl + 1 

Switch to FBD 
Switch to LAD 

Switches the display 

 
 

Shortcuts Menu item Reaction 
Help... 
SHIFT+F1 Context-sensitive help Opens the online help for the TOs axis, 

measuringInput, outputCam, externalEncoder 
and followingObject 

 
 

Shortcuts Menu item Reaction 
Hardware configuration... 
CTRL+U 
(In HW Config) 

Address overview Opens the Address Overview window 

F4 Optimize layout  

 
 

Shortcuts Menu item Reaction 
Drive control panel 
F8 Enable (bit 1 to bit 6) - 

PC 
Enables or disables controller 
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3.2.4 Using context menus 
The tree elements of the project navigator have context menus. These provide quick access 
to all major functions enabled for this tree element.  
To call up a function for the tree element via context menus, proceed as follows: 
1. Left-click the relevant tree element in the project navigator. 
2. Right-click. 
3. Left-click the appropriate menu item. 

 
Figure 3-2 Example of a context menu 

3.3 Project navigator 

3.3.1 Using the project navigator 

The project navigator in the SIMOTION SCOUT workbench 
As standard, the project navigator has two tabs, the Project and Command library tabs. 
The Project tab displays the entire project structure and is used for managing elements 
within the projects. 
The commands and functions required for the programming are displayed in the Command 
library tab. You can search in the command library or set filters. You can use commands and 
functions in the ST, LAD/FBD and MCC programming languages, e.g. for the creation of 
conditions. In the MCC programming language, the functions are used, e.g. via the ST zoom 
or the system function call command.  
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3.3.2 Creating elements 

Elements in SIMOTION SCOUT 
There are two different ways to insert elements in the project navigator tree:  

Inserting hardware 
Integrate hardware using: 
● SIMOTION device element: Create new device 
Alternatively, you can also call up the Insert > Hardware menu. 
● Drive element: Insert single drive unit 

 

  Note 
You can insert a standalone drive (e.g. SINAMICS S120) with the Insert single drive unit 
element in the project navigator. It is commissioned using wizards in the working area of 
the workbench that contains the Starter functionality.  

Elements within a SIMOTION device 
Create the following elements within a SIMOTION device directly in the project navigator: 
● Technology objects, e.g.: 

Axes, external encoders, cams, measuring inputs, output cams, following objects, 
temperature channels, track objects 

● Programs 
Other elements are created automatically, e.g. 
● When creating a project: 

– Insert monitoring function / watch table 
– Insert libraries/library 

● When inserting a SIMOTION device: 
– AXES, EXTERNAL ENCODERS, CAMS, PROGRAMS, TECHNOLOGY folders 
– I/O, EXECUTION SYSTEM, GLOBAL DEVICE VARIABLES elements 

● When creating an axis: 
– MEASURING INPUTS, OUTPUT CAMS folders 
– Access to the configuration views 

● Additionally when creating a following axis: 
– Synchronous operation element 
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Displaying the station level of a SIMOTION device 
The function provides a better transparency in large SIMOTION SCOUT projects. A project 
with several SIMOTION devices and a large number of drives can be displayed in a 
structure. The assignment in station levels, as is well known from SIMATIC STEP7, is used. 

 

 Note 
Optionally, the associated SIMATIC station of the SIMOTION device in the project navigator 
can be displayed. In this way, all drive units that are assigned to a SIMATIC station are also 
displayed in this structure. 

 
Proceed as follows to activate or deactivate this function:  
1. In the SIMOTION SCOUT, click the Options > Settings function. 
2. Click the Workbench tab. 
3. Activate/deactivate the Insert station level. 

When the function is activated, all drive units that belong to a STEP7 station are also 
displayed below this station. 
When the function is deactivated, all drive units are displayed below the project. 

4. Click OK to confirm the change. 

Opening HW Config of a SIMOTION device 
To call up the hardware configuration of a previously inserted SIMOTION device:  
● Select the required SIMOTION device in the project navigator and select Insert > 

Hardware in the menu, or 
● In the project navigator, double-click the SIMOTION device whose hardware 

configuration you wish to open or 
● Select the desired SIMOTION device in the project navigator, open the shortcut menu 

and click Open HW configuration. 

Insert single drive 
To open the Insert single drive element (e.g. MM4):  
● In the project navigator, double-click Insert single drive unit. 

Inserting elements within a SIMOTION device 
To insert technology objects, source files, or watch tables: 
1. Open the SIMOTION device under which the element is to be created. 
2. Select the relevant folder (e.g. AXES, PROGRAMS). 
3. Select the desired function, e.g.: 

– Insert > Technology object > ... menu or 
– Insert > Program > ... menu or 
– Insert > Watch table menu 
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3.3.3 Changing properties of the elements 
You can change the properties of various elements as follows:  

 

CAUTION  
Changing a name can have far-reaching consequences. References to the axis, particularly 
in programs, are lost. This can cause runtime errors in the program. Make sure that you 
also change all name references. 

 
1. In the project navigator, select the element to be edited, e.g. a specific axis or a specific 

program. 
2. Select the menu: Edit > Object properties. 

 

  Note 
You define the hardware properties in the hardware configuration. 

To rename an element: 
1. Select the element you wish to rename in the project navigator. 
2. Open the shortcut menu and select Rename. 
3. Confirm the warning message. 
4. Enter a new name and confirm the input by pressing the Enter key. 

3.3.4 Wizards for configuration support 
Wizards are provided to assist you in configuring axes and external encoders. The wizards 
guide you step-by-step through the configuration. Parameter interdependencies are taken 
into account. 

 
Figure 3-3 Axis configuration wizard - window for drive assignment 



 Functions 
 3.4 Using the working area 

SIMOTION SCOUT 
Configuration Manual, 03/2007 Edition 49 

 

3.4 Using the working area 

 
The workbench displays all of the snap-in working windows in the working area. Each snap-
in provides its own working window. You can open multiple instances of these windows. You 
can, for example, open several programs at the same time for editing. The online help 
provides additional information.  

Table 3-5 Active functions in the working area of the workbench depending on the project mode 
(offline/online) 

Function in project navigator Function in working area 
offline mode 
(Example) 

Function in working area 
online mode 
(Example) 

Programs  
(MCC, ST, LAD/FBD) 

Create program Monitor program 

Execution system Assign program – 
Technology objects 
(TO configuration) 

Create and configure TO 
element 

Change configuration data 
during RUN 

Cam editor  
(CamEdit) 

Create cam Change cam 

Trace Load and evaluate old 
recordings 

Create current recordings 

Axis control panel – Traverse axes during 
commissioning 

Using windows in the working area 
You can change the size of the windows in the working area:  
Click on the edge of the window, hold down the left mouse button, and drag the window to 
the required size.  
You can maximize or minimize each window using the shortcut CTRL+F11. 
Each window opened in the working area can be accessed via a tab at the bottom edge of 
the working area. To bring a window into the foreground:  
● Click on the relevant tab or 
● Select the appropriate entry in the Window menu. 
To close the window: 
● Configuration dialog boxes: Click Close. 
● Editors for MCC, ST and LAD/FBD: 

Click the X button in the top right-hand corner. 
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3.5 Detail view 

3.5.1 Using the detail view 
When you select an element in the project navigator, the associated detail view will appear in 
the lower area of the workbench.  
Various tabs are available depending on the element selected. The tabs available are 
determined by the project mode (offline/online) and the active snap-ins. 
You can maximize or minimize each tab using the shortcut CTRL+F12. 

Table 3-6 Tabs available for the detail view depending on the project mode (offline/online) and the 
active snap-ins 

 Offline Online 
 Tab 
Workbench (default) Symbol browser (variables)  

Axis overview 
Symbol browser (variables)  
Axis status  
Target system output  
Load to PG  
Diagnostics overview  
Alarms  
Drive control panel (MM4) 

Additionally with  
program editors 

Compiler output  
Generation of  
ST code 

Compiler output  
Generation of  
ST code 

Each tab is opened only once, i.e.: 
● The active tab shows the details of the selected element. 
● The contents of the tab change when you select a different element. 
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3.5.2 Using the symbol browser 

The symbol browser in the detail view. 
The symbol browser is a tab in the detail view. It displays status values of the variables for 
the element selected in the project navigator.  
To activate the symbol browser: 
1. Select an element in the project navigator. 
2. In the detail view, select the Symbol browser tab. 

Continuous display of the symbol browser 
To activate/deactivate the continuous display of the symbol browser:  
Click the symbol at the top right of the the symbol browser (pin). 
The active element is displayed continuously until this function is deactivated. To deactivate 
this function, click the pin again. 

3.6 Adding add-ons to the workbench 

Add-ons in SIMOTION SCOUT 
SIMOTION provides you with the option of enhancing the functionality or accommodating 
customer-specific requirements. You can integrate add-ons. The CamTool add-on is 
currently available. 

 

 Note 
More detailed information about the CamTool add-on is contained in the CamTool 
configuration manual or the associated online help. 

 
Add-ons are added to the workbench and are displayed as fully integrated: 
● Menus and toolbars appear at the appropriate position in the workbench. After installation 

of add-ons, the menus are visible and the toolbars are active. 
● The working windows appear in the working area of the workbench and have tabs. 
● The detail view of the workbench shows details about the currently active add-on. If the 

associated details are distributed over several tabs, you can select the relevant tab and 
place it in the foreground. 
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3.7 Online help 

3.7.1 Structure of the online help 
SIMOTION SCOUT has a comprehensive context-sensitive help. You can find examples for 
the use of the help function in the online help under SIMOTION SCOUT > General > Help.  

 
Figure 3-4 HTML help window 
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3.7.2 Types of online help 
The following types of online help are available: 
● Entire help 
To open the entire help: 
In the menu bar, select Help > Help topics or press key F1. The entire help is displayed. 
● Getting Started 
To open Getting Started: 
In the menu bar, select Help > Getting Started.  
Getting Started is displayed. 
● Help button 
To open the help: 
Click the Help button of the respective dialog box or window.  
The context-sensitive help for the dialog box is opened. 
● Context-sensitive help 
To open the context-sensitive help: 
1. Press the SHIFT+F1 keys or click the button in the toolbar or select Help > Context-

sensitive help in the menu bar.  
The cursor changes to a question mark. 

2. Use the mouse pointer to click on, e.g. dialogs, parameters, input fields, menu items, 
command libraries, expert lists, symbol browsers or objects in the project navigator.  
The context-sensitive help for the selected entry is displayed. 

3.7.3 Searching in the online help 
You can carry out a full-text search throughout the entire help in the Search tab.  
With a full-text search, you have to consider certain points to ensure that the search is 
successful. A simple search according to subject consists of the word or expression that you 
want to find. 
To refine your search, you can use wildcard expressions, nested expressions, Boolean 
operators, similar word hits, the previous result list or subject titles. 
To carry out a full-text search: 
1. In the menu bar, select Help > Help topics or press key F1. The entire help is displayed. 
2. Click the Search tab and enter the search term. You can add Boolean operators by 

clicking the arrow next to the input field. 
 

  Note 
If you enter the term System, this term is sought throughout the entire Help. Only the 
Help pages that contain the word System are found. Compound words, e.g. Systemclock 
are not found. Therefore it is usually more appropriate to search with wildcards if you are 
not searching for a definite term, e.g. *system* returns all the results that contain system.
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3. Click List subjects to start the search. The search returns a maximum of the first 500 hits. 
If you want to sort the subject list, click Title, Position or Order. 

4. Double-click the desired subject to display the Help page. The found terms are 
highlighted on the page. 

 

  Note 
If the terms are not highlighted or you want to switch the highlighting off, click the Options
button and select Activate/deactivate search term highlighting in the menu displayed. 

You can refine a full-text search by using wildcard expressions, nested expressions and 
Boolean operators. You can also only search the last result list, include similar word hits or 
only search the subject titles in the table of contents.  
For very many matches, the sorting using "position" provides a better overview because the 
search results are arranged according to the associated topic. 
You can find more information about this subject in the online help. 

3.7.4 Getting Started in SCOUT 

Contents and settings in Getting Started with SIMOTION SCOUT 
By default, the Getting Started with SIMOTION SCOUT HTML help window appears when 
SIMOTION SCOUT opens. You can deactivate this function.  
The Getting Started provides a brief overview of how you can work with SIMOTION SCOUT. 
A typical example is used to show you the different steps required to create a project as well 
as to introduce the configuration, programming, and diagnostic tools. 
To deactivate the standard setting that automatically opens the HTML Help window when 
you open SIMOTION SCOUT: 
1. In the menu bar, select Options > Settings... 
2. Click the Workbench tab. 
3. Deactivate the checkbox Display "Getting Started" at the start. 
4. Click OK. 
To reopen Getting Started: 
In the menu bar, select Help > Getting Started. 

3.7.5 Error remedy 
If error messages appear in the detail view in the SCOUT workbench, you can call up 
detailed information in the online help. This is possible for technology objects, alarms and 
alarms for drive units and I/O devices. To do this, press SHIFT+F1.  
Otherwise, additional information about the error text can be found using the complete text 
search.  



 Functions 
 3.8 Basic steps 

SIMOTION SCOUT 
Configuration Manual, 03/2007 Edition 55 

3.8 Basic steps 

3.8.1 Overview 
In order that the machine or plant can perform the desired tasks, you must carry out the 
following steps with SIMOTION SCOUT: 
● Create a project: 

The project is the generic term under which you store all of the relevant files. 
● Configure hardware: 

Provide the SIMOTION system with information about the hardware. 
● Configure technology objects (TO): 

Provide the SIMOTION system with information about the technologies used. 
SIMOTION SCOUT provides wizards for comprehensive assistance. 

● Create and test open-loop and closed-loop control programs. 
● Commission and optimize drives and axes. 
● Test the system and utilize the diagnostic options. 
SIMOTION SCOUT provides the workbench to enable you to perform these steps easily and 
efficiently. 

3.8.2 Basic settings of SCOUT 
In SCOUT, you have the possibility of predefining various basic settings via the Options > 
Settings menu. Detailed information on the individual tabs and settings is provided in the 
SIMOTION SCOUT online help. 
1. Open SIMOTION SCOUT. 
2. Click the Options > Settings... menu. 

The Settings window is opened. 
3. Select the desired tab. 
4. Enter the settings. 
5. Click OK. 

3.8.3 SIMOTION SCOUT project 
The project is the highest level in the data management hierarchy. SIMOTION SCOUT 
saves all data which belongs, for example, to a production machine, in the project directory. 
The project is therefore the sum of all data, programs, settings, etc. 
The project encompasses all of the SIMOTION devices, drives, etc., that belong to a 
machine. The axes, external encoders, cams, and programs are assigned hierarchically to 
the respective devices. This hierarchical structure is displayed in the project navigator. 
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3.8.4 Creating a new SCOUT project 
 

 Note 
Further information can be obtained in the "Getting Started with SIMOTION SCOUT" HTML 
help. 

 

To create a new project:  
1. Open SCOUT from the Start menu on the Windows desktop: Start > SIMATIC > STEP 7 

> SIMOTION SCOUT. 
Or: 
Double-click the SIMOTION SCOUT icon on your PC desktop. 
SIMOTION SCOUT starts and the workbench appears. 

2. In the workbench menu bar, select Project > New. 
The New Project window opens. 

 

  Note 
SIMOTION SCOUT creates a directory with the selected name. All files relevant to the 
project are stored in this directory. 
Directory names and file names are shortened to 8 characters. If you assign longer 
names, these are displayed in SCOUT. However, these names are only managed with 8 
characters in the Explorer. 
Special characters may not be used. 

 
Figure 3-5 Creating a new project 
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3. Enter the following data in the dialog box: 
– Name:  

Select a name for the project. 
– Storage location (path): 

Select the location (path) where the new project is to be stored. 
4. Confirm with OK. 
An icon with the full name of the project appears in the project navigator. The associated tree 
is expanded. 

 
Figure 3-6 Workbench with new project 

The following entries are located beneath the project name in the project navigator: 
● Create new device element. Double-click on this symbol to select the required SIMOTION 

device, create and configure a new subnet and insert the new device in the HW Config 
program. 

● Insert single drive unit element. Double-click on this symbol to insert and commission a 
stand-alone drive (e.g. MM4 Basic). Although this drive cannot be linked to or configured 
in the master system of the project using a PROFIBUS DP connection, it appears in the 
project navigator within the project. 

● Folder labeled MONITORING 
● Folder labeled LIBRARIES 
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3.8.5 Opening an existing project 

To open a project saved on the hard disk of the PC:  
You can open projects that SIMOTION SCOUT has stored locally (e.g. on the hard disk). 
1. Select the Project > Open menu. 
2. Select the User projects tab. 
3. If the project you require is not saved under the default path, click Browse... and follow 

the instructions on the screen. 
4. Select the required project. 
5. Confirm with OK. 
If you want to open a project that was created in an older version, a message appears 
asking whether the project should be converted to the newer version. This function is 
available since SIMOTION SCOUT Version V3.1. 

 

 Note 
The "Save as" function saves all previously made changes in either a new or in an existing 
project. 
This means when you change an existing project and save with a different name, you must 
do this before you make any changes in the existing project. 

 
 

 
Figure 3-7 Opening a project stored on the hard disk 
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 Note 
The workbench displays one project at a time. 
If you wish to display two projects at the same time, e.g. in order to copy/paste parts of a 
project, start SIMOTION SCOUT a second time. SIMOTION SCOUT can only be opened 
twice. 

 

3.8.6 Using program editors 

Editors in SIMOTION SCOUT 
Three editors are available for creating programs:  
● Graphics-based MCC editor for creating Motion Control charts. You program by arranging 

symbolic program commands similar to a flow diagram and assigning parameters to 
these commands. 

● Text-based editor for creating ST source files. ST is a text-based programming language 
in compliance with IEC 1131-3, expanded to include motion commands (system functions 
for the technology objects). An ST source file can encompass several programs. 

● Graphics-based editor for creating ladder diagrams and function block diagrams . 
The syntax of the statements in LAD corresponds to a schematic circuit diagram. LAD 
statements consist of elements and boxes, which are graphically connected to networks. 
The LAD operations work according to the rules of Boolean logic. 
FBD uses the logic boxes familiar from Boolean algebra to map logic. You can represent 
complex functions (e.g. mathematical functions) directly in connection with the logical 
boxes. 
FBD provides all the elements required for the creation of a complete user program. FBD 
features a powerful command set. This includes the various basic operations with a 
comprehensive range of operands and how to address them. The design of the functions 
and function blocks enables you to structure the FBD program clearly. 

Optional editors 
● CamTool for the easy creation of cams using a graphical editor 
● DCC graphical editor based on CFC. SIMOTION controllers and SINAMICS drives can be 

configured graphically. 
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Additional references 
Please refer to the following documents on this subject 
● SIMOTION MCC (Motion Control Chart), Programming Manual 
● SIMOTION ST (Structured Text), Programming Manual 
● SIMOTION LAD/FBD, Programming Manual 
● Programming and Operating Manual SINAMICS/SIMOTION Editor description DCC 
and the SIMOTION SCOUT online help. 
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Figure 3-8 Program editors 
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3.9 HW Config 

3.9.1 Inserting and configuring a SIMOTION device 
Configure the hardware using the HW Config module. This informs the SIMOTION system 
which hardware is present, e.g.:  
● Type of SIMOTION device 
● Type of the I/O modules 
● Type of the drives 
In addition, you also inform the SIMOTION system which parameters it should use, e.g.: 
● Configuration of the SIMOTION device 
● Configuration of the PROFIBUS 
● Assignment of the hardware to the PROFIBUS 

In this section, you learn how to use the HW Config tool: 
● How to insert objects from the hardware catalog. 
● How to edit objects. 
● How to replace or delete objects. 

3.9.2 Starting HW Config 
HW Config can be started, e.g. to add a drive to the PROFIBUS.  
To start HW Config: 
● Double-click on the appropriate SIMOTION device in the project navigator or 
● Select the appropriate device in the project navigator and confirm your selection in the 

Open HW configuration shortcut menu or 
● Select the appropriate device in the project navigator and select the Insert > Hardware 

menu. 
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3.9.3 The HW Config program 
The HW Config program is displayed as follows: 
● A hardware catalog window 
● A working window that is split into two: 

– In the upper half, you can see the rack or station frame with the CPU previously 
automatically inserted in slot 2 (example for C2xx).  
Insert the objects from the hardware catalog and edit them here. 

– In the lower half, you can see detailed information about the selected objects. 

 
Figure 3-9 HW Config with opened hardware catalog and the CPU previously inserted in the module 

3.9.4 HW Config: Opening the hardware catalog 
You can open the hardware catalog in the following ways:  
● Select the Insert > Insert object menu. 
● Select the View > Catalog menu. 
For additional information, see 
● Insert drives section 
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3.9.5 SIMOTION devices in the hardware catalog 
You can find the SIMOTION devices in the corresponding directories of the 
hardware catalog. 

Table 3-7 SIMOTION device directories in the hardware catalog 

SIMOTION  
device 

SIMATIC station Subdirectory 

C230-2 SIMATIC 300 CPU-300\CPU C2x0\6AU1 230-2AA00-0AA0\V2.1 
CPU-300\CPU C2x0\6AU1 230-2AA00-0AA0\V3.0 
CPU-300\CPU C2x0\6AU1 230-2AA00-0AA0\V3.1 
CPU-300\CPU C2x0\6AU1 230-2AA00-0AA0\V3.2 

C230-2.1 SIMATIC 300 CPU-300\CPU C2x0\6AU1 230-2AA01-0AA0\V3.2 
CPU-300\CPU C2x0\6AU1 230-2AA01-0AA0\V4.0 
CPU-300\CPU C2x0\6AU1 230-2AA01-0AA0\V4.1 

C240 SIMATIC 300 CPU-300\CPU C2x0\6AU1 240-1AA00-0AA0\V4.0 
CPU-300\CPU C2x0\6AU1 240-1AA00-0AA0\V4.1 

P350 SIMATIC PC station SIMOTION P350\6AU1 350-XXXXX-XXX1\V2.1 
SIMOTION P350\6AU1 350-XXXXX-XXX1\V3.0 
SIMOTION P350\6AU1 350-XXXXX-XXX1\V3.1 
SIMOTION P350\6AU1 350-XXXXX-XXX1\V3.2 
SIMOTION P350\6AU1 350-XXXXX-XXX1\V4.0 - V2 box 

P350-3 SIMATIC PC station SIMOTION P350\6AU1 350-XXXXX-XXX2\V4.0 - V3 box 
SIMOTION P350\6AU1 350-XXXXX-XXX2\V4.1 - DP 
SIMOTION P350\6AU1 350-XXXXX-XXX2\V4.1 - DP/PN 
SIMOTION P350\6AU1 350-XXXXX-XXX2\V4.1 - PN 

D410 Drive-based SIMOTION SIMOTION D410\6AU1 410-0AA00-0AA0\V4.1 - SINAMICS S120 V2.5 
(PROFIBUS interface) V4.1 SP1 
SIMOTION D410\6AU1 410-0AB00-0AA0\V4.1 - SINAMICS S120 V2.5 
(PROFIBUS interface) V4.1 SP1 

D425 Drive-based SIMOTION SIMOTION D425\6AU1 425-0AA00-0AA0\ V3.2 SINAMICS S120 V2.2 
SIMOTION D425\6AU1 425-0AA00-0AA0\ V3.2 SINAMICS S120 V2.3 
SIMOTION D425\6AU1 425-0AA00-0AA0\ V4.0 SINAMICS S120 V2.4 
SIMOTION D425\6AU1 425-0AA00-0AA0\ V4.1 SINAMICS S120 V2.5 

D435 Drive-based SIMOTION SIMOTION D435\6AU1 435-0AA00-0AA0\ V3.1 SINAMICS S120 V2.1 
SIMOTION D435\6AU1 435-0AA00-0AA0\ V3.2 SINAMICS S120 V2.2 
SIMOTION D435\6AU1 435-0AA00-0AA1\ V3.2 SINAMICS S120 V2.2 
SIMOTION D435\6AU1 435-0AA00-0AA1\ V3.2 SINAMICS S120 V2.3 
SIMOTION D435\6AU1 435-0AA00-0AA1\ V4.0 SINAMICS S120 V2.4 
SIMOTION D435\6AU1 435-0AA00-0AA1\ V4.1 SINAMICS S120 V2.5 
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SIMOTION  
device 

SIMATIC station Subdirectory 

D445 Drive-based SIMOTION SIMOTION D445\6AU1 445-0AA00-0AA0\ V3.2 SINAMICS S120 V2.2 
SIMOTION D445\6AU1 445-0AA00-0AA0\ V3.2 SINAMICS S120 V2.3 
SIMOTION D445\6AU1 445-0AA00-0AA0\ V4.0 SINAMICS S120 V2.4 
SIMOTION D445\6AU1 445-0AA00-0AA0\ V4.0 SINAMICS SM150 V2.4 
SIMOTION D445\6AU1 445-0AA00-0AA0\ V4.1 SINAMICS S120 V2.5 
SIMOTION D445\6AU1 445-0AA00-0AA0\ V4.1 SINAMICS SM150 V2.5 

The version of the SIMOTION D4xx listed here must not be confused with the version of the 
drive firmware contained in SINAMICS integrated. The SIMOTION D4xx is supplied with a 
specific version of the drive firmware. If you insert a SIMOTION  D4xx into a project, this 
specific version is used as default version and displayed in the "Properties". When the 
SINAMICS integrated firmware is updated, the firmware must first be physically replaced and 
then the drive firmware version changed in the "Properties". 

Add interfaces 
After inserting the SIMOTION device, the Properties - PROFIBUS DP Master Interface 
(R0/S2.1) window appears. Create the PROFIBUS DP subnets and configure the SIMOTION 
device interfaces in this window. 

 

 Note 
The PCI integrated PROFIBUS subnet is created and configured automatically for the 
SIMOTION D4xx. The user may neither configure nor select it! 

 
When the SIMOTION device is inserted into the rack, all interfaces and the PROFIBUS 
subnets that you have created are displayed at the same time. 
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Figure 3-10 Hardware configuration of a D4x5 

Detailed information on the configuration of the SIMOTION device is contained in the 
corresponding documentation for the SIMOTION devices. 

3.9.6 Inserting a SIMOTION device in the rack 

Example: To insert the SIMOTION C230-2.1 in the rack: 
1. Open the SIMATIC 300>CPU-300 > CPU C230-2 > 6AU1 230-2AA01-0AA0 folder in the 

hardware catalog. 
2. Use drag-and-drop to drag the required CPU version to rack slot 2. 

 

  Note 
The slot rule is applied automatically. The SIMOTION C2xx can only be inserted into 
slot 2. 
SIMOTION D4xx can not be added to slot 2, but needs to be fitted to the module holder 
(rack). 
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3.9.7 Changing the SIMOTION device 

Prerequisite 
You will only need to perform this operation if you intend to upgrade a kernel or change a 
platform within the same station type. 

Swapping modules between SIMOTION families 
A module replacement can be made within a device family (SIMOTION C2xx, P350, D4x5 or 
D410 devices). 
Changing between SIMOTION the C2xx, P350, D4x5 and D410 families is only possible 
using an XML export: 
XML Export > Delete device > Create new device > XML Import. 

3.10 Downloading the project 

3.10.1 Approach to project download 
You must reload a project to the target system, if you:  
● have created or changed programs 
● Changed definitions of global variables or symbolic I/O variables 
● Made changes to the execution system 
● Changed technology object configurations 

Checking the project for consistency and compiling the project 
Before you download the project to the target system, the program source files must be 
compiled without error and the consistency ensured.  
1. Select the Project > Save and compile all menu. 

SIMOTION SCOUT compiles all changed source files. 
Further information about saving and compiling the project is contained in the "Save 
and Recompile Everything" section. 

2. Select the Project > Consistency check menu. 
SIMOTION SCOUT checks whether, for example, all technology objects have been 
configured and the source files have been compiled without error. 
If no consistency test is performed, errors in the configuration may possibly be detected 
and reported only after the download. 

If errors occur, their possible causes are displayed by entries in various output tabs in the 
detail view. 
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Detailed information about compilation errors is output for the compilation of single source 
files. Double-clicking the error message in the detail window causes the cursor to jump to the 
error location in the source file. 
Correct the errors, for example, by: 
● Change the configuration of the technology objects 
● Change the programs 
Repeat steps 1. and 2. as often as required until no more errors are displayed. 

Downloading the project to the target system 
The following conditions must be met before the project can be downloaded to the target 
system: 
● All cables must be plugged in and the interfaces configured 
● The project has been checked for consistency (from the menu Project > Check 

consistency) 
● All program sources have been compiled (from the menu Project > Save and compile all) 
● The target systems are in the operating mode STOP 
● The system status is ONLINE (menu: Project > Connect to target system) 
If an error occurs, transfer of data to the target system is aborted. The tab in the detail view 
where the transfer sequence and any errors are logged indicates the possible cause of the 
error. 

 

 Note 
As of SIMOTION SCOUT Version V3.2, a message appears in the diagnostics buffer if a 
power failure occurs during the download: Starting lockout set, after you have switched to 
RUN mode. Go online again and carry out the download once more. 
In earlier versions, this can lead to various faults that cannot be corrected by the system. 
Unexplainable error messages may appear. 
If this happens: 
Go online again and carry out the download once more. 
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3.10.2 Save and recompile all 
Before loading a project into the target system, a consistency check is carried out. The 
project is then saved and compiled. 
SIMOTION SCOUT makes a distinction between two commands, which make a real 
difference when it comes to saving and compiling: 
● Save and compile all 
● Save and recompile all 

Save and compile all 
On this command, the whole project is searched for changes. If a source that has been 
changed is found, this single source is compiled and saved. The delta is therefore only 
compiled once. This command is used in a normal service case. 

Save and recompile all 
In the device, the compiled program (the older version) differs from the compiled program in 
the offline project (new version). The inconsistency will be visualized with a button in the 
online view in the project navigator. 
The save and recompile command is suitable if you are entirely sure that all the old data 
from older SCOUT versions has been removed and should be replaced with new compilation 
results. 

3.10.3 Project "load to file system" 
This function can be used to load into the file system on the hard disk of the PC/PG (as Zip 
file) or directly to the memory card using the card adapter. The loading to the memory card 
can be considered as being a download with subsequent Ram2Rom. This function is very 
useful. for example, for the series commissioning. 

3.10.4 Download 

Automatic CPU STOP to RUN 
By default, the download is performed in STOP. After a successful download, the CPU is 
automatically restored to its previous status. If the CPU is in RUN, the Engineering system 
queries whether the CPU should be stopped. The download is then carried out. After the 
download has been carried out successfully, you are prompted again whether the CPU 
should be restarted. 
For additional information, see 
● Download during RUN section 
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3.10.5 Download during Run 
You can use the CPU download tab from Options > Settings to specify whether the 
downloading is to be possible in RUN mode. 
To do this, activate the "Download" checkbox in the SCOUT settings. 

When is a download possible during RUN? 
Permissible changes in the code part only 
● Execution changes 
● Insert system function and FB instance 
● Also use global variables 
Permissible change in the data declarations 
● A change in the data declaration is possible with temporary variables (volatile variables), 

which are generated and initialized at every call (to the stack). This is for: 
– FC: VAR and VAR_INPUT 
– FB: VAR_TEMP 
– Program: VAR in sequential tasks (tasks such as MotionTasks, UserInterruptTasks 

and FaultTasks, which are executed once and then terminated) and VAR_TEMP in all 
tasks (is always temporary). 

● As soon as data with fixed addresses is changed, a download during RUN is no longer 
possible. 

● Changes to initial values are generally possible. 

References 
More information on this topic is available in: 
● Base Functions Function Manual, Change-optimized Programming section 
● Online Help 
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3.11 Licensing 

3.11.1 Licensing of the runtime components 

3.11.1.1 Overview for the licensing 
Functions can be licensed using the following software options:  
● Motion control technology functions 

The licensing is performed axis-specifically for: 
– POS - position; use of the technology functions for position axis 
– GEAR; use of the technology functions for following axis 
– CAM; use of the technology functions for cam axis 

The GEAR technology function contains the POS technology function, while the CAM 
technology function contains the POS and GEAR technology functions. 
The MultiAxes package permits a simple licensing of the Motion Control technology 
functions. It contains the license for the unlimited use of the CAM technology function on a 
SIMOTION device, e.g. a C230-2 or a D4x5 or a P350. 
● TControl technology function 

The TControl technology package is licensed channel-specifically, in packages of 8 
temperature channels. 

● IT functions, IT-Diag and OPC XML-DA 
The use of these functions is licensed for each SIMOTION device. 

 

  Note 
Another option is to order SIMOTION memory cards (MMC and CF) and  
SIMOTION P350-3 with pre-installed runtime licenses. 
Further important information for the licensing of the runtime software and the ordering 
data can be found in:  
SIMOTION PM10 2005 catalog, Chapter 6, SIMOTION Software. 
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3.11.1.2 Licenses and license key 
Depending on the type and number of runtime components used in the project, licenses 
must be acquired as part of the licensing procedure for SIMOTION. The licenses required for 
a SIMOTION device are assigned to a license key. This license key is stored on the memory 
medium of the SIMOTION device during the licensing procedure.  
There are two ways of ordering the licenses: 
● Preinstalled licenses 

The license key is already stored on the card. 
● Ordered licenses (Certificate of License) 

These licenses must be assigned to the storage medium using the Web-License-
Manager. The determined license key is transferred to the hardware using SCOUT. 

You require the following information to obtain the license key: 
● The serial number of the SIMOTION device memory medium 

You can obtain the serial number from the memory medium or have it displayed online in 
the SIMOTION SCOUT (licensing wizard). 

● The serial number of the CoL (Certificate of License) 
You have this number on paper. 

Table 3-8 The serial number on the SIMOTION hardware assigned to the SIMOTION device 

SIMOTION device Hardware serial number of module 
SIMOTION C2xx SIMOTION Micro Memory card 
SIMOTION P350 SIMOTION IsoPROFIBUS-Board or 

SIMOTION MCI-PN board 
SIMOTION D4xx SIMOTION CompactFlash card 

License keys can be generated separately from the licensing. 
 

 Note 
When the SIMOTION memory card is deleted or formatted, the licensing data is also 
deleted. Archive the licensing data in order to be able to transfer it again to the memory 
medium in such a case. If the data is not backed up, you have to perform the licensing again. 
You can display the entered license key in the Web License Manager. 

 
Additional information is available at:  
"License Key is Protected from being Deleted (as from Kernel V4.1)" section 
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3.11.1.3 Determining licensing requirements 
 

 Note 
Determine your license requirement only after you have completed the configuration! A 
license that has been assigned a license key cannot be withdrawn. 

 
Once you have completed your project configuration with SIMOTION SCOUT and before 
you download it to the target device, you can determine the licenses required for the project. 
You have three options for determining license requirements. Before you begin, the project 
must have been saved and compiled. If you have not yet acquired any licenses, 
underlicensing is displayed.  
Options for determining license requirements are as follows: 
● Offline mode with open project 

The required licenses are displayed. 
● Online mode with open project 

A comparison of the required and actual licenses is displayed. 
● Online mode without project 

The actual licenses of the selected SIMOTION device are displayed. 

Proceed as follows: 
1. Select the SIMOTION device in the project navigator. 
2. Select Licenses in the context menu. 

The required licenses for the project or a comparison of required and actual licenses are 
displayed. 

3. You can close the window with X or continue with Perform licensing.... 
The license check, i.e. the inspection of the license keys, is carried out in the target system. 
Possible responses in the case of underlicensing are described in the Underlicensing 
section. 

 

 Note 
Memory cards can be purchased with integrated runtime licenses, which do not require 
separate licensing. 
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3.11.1.4 Displaying existing licenses of the SIMOTION device 

Displaying via accessible nodes 
You can use the list of Accessible nodes  to determine the specific licenses that have 
already been assigned to the SIMOTION device. You can access the data of the SIMOTION 
device directly.  

 

 Note 
This step is not necessary if the required and actual licenses are displayed within a project. 

 

Requirements: 
● SIMOTION SCOUT is running 
● SIMOTION SCOUT is in online mode 
● No projects are open 

Proceed as follows: 
1. Select the Project > Accessible nodes menu.  

The list of accessible nodes is displayed in the working area. 
2. Select the relevant SIMOTION device. 
3. Select Licenses in the shortcut menu. 

The Licenses dialog box appears, showing the actual licenses for the selected 
SIMOTION device. 

4. You can close the window with X or continue with Perform licensing.... 
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3.11.1.5 Performing the licensing 

To perform the licensing: 
Once you have determined your actual license requirements, you can purchase the licenses 
and then generate the required license key.  

Requirements: 
● Configuration has been completed 
● The project has been saved and compiled 
● The required licenses have been determined 
● The license key has been determined or the serial numbers of the memory medium and 

the CoL are available 
● SIMOTION SCOUT is in online mode 

Proceed as follows: 
1. Select the relevant SIMOTION device in SIMOTION SCOUT. 
2. Open the context menu and click Licensing. 
3. In the Licenses dialog box, click Perform licensing...  

If the Use wizard checkbox is activated, a wizard guides you through the licensing 
procedure. 
If the checkbox is not activated, the window for the expert licensing is opened. You can 
enter the license key there without running through the wizard. 
If you have not yet generated the license key, the wizard gives you the option to switch to 
the Web tool to generate one. Then switch back to the wizard. 

4. If you have an online connection, continue with item 5.  
Otherwise, you can establish an online connection with Online in the Step 2 of 3 window. 

5. Enter the license key in the Step 3 of 3 window. 
6. Click Finish. 

The wizard is closed. Licensing is complete. 
 

  Note 
The license key is written to the retentive memory when the project data is transferred to 
the target system. 
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3.11.2 Changing the license key 

Reasons for changing the license key 
The license key is influenced by changes to the project such as expanding the configuration. 
This is why underlicensing is displayed when the project is downloaded and the SF LED 
flashes.  
After you have redetermined the actual requirement and purchased the necessary licenses, 
generate the license key again. Now replace the license key already entered with the newly 
generated one. 

 

 Note 
Transition from Version V3.0 to V3.1, V3.2.1 or V4.0 
In a project as of Version V3.1, the license key is stored in a different location than in a 
Version 3.0 project. You must re-enter the license key in order for Version V3.0 licenses to 
be recognized in a project as of V3.1. 

 

3.11.3 License key is protected from being deleted (as from Kernel V4.1) 
The license key is stored in the "KEYS" directory on the SIMOTION Memory Card. 
When the controller starts up for the first time, the license key will be saved in the boot sector 
of the card and from this time is protected from being lost. 
Operator actions cannot delete the license key in the boot sector. Also not by formatting the 
card or with the "Write boot sector..." function. 
If the license key is no longer present on the card, it will be written again during the startup 
from the boot sector into the "KEYS" directory. This means that the system will repair any 
deletion on the "Key" file. 
The license key can be changed at any time, for example, by relicensing. At the next startup, 
the license key will be saved again in the boot sector. 

3.11.4 Licensing during hardware replacement 
For the replacement of licensed SIMOTION components (MMC, CF, IsoPROFIBUS board or 
PN board), the associated license key must be assigned to the new SIMOTION component. 
In this case, contact the Customer Support for assistance.  
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3.11.5 Underlicensing 
If SIMOTION SCOUT detects the presence of underlicensing during license verification, an 
entry is made in the diagnostics buffer. The verification is repeated every hour, and an entry 
is made in the diagnostics buffer each time underlicensing is detected.  
The following information can be read from the diagnostics buffer entry: 
● Number of required licenses 
● Number of actual licenses 
● Operating mode 
As an additional warning signal, the SF LED flashes as long as underlicensing is present on 
the system. Underlicensing will only be displayed if no acknowledgeable technological event 
is present, as it is also indicated via this SF LED. 

3.12 Searching in the project 
In the open project, you can search all the project data for variables or any text. 
If you select a variable search, you can also search within the ST sources. All global and 
local variables at the declaration and use points are recognized.  
Open the dialog by going to menu item Edit > Search in project or using the shortcut Ctrl + 
Shift + F. 
The results are displayed in the search results tab of the detail view. 

 
Figure 3-11 Searching in the project 
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Searching in CPU/Libraries only 
If the "Search only in CPU/Library" checkbox is ticked, a selection list of all the CPUs and 
user-defined libraries in the project appears. You can select one to search in this 
CPU/Library only. 
● For more information regarding this topic, see the online help. 

3.13 Replacing in the project 
The "Replace in project" function is based on the "Search in project" function.  
To open it, go to the menu option Edit > Replace in Project. 
When you carry out a replacement, both the results found and the replacement term are 
displayed in the "Search result" tab of the "detail view". The text can be edited again here. 
Use the Replace button to replace all search results selected using the checkbox. 

Boundary conditions: 
● Only text can be entered. 
● Only texts in programs and script files are replaced (no variables in the IO or device 

global variable list (declaration tables)). 
● Replaced texts cannot be undone. 
●  
● More information on this topic is available in: 
● Online help. 

3.14 Changing a SIMOTION device 

3.14.1 General information 
In order that you can upgrade or replace a SIMOTION device and subsequently perform a 
TP upgrade, you must decide which of the following upgrade variants is needed:  
● Upgrade within a platform and a station type 
● Station change: An old station is replaced by a new type of station.  
● Platform change: The platform is changed within the same SIMOTION version. For 

example, a SIMOTION C230-2 is replaced by a SIMOTION P350.  
When the platform is changed, it may be necessary to change the station. In special cases, it 
may also be necessary to change a station within a platform. This is the case, for example, 
when upgrading from P350 V2.1 to P350 V3.0. 
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3.14.2 Changing a SIMOTION device followed by a TP upgrade 

3.14.2.1 Upgrading within a platform and a station type 
An upgrade is necessary when you want to replace the type or version of the SIMOTION 
device in your existing project. Perform this replacement in HW Config.  

To replace a SIMOTION device: 
1. Double-click the SIMOTION device to be replaced in the project navigator in SIMOTION 

SCOUT. HW Config is opened. 
2. Open the appropriate folder structure in the hardware catalog: 

 

  Note 
Please make sure that you do not delete the module to be replaced located in slot 2! 
When you drag the new module using drag-and-drop to the occupied slot 2, the old 
module is replaced. 

3. Confirm the displayed dialog box with Yes if you want to replace the SIMOTION device. 
4. Accept the changes made to the hardware configuration with Station > Save and compile. 
5. Close the HW Config. 

 

  Note 
The data for the SIMOTION device is immediately accepted in the SIMOTION SCOUT 
project and the entire project is saved. In this way, the project also accepts all changes in 
the project (e.g. axis configuration). 
If you are using technology packages in your project, these will also need to be updated. 

Upgrading technology packages 
When modules are replaced or project data is imported, the versions of the technology 
packages (TP) assigned to the individual technology objects (TO) are not automatically 
upgraded to a version valid for the SIMOTION device. This upgrade requires a separate 
step. 
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Adapting the technology packages version of the new SIMOTION device 
1. Select the required SIMOTION device in the project navigator. 
2. In the shortcut menu, select Select technology packages. 

 

  Note 
If the last step you performed was to replace the SIMOTION device, the Unfamiliar 
Technology Package Version dialog box appears. Confirm this with OK in order to delete 
the existing links to the technology packages, enabling new technology packages to be 
assigned. The Select Technology Packages dialog box will appear. 

3. Activate the checkbox of the technology packages. 
The technology packages must have the same version as the kernel. Consequently, in 
SIMOTION SCOUT V3.0 and higher, the same version as the kernel is automatically 
assigned to each technology package. 

4. If TOs for your project indicating an incorrect version appear under Incorrect version, click 
Update. If this is not the case, continue with step 8. 

5. The Update Technology Packages dialog box appears.  
Confirm this with OK.  
A message appears. 

6. Click OK to confirm the message. 
7. If the update is successful, a message appears. Click OK to confirm. 
8. Click OK to confirm the Select Technology Packages dialog box. 

The upgrade of the TPs is completed. 
 

  Note 
If you are using libraries in the project, these must also have the same version as the 
SIMOTION device. You can only upgrade libraries that are not write-protected. Note also 
the information in the SIMOTION SCOUT online help. 

Upgrade of libraries 
When the version of a SIMOTION device and the technology packages changes, the 
libraries created in SIMOTION SCOUT must also be adapted.  
1. Select a library in the project navigator. 
2. Right-click and select Properties... in the context menu. 

The Object Properties window opens. 
3. Click in the TPs/TOs tab. 
4. Select the appropriate device and the technology packages. 
5. Click OK to confirm the changes. 
6. Select the same library. 
7. Right-click and select Save and compile in the context menu. The upgrade is completed. 
8. Repeat the operations for all created libraries. 
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3.14.2.2 Changing a station 
A station change is required if the station type changes.  
This is the case, for example, if you want to change a platform between two of the following 
SIMOTION devices: 
● SIMOTION C2xx 
● SIMOTION P350 V2.1 and higher 
● SIMOTION D4xx 
Proceed as follows: 
1. In the project navigator, selectively export the project data of the SIMOTION device for 

which the station change is to be performed. 
2. Create a new SIMOTION device with the same or a different platform. This will be 

automatically inserted in the project navigator. 
3. Insert a new SIMOTION device or several master systems and configure them. 

The HW Config is opened. The new station and the created master systems are already 
inserted. 

4. Also open the old station in the HW Config. Switch to the old station. 
5. Copy the DP slaves. 
6. Switch to the new station. 
7. Insert the DP slaves in the new station. 
8. Check the configuration of the elements of the new station. 
9. Close the HW Config. 
10. Delete the old device in the project navigator. 
11. Perform a selective import of the data of the old device to the new device. 

3.14.2.3 Changing a platform within a station type 
A platform will need to be changed within a station type if you wish to switch between 
SIMOTION P and SIMOTION C or vice versa.  

Perform the following steps: 
● Step 1: Export of the station in HW Config 
● Step 2: Export of the SIMOTION device objects in SIMOTION SCOUT 
● Step 3: Deletion of the SIMOTION device in SIMOTION SCOUT 
● Step 4: Import of the hardware configuration of the station in HW Config. 
● Step 5: Replacement of the SIMOTION device in HW Config 
● Step 6: Check and update of the properties and communication connections in 

HW Config 
● Step 7: Import of the SIMOTION device objects in SIMOTION SCOUT 
● Step 8: Upgrade of the TPs and the used libraries in SIMOTION SCOUT 



Functions  
3.14 Changing a SIMOTION device 

 SIMOTION SCOUT 
82 Configuration Manual, 03/2007 Edition 

Proceed as follows: 

Step 1: Export of the station in HW Config 
1. In HW Config, open the station which is to be exported. 
2. Select Station > Export... in the menu. 
3. In the Export dialog box, specify the target directory for the export and confirm with Save. 
4. Switch to the SIMOTION SCOUT application. 

 

  Note 
An exported station can only be imported into a station of the same type! 

Step 2: Export of the SIMOTION device objects in SIMOTION SCOUT 
Selective export of the SIMOTION device to be replaced along with its associated elements. 
1. In the project navigator, select the SIMOTION device whose hardware configuration you 

have exported. 
2. Select Target device > Expert > Save project and export object in the shortcut menu. 
3. In the Export Device dialog box, specify the target directory for the export and click OK to 

confirm. 
 

  Note 
The result and the set target path appear in the status display once you have exported a 
project. 

Step 3: Deletion of the SIMOTION device in SIMOTION SCOUT  
A delete action removes all PROFIBUS connections, including the associated and 
centralized I/O. 
1. Select the SIMOTION device to be replaced in the project navigator. 
2. Select Edit > Delete in the menu. 
3. Click Yes to confirm the dialog box. 
4. Switch to the HW Config application. 

Step 4: Import of the station in HW Config  
1. In the menu, select Station > Import... 
2. Double-click the project in the Open Project dialog box. 
3. In the Import dialog box, select the previously exported file (*.cfg) and click Open to 

confirm. The hardware configuration for the station is opened in HW Config. 
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Step 5: Replacement of the SIMOTION device in HW Config 
1. Replace the SIMOTION devices, taking into account the following: 

– SIMOTION C2xx on P350: 
Delete the SIMOTION device from the rack and then the rack itself.  
Click OK to confirm the warning message. 

– Drag the appropriate SIMOTION device from the corresponding SIMATIC PC Station 
> SIMOTION P350 directory and drop it in the station window. 

– SIMOTION P350 to C2xx:  
Delete the SIMOTION device.  
You must first have selected the rack for the device.  
Click OK to confirm the warning message. 

– Then drag a rack, a power unit and the appropriate SIMOTION device into the station 
window. 

Step 6: Check and update of the properties and communication connections in HW Config 
 

 Note 
Check and update the properties (e.g. clock synchronization, base time on the isochronous 
PROFIBUS for the MASTERDRIVE MC) of the PROFIBUS connection. Then reassign the 
orphaned master systems to the SIMOTION device. 

 
1. Click Save and compile to save the changed hardware configuration. 

Step 7: Import of the SIMOTION device objects in SIMOTION SCOUT  
Selective import of all previously exported elements of the original SIMOTION device. 
1. Switch to the SIMOTION SCOUT application. 

The SIMOTION device is inserted in the project navigator of SIMOTION SCOUT. 
2. In the project navigator, select the newly inserted SIMOTION device. 
3. In the shortcut menu, select Target device > Expert > Import object. 
4. In the Import dialog box, specify the source directory of the import. 

 

  Note 
The SIMOTION device data appears in the project navigator once you have exported the 
device successfully. 

Step 8: Upgrade of the TPs and the used libraries in SIMOTION SCOUT 
The technology package versions are transferred for the elements saved by the export 
operation. 
1. Upgrade the TPs. 
2. Upgrade the used libraries. 
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3.15 Saving and restoring variables after a platform replacement or update 

3.15.1 Saving data 
If a SIMOTION platform has to be replaced, e.g. during a service job or before an upgrade, 
you have to save the data in order to be able to use this on the new SIMOTION platform. 
You can save a SIMOTION SCOUT project by exporting the data. This is described in the 
section Exporting and importing a project in XML format. 
You can save data that has been changed during operation and is only saved in the runtime 
system via the Save variables function. You have the possibility of saving and restoring 
retentive and non-retentive data, unit variables in the interface and implementation sections, 
as well as global device variables. If you use the functions Save variables and Restore 
variables, XML files are created that can be stored in a folder of your choice. With this 
function, all segments contained in the data sets are saved and restored. In this way, you 
can restore the original variable values. 
The following variables can be saved: 
● Retentive data that is defined as RETAIN global device variables for MCC, LAD/FBD and 

ST; all variables of the type VAR_GLOBAL RETAIN 
● Non-retentive global unit variables of the interface and implementation sections of the 

program sources: ST source file, MCC unit and LAD/FBD source 
If the "Save variables" function is selected for a SIMOTION device, a directory structure is 
created in the selected path. This directory is assigned the name of the selected SIMOTION 
device or the selected unit, depending on whether you want to save or restore the variables 
for the entire SIMOTION device or a unit. The retentive, global device variables are saved in 
the unitdata.xml file. The number of subdirectories corresponds to the number of sources in 
the SIMOTION project. The names of the subdirectories correspond to the names of the 
sources. Each subdirectory contains a unitdata.xml file in which the retentive unit variables 
are stored. If necessary, a further file is saved which contains the global variables of the 
source. This file is assigned the data set number, which is transferred by specifying the 
parameter "id" for the _saveUnitDataSet or _importUnitDataSet function, as name. Detailed 
information can be found under Data backup from user program. Further information can be 
found in the SIMOTION SCOUT online help. 
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3.15.2 Save variables 

Requirements: 
● Variable is declared as retentive or non-retentive global unit variable in the interface part 

of the source or as retentive global device variable 
● The project has been downloaded to the target system 
● SIMOTION SCOUT is in online mode 
● Only for unit variables saved via system functions: 

– The system function _saveUnitDataSet or _exportUnitDataSet must be executed in the 
ST program for every source so that the global unit data is created as binary data set 
in the SIMOTION device. 

– When executing the system function, the memory medium (RAM or memory card) 
must match the selection in the Save Variable dialog box 

To save the variables: 
1. Switch the SIMOTION device to STOP mode. This ensures that all the variable values 

have the same time stamp. 
2. Select the SIMOTION device, e.g. C230-2, or the unit. 
3. Right-click to open the shortcut menu. 
4. Click Save variables. 

The Save Variables window appears. 
 

  Note 
Activate the Retain variables checkbox if you want to save all retentive variables from the 
current data memory. 
Activate the Unit variables (ST) / global variables (MCC, LAD/FBD) saved via system 
functions checkbox if you want to save the previously saved or exported data sets.  
Select whether the data sets should be read from the memory card or from the RAM disk. 
Ensure that this selection corresponds to the storage location where the data sets were 
saved by the _saveUnitDataSet/_exportUnitDataSet function. Detailed information is 
contained in the programming manuals. 

5. Make the required settings. 
6. Click OK. 

The Select Folder window appears. 
7. Select the storage location for the backup files. 
8. Click OK to confirm. 

The variables are saved. 
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3.15.3 Restoring variables 

Requirements: 
● The interface section of the source has not been changed 
● The variables have been saved via the Save variable function. 
● The project has been downloaded to the target system 
● The SIMOTION device is in the STOP mode 
● SIMOTION SCOUT is in online mode 
● Only for unit variables saved via system functions: 

– The system function _loadUnitDataSet or. _importUnitDataSet must be executed in 
the ST program for every source so that the global unit data is created as binary data 
set in the SIMOTION device. 

– When executing the system function, the memory medium (RAM or memory card) 
must match the selection in the Save Variable dialog box 

 

  Note 
General conditions for restoring variables if there are differences between the backup 
file and the project: 
If the unit variable or the global device variable exists in the project, but not in the 
backup file, then the contents of the unit variable in the unit or the global device 
variable are retained unchanged. 
If the unit variable or the global device variable exists in the backup file, but not in the 
unit or on the device, then the variable is ignored. 
If the unit variable or the global device variable exists in the backup file and on the unit 
or device, but is of a different data type, then a type conversion is performed between 
ANY_INT <-> ANY_INT, ANY_INT <-> ANY_REAL, ANY_REAL <-> ANY_REAL. If a 
type conversion is possible, then the value in the backup file must fit in the new value 
range of the unit variable or global device variable, otherwise this is initialized. If a type 
conversion is not possible (e.g. date, time), then the UNIT variable or global device 
variable is initialized. 
If the unit variable or the global device variable exists in the backup file and on the unit 
or device and the data type is identical, then the contents of the variables from the 
backup file is transferred to the unit variable of the unit or to the global device variable 
on the device. 

To restore variables: 
1. Select the SIMOTION device, e.g. C230-2, or the unit. 
2. Right-click to open the shortcut menu. 
3. Click Restore variables. 

The Restore Variables window appears. 
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  Note 
Activate the Retain variables checkbox if you want to restore the previously saved 
retentive variables. 
Activate the Unit variables (ST) / global variables (MCC, LAD/FBD) saved via system 
functions checkbox if you want to restore the previously saved data sets. Select whether 
the data sets should be written to the memory card or to the RAM disk. 

4. Make the required settings. 
5. Click OK. 

The Select Folder window appears. 
6. Select the folder of the SIMOTION device or the unit in which the backup files are stored. 
7. Click OK to confirm the following window. 
8. Switch the SIMOTION device to RUN mode. 
9. Execute the system function _loadUnitDataSet or _importUnitDataSet to initialize the 

variables with the values from the backup files. 
 

  Note 
To restore the global unit data, the system function _loadUnitDataSet or 
_importUnitDataSet must be executed in the ST program for every source whose 
variables are to be initialized with the values from the XML files. 
Ensure that the parameter for the memory source corresponds to the memory to which 
the data was written with the Restore Variable function. For more detailed information, 
refer to the SIMOTION ST (Structured Text), Programming Manual. 

3.16 Exporting and importing projects 

3.16.1 Exporting and importing a project in XML format 
A log of the export or import is displayed in the XML export/import status display tab in the 
detail view. The XML export log also contains a link to the exported file. Double-click on this 
link to view the exported project data in the Internet browser.  

 

 Note 
Projects are exported and imported version-neutral. However, if a project has version-
specific properties, related errors may occur following import into another SCOUT version, 
e.g. when compiling of ST programs. 
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Exporting a project 
Menu: Project > Save and export 
The data format for exporting projects has been changed in SIMOTION SCOUT Version 
V2.1. Activate the Use V2.0 export format checkbox to export a project in V2.1 or higher with 
V2.0 format and re-import it with an older version of SIMOTION SCOUT (< V2.1). If you 
activate this checkbox, an optimized XML export is not possible. 
SIMOTION SCOUT V3.0 and higher features an additional function. Projects can be 
exported more quickly using less memory. This is the default setting when you call the 
export. 
For this, activate the checkbox Use optimized export format.  
If neither checkbox is activated, all data in the SCOUT project is exported, even data not 
read back in during an import. This export is only required in exceptional cases. 

Importing a project 
 

 Note 
Projects can only be imported in offline mode and no projects should be open in SIMOTION 
SCOUT. 

 
1. Select Project > Import in the menu bar.  

The Import Project window and the XML export/import status display tab appear. 
2. Under Source path and Source name of the import, select the XML file to be imported. 
3. Click Open to confirm. 
4. Click OK. 
5. Enter the project name in the newly opened window and select a project directory by 

clicking Browse. 
6. Click OK. 

The import is started. On completion of the import, the successfully completed import, the 
project name and the target path are displayed in the XML export/import status display 
tab of the detail view. The new project is displayed in the project navigator. 

Additional references 
Please refer to the online help on this subject 
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Product combination 4
4.1 Compatibility 

4.1.1 General compatibility 
Different hardware and software combinations as well as different Kernel and SIMOTION 
SCOUT version combinations are possible when using SIMOTION. These combinations can 
be found in the compatibility lists on the SIMOTION SCOUT Add-On CD and in the Internet 
at http://www4.ad.siemens.de/view/cs/de/18857317.  

4.1.2 Software compatibility 

Technology packages with Kernel 
The SIMOTION kernel and the technology packages must always have the same version.  
Example: Only a TP Cam Version V3.2 technology package will run on a SIMOTION Kernel 
Version V3.2.  

Table 4-1 SIMOTION SCOUT with SIMOTION Kernel 

Kernel version SCOUT version 
V2.1.x V3.0.x V3.1.x V3.2.x V4.0 V4.1 

SCOUT V2.1.x x - - - - - 
SCOUT V3.0/SP1 x x - - - - 
SCOUT V3.1.x x x x - - - 
SCOUT V3.2.x x x x x - - 
SCOUT V4.0 - x x x x - 
SCOUT V4.1 - x x x x x 
x = compatible; - = not compatible 
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Project on memory card with SIMOTION Kernel 
A project is always created for a specific SIMOTION Kernel and will only run on the relevant 
SIMOTION device if this exact SIMOTION Kernel version is available. 

Table 4-2 SIMOTION SCOUT with project version 

Project created with SCOUT version SCOUT version 
V2.1.x V3.0.x V3.1.x V3.2.x V4.0 V4.1 

SCOUT V2.1.x x - - - - - 
SCOUT V3.0/SP1 x x x x x x 
SCOUT V3.1.x* x x x x x x 
SCOUT V3.2.x* x x x x x x 
SCOUT V4.0* x x x x x x 
SCOUT V4.1* x x x x x x 
x = compatible; - = not compatible 

* As of SIMOTION SCOUT Version V3.1.1 you can also save a project in the project format 
of an older version (up to Version V3.0), when the project has been created with the 
appropriate version. 
A project with a version earlier than the installed SCOUT version will be converted to the 
current version when it is opened. Only the data content of the SCOUT project will be 
converted to the current version, but not the SIMOTION device version. 
Example: If you have installed SIMOTION SCOUT V4.1 and wish to open a project created 
in SIMOTION SCOUT Version V4.0, the project is converted to V4.1 . 
To successfully convert a project into an older format, no functions of the newer version may 
be used. 

4.2 Memory media of the SIMOTION devices 

Storing on memory media 
The online project comprising the technology package and the user data. It is stored on a 
memory medium secure against power loss. The data medium used will vary depending on 
the SIMOTION platform and SIMOTION version.  
● SIMOTION C2xx: Micro memory card 
● SIMOTION P350: Virtual memory card 

Handling and functionality correspond to the micro memory card of the SIMOTION C2xx. 
● SIMOTION D4xx: CompactFlash card 

 

  Note 
The memory card must not be inserted or removed during operation. Removing the card 
in RUN mode triggers an overall reset, which results in the loss of stored data. 
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Additional references 
More information on this topic is available in 
● Operating Instructions SIMOTION C2xx 
● SIMOTION P350 and Panel Fronts, Commissioning Manual 
● SIMOTION D4x5 Commissioning Manual 
● SIMOTION D410 Commissioning Manual 
● SIMOTION SCOUT Online Help 

Persistent data backup 
Persistent data storage is executed using a non-volatile memory integrated in the SIMOTION 
device, e.g. SRAM for D4xx. SuperCap and optionally a battery are used for buffering the 
non-volatile memory.  
You can save data from the non-volatile memory in order to avoid loss of data in the event of 
a power failure. The following functions are possible: 
● System function _savePersistentMemoryData for saving the non-volatile memory 
● Restoration of the non-volatile memory during the ramp-up on detection of a power loss. 

Additional references 
More information on this topic is available in 
● Base Functions Function Manual 



Product combination  
4.3 STEP7 

 SIMOTION SCOUT 
92 Configuration Manual, 03/2007 Edition 

4.3 STEP7 

4.3.1 SIMATIC Manager 

Open SIMOTION project 
You can also open a project in the SIMATIC Manager and edit it with the tools provided. 
However, you do not have any direct access there to specific SIMOTION components, such 
as technology object and programs. 
You can open the SIMOTION SCOUT from the CPU. 

 

 Note 
You can use File > Manage... to show and hide the projects you have created in 
SIMOTION SCOUT in the SIMATIC Manager. 
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4.3.2 SIMATIC Logon 

Overview 
As of SIMOTION SCOUT V4.1, you have the option of assigning a project password to 
provide access protection for projects. This functionality requires the previous installation of 
the SIMATIC Logon STEP7 option. 
This function makes it possible to restrict project creation to authorized personnel only and to 
track changes in versions created with SIMATIC Logon. It also therefore provides support for 
the validation process of a machine or system [as per FDA 21 CFR Part 11].  

Installation / Prerequisites 
The STEP7 V5.4 SP1 options SIMATIC Logon and Version Trail must be installed and 
licensed in addition to SIMOTION SCOUT V4.1. 

Features 
When SIMATIC Logon is installed, password protection can be activated for any project. A 
SCOUT project saved with SIMATIC Logon can only be opened and edited with password 
protection. 
● If a project is opened in SCOUT that has an access protection set with SIMATIC Logon, 

the access dialog appears in which the project password must be entered. This means 
the correct password must be entered to open the project. 
If an incorrect password is entered, an error message will be issued and the project 
remains closed. 

● Passwords are assigned in a separate administrator screen using a process configured 
according to the guidelines under FDA 21 CFR Part 11. 

● Every file open and every change is automatically recorded in a revision log. 
● SCOUT projects created with SIMATIC Logon can be archived, managed and their 

changes tracked in a clearly organized fashion using the SIMATIC Version Trail option. 
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Activate SIMATIC logon 
When SIMATIC Logon is installed, password protection can be activated for any project. 
To do this, select Options > Access Protection > Activate in SIMATIC Manager. 

 
Figure 4-1 Activate SIMATIC Manager access protection 

When access protection is activated, the SIMATIC Logon Service window opens. The 
administrator logs in here to assign a project password for this project. 

 
Figure 4-2 Activate access protection 

Then the users are entered in the user administration for this project using drag&drop. 
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Figure 4-3 SIMATIC Logon AdminTool 
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Open protected project 
When a protected project is opened, the following dialog box appears if SIMATIC Logon is 
installed. Enter your user name and password here.  

 
Figure 4-4 SIMATIC Logon service 

If SIMATIC Logon is not installed, the project can also be set to open only with the project 
password using STEP7 V5.4. 

 
Figure 4-5 Enter the project password. 

For more details on this topic, see the following document: 
● SIMATIC Logon; SIMATIC Electronic Signature, Manual 
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4.3.3 SIMATIC Version Trail 

Overview 
SIMATIC Version Trail is a software option for SIMOTION engineering which, together with 
the SIMATIC Logon central user administration, can assign a version history to libraries and 
projects.  

Installation / Prerequisites 
SIMATIC Version Trail is an option in STEP7 V5.4 SP1 and must be installed and licensed in 
addition to SIMOTION SCOUT V4.1. SIMATIC Version Trail can only be used and licensed 
in a package together with SIMATIC Logon. 

Function 
When archiving, SIMATIC Version Trail creates a version history with the following 
information in association with SIMATIC Logon: 
● Version 
● Version name 
● Date and time 
● Users 
● Comments 
This version history can be displayed and printed. Individual versions can be retrieved from 
the version history, and used further. SIMATIC Logon organizes the access protection. 
View of a SIMATIC Version Trail window, showing the project name, comments and 
versioning data. The versions created with SIMATIC Logon can be documented and 
managed in a clearly organized fashion after changes. 
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Figure 4-6 SIMATIC Version Trail - version data 

 

 Note 
Please note that SIMATIC Version Trail cannot be used separately, but only in combination 
with SIMATIC Logon. 

 



 Product combination 
 4.4 NetPro 

SIMOTION SCOUT 
Configuration Manual, 03/2007 Edition 99 

4.4 NetPro 

NetPro in STEP7 
NetPro is integrated in the STEP 7 basic package. NetPro is a supporting tool for STEP 7. 
A time-controlled cyclical data transmission via MPI is possible with NetPro:  
● Selection of the communication stations 
● Entry of data source and data target in a table; the generation of all blocks (SDB) to be 

loaded and their complete transfer to all CPUs is performed automatically. 
An event-driven data transmission is also possible with:  
● Specification of the communication connections 
● Selection of the communication/function blocks from the integrated function block library 
● Parameter assignment of the selected communication/function blocks in the usual 

programming language. 

Application for SIMOTION 
So that network nodes can communicate, configure networks and/or subnets in NetPro. In 
NetPro, you create a graphic view of the networks and subnets and specify their properties 
or parameters. You can also define the node properties. 
You can open NetPro via SIMOTION SCOUT; the NetPro application then opens as a 
separate window. Application cases for the SIMOTION project are, for example, the 
connection of the engineering system via network nodes and the creation of routing 
connections. 
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4.5 HMI 

Overview 
The Human Machine Interface (HMI) connects the world of automation with the individual 
demands of the operator. As part of TIA, SIMATIC HMI supports uniform engineering under 
Windows, accesses common data and communicates uniformly.  
For efficient machine operation and monitoring in various performance classes, you can use 
the following panels recommended for SIMOTION as well as PC-based panel systems with 
membrane keyboards or touch screen operation: 
● Panels 

For efficient machine operation and monitoring in various performance classes, either 
text-based or graphics-capable with membrane keyboards or touch screen operation. 

● Multi-panels 
These can be used for operator control and monitoring in the same way as the panels, 
with operation by means of touch screens or membrane keyboards. Multi-panels (MP) 
also permit the installation of additional applications and therefore provide typical PC 
flexibility. 

● Panel PCs 
Are designed for demanding environmental conditions and provide the same degree of 
robustness and suitability for industry. 

Detailed information can be found in the SIMOTION PM 10 Catalog. 
SIMATIC ProTool/Pro, a modern visualization software under Windows, and the WinCC 
flexible engineering software are available for the display of the user interface. 

SIMATIC ProTool/ ProTool/Pro 
ProTool is the system-wide and uniform configuration software under Windows for all 
SIMATIC HMI operator panels.  
SIMATIC ProTool covers the applications of the machine-related area with PC-based control 
and monitoring solutions for single-user systems based on ProTool/Pro through to the 
SIMATIC HMI operator panels. For the configuration of the ProTool/Pro runtime for PCs as 
well as SIMATIC HMI operator panels, the ProTool family has the uniform and scalable 
configuration tools ProTool/Lite, ProTool and ProTool/Pro CS.  
ProTool/Pro is the visualization software under Windows for the PC-based HMI in the 
machine-related area. It allows quick response times and safe process control. 
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SIMATIC WinCC flexible 
SIMATIC WinCC flexible is the innovative HMI software under Windows 2000/XP for all 
applications in the machine-related area. The engineering software enables the uniform 
configuration of all Windows-based SIMATIC HMI operator panels.  
WinCC flexible Runtime provides basic HMI functionality on PCs, including messaging and 
logging systems and can be expanded when required via options. The runtime functions 
available on the SIMATIC HMI operator panels are dependent on the device class. 
Existing ProTool projects can be accepted or converted. The WinCC flexible engineering 
software can be integrated in the central programming software of the SIMATIC world, 
SIMATIC STEP 7, and used for the configuration of all operator panels. The engineering 
software of SIMATIC HMI also accesses variable lists and message lists of the controller and 
uses their communication parameters.  

OPC / OPC XML-DA  
Open communications standard for automation components. The goal of the standard is to 
ensure a problem-free and standardized data exchange between controllers, operator 
control and monitoring systems, field devices and office applications from different 
manufacturers. 
The OPC abbreviation previously means "OLE for Process Control", because the 
implementation is based on Microsoft's COM/DCOM technology.  
Nowadays, one uses the term "Openess, Productivity and Collaboration". Today, a number 
of standards defined by the OPC Foundation have evolved. The OPC Foundation is a 
grouping of many manufacturers from the automation technology area. 
SIMOTION supports the OPC DA (Data Access) and OPC AE (Alarm & Event) standards 
with the SIMATIC NET Softnet package. This is based on the Windows COM technology.  
SIMOTION also supports OPC XML-DA (Data Access based on XML). The OPC server is 
located in the SIMOTION device and is accessed from a partner station no longer using 
COM mechanisms but with Web services and their XML-coded function calls. This makes 
the partner stations independent of hardware and operating systems. 
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4.6 Drive ES 

Drive ES engineering system 
Drive ES is the engineering system used to easily integrate Siemens drive technology into 
the SIMATIC automation world easily, efficiently and cost-effectively in terms of 
communication, configuration and data management. The STEP 7 Manager user interface 
provides the basis for this procedure. 
Drive ES Basic is the basic software for the parameterization of all drives, online and offline. 
With the Drive ES Basic software, the automation and the drives are edited on the user 
interface of the SIMATIC Manager. Drive ES Basic is the starting point for common data 
archiving from complete projects and for extending the use of the routing and SIMATIC 
teleservice to drives. Drive ES Basic provides the engineering tools for the new motion 
control functions - data exchange broadcast, equidistance and isochronous operation with 
PROFIBUS DP. 
The following commissioning tools are contained in Drive ES: 
● STARTER Standalone for SINAMICS is not required and cannot be used in conjunction 

with SIMOTION SCOUT because STARTER is integrated in SIMOTION SCOUT. 
● SIMOCOM U for SIMODRIVE 
● Drive Monitor for MASTERDRIVES 

 

  Note 
Drive ES Basic is part of the delivery of SCOUT and SCOUT Standalone. 
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4.7 Commissioning drives (Starter) 
The aim of STARTER is the simple and rapid commissioning, optimization and diagnostics of 
all Siemens drives of the new drive generation with only one tool.  
The STARTER drive/commissioning tool supports the following drives: 
● SINAMICS 
● MICROMASTER 420/430/440 
● MICROMASTER 411 / COMBIMASTER 411 
● COMBIMASTER 
● ET200pro FC 
● ET200S FC ICU24 
The following variants are available: 
● STARTER Standalone: 

STARTER as commissioning tool for applications without SIMOTION, but with integration 
of the new drives in SIMATIC S7. STARTER Standalone is not required in connection 
with SIMOTION SCOUT and cannot be used. 

● STARTER integrated in SIMOTION SCOUT:  
For SIMOTION applications, SIMOTION SCOUT contains the entire functionality of 
STARTER. 

Performance characteristics: 
● Wizards support new users by providing solution-oriented dialog guidance, whereby the 

uniform graphics-based display facilitates understanding. 
● However, experts are also able to access the individual parameters quickly. 

4.8 CAMTool 

Graphic creation of cams 
Simple text-based editors are already integrated in the basic SIMOTION SCOUT package 
for the creation of cams. The CAMTool V2.2 option package expands SIMOTION SCOUT 
with a powerful tool for the full graphical creation and optimization of cams. CAMTool fully 
integrates into the SIMOTION SCOUT user interface. In SIMOTION CAMTool, you can 
create, edit and optimize cams with the aid of a graphical user interface. 

Additional references 
Please refer to the following document on this subject 
● SIMOTION CamTool, Configuration Manual 
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4.9 DCC programming system 

Drive Control Chart 
DCC enables SIMOTION and SINAMICS users to also implement and graphically configure 
drive-related tasks employing continuous closed-loop and open-loop control.  
A set of function blocks (Drive Control Blocks library) is available for this purpose. These 
function blocks can be graphically interconnected and configured in so-called "charts" via a 
configuration tool (DCC editor). 
A large number of Drive Control Blocks (DCB) are available for both DCC-SIMOTION and 
DCC-SINAMICS with identical functionality. 
● Module library with administration, calculation, control, logic and complex modules. 
● Graphical switching editor with various editing, macro, help, search, comparison and print 

functions. 
● Sequence environment for SIMOTION with selectable, mixable scanning times and 

consistent data transfer between scanning periods. 
● Sequence environment for SINAMICS with embedding of technology option in SINAMICS 

using the BICO technique, with the applications set using configured parameters 
● Diagnostics environment with signal display, diagnostics and trace functions. 
● Scalability with different performance features and project data volumes for DCC-

SIMOTION and DCC-SINAMICS. 

Additional references 
More information on this topic is available in 
● Programming and Operating Manual SINAMICS/SIMOTION Editor description DCC 
● SINAMICS/SIMOTION DCC Module Description Function Manual 
● SIMOTION SCOUT Online Help 
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Diagnostics 5
5.1 Controlling the target system 

5.1.1 Overview 
In online mode, you can control the SIMOTION device with SIMOTION SCOUT, e.g.:  
● Change and compile program sources 
● Download 
● Select the operating mode 
● Set the internal clock of the SIMOTION device 
● Change Configuration Data in RUN Mode 
● Control variables in RUN 
● Copy current data to RAM 
● Copy RAM to ROM 
● Delete the RAM of the SIMOTION device (overall reset) 
● Archive project data 

5.1.2 Setting the operating mode in SIMOTION SCOUT 
 

DANGER  
Danger to personnel and machine can result from an uncontrolled change of the operating 
mode. 
Please note the safety regulations before you control a SIMOTION device via the mode 
selector in SIMOTION SCOUT. 

 
1. Select the SIMOTION device in the project navigator. 
2. Select the Target system > Control operating mode menu. 

A software switch is displayed. This represents the mode selector on the 
SIMOTION device or the virtual hardware mode selector (SIMOTION P). The current 
operating mode is displayed with symbolized switch setting and LEDs. 
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3. Select the desired operating mode. 
Click the corresponding button. 
The switching options are dependent on the position of the mode selector on the 
SIMOTION device. 

The operating mode can be monitored and switched with the device diagnostics.  

Table 5-1 Operating modes of a SIMOTION device 

Operating mode Description 
STOP • Technology objects inactive (enables deleted, no axis motion) 

• User program is not executed 
• Loading a user program is possible 
• All system services are active (communication, etc.) 
• All analog and digital outputs set to 0 
• The I/O modules (signal modules) are in the safe state (SIMOTION D4xx) 

STOP U • Technology objects are active 
• Technology objects can execute jobs for testing and commissioning 

functions. 
• Otherwise identical to STOP operating mode 
• STOP U means stop user program 
• User program is not executed 

RUN • Technology objects are active 
• Execution of the user programs assigned to the execution system 
• Loading a user program is possible 
• Process image of the inputs and outputs is read or written 

MRES Overall reset 
• Switch setting for the overall reset of the SIMOTION C2xx, SIMOTION P350-

3 and the SIMOTION D4xx 
SERVICE • Mode selector on SIMOTION device (!) must be in the STOP U or RUN 

position. 
• The mode is assumed when the control priority is fetched using the axis 

control panel. 

 

Table 5-2 The switching possibilities of the software switch depending on the position of the mode 
selector on the SIMOTION device (with regard to the SIMOTION D4xx, see the 
SIMOTION D4x5 Product Manual; SIMOTION D410 Product Manual) 

Mode selector position of the SIMOTION device Switching options of software switch in 
SIMOTION SCOUT 

STOP STOP 
STOP U STOP U  

STOP 
RUN RUN  

STOP U  
STOP 

MRES MRES  
STOP 
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Table 5-3 LEDs of the mode selector 

LED Description Color Meaning 
5 VDC Power OK Green Power supply 5 V 

• Steady:  
Power supply functioning correctly. 

• Flashing:  
Power supply defective 

RUN RUN Green RUN mode 
• Steady:  

SIMOTION device is in RUN mode. 
• Flashing:  

RUN mode is selected (by SIMOTION SCOUT or 
switch) and the SIMOTION device is on its way there. 

• Flashing simultaneously with STOP U 
SIMOTION device is in SERVICE mode. 

• Off: 
SIMOTION device is not in RUN mode. 

STOP U STOP User 
program 

Orange STOP U mode 
• Steady:  

SIMOTION device is in STOP U mode. 
• Flashing:  

STOP U mode is selected (by SIMOTION SCOUT or 
switch) and the SIMOTION device is on its way there. 

• Flashing simultaneously with RUN 
SIMOTION device is in SERVICE mode. 

• Off:  
SIMOTION device is not in STOP U mode. 

STOP STOP Orange STOP mode 
• Steady:  

SIMOTION device is in STOP mode. 
• Flashing:  

STOP mode is selected (by SIMOTION SCOUT or 
switch) and the SIMOTION device is on its way there. 

• Flickering (fast flashing):  
Write access to the memory card 

• Off:  
SIMOTION device is not in STOP mode. 

 
 

 Note 
The LED displays on SIMOTION devices are described in the associated Manuals. 
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SIMOTION C2xx 

 
Figure 5-1 Mode selector 

On the SIMOTION C2xx, the operating mode can also be set via a rotary switch on the 
device. 

SIMOTION P350-3 
 

 Note 
With SIMOTION P, the mode selector is displayed via the SIMOTION P Startup application. 
You can call this via Start > Programs > SIMOTION P Startup. 
For more information, see the SIMOTION P Product Manual. 

 

 
Figure 5-2 SIMOTION P state application 
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SIMOTION D4xx 
 

 Note 
For the SIMOTION D4xx, it is recommended that the operating mode be switched with the 
SIMOTION SCOUT. 

 

 
Figure 5-3 D4xx mode selector 

Additional references 
Please refer to the following documents on this subject 
● Operating Instructions SIMOTION C2xx 
● SIMOTION P350-3 and Panels Commissioning and Hardware Installation Manual 
● SIMOTION D4x5 Commissioning and Hardware Installation Manual 
● SIMOTION D410 Commissioning Manual 
and the SIMOTION SCOUT online help. 

5.1.3 Overall reset 
Proceed as follows:  
1. Start the software mode selector. 
2. ClickMRES. 
3. Acknowledge the warning. 
On the SIMOTION device, MRES automatically switches to the STOP mode once execution 
is completed. 
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References 
For more information, please refer to 
● SIMOTION C2xx Operating Instructions 
● SIMOTION P SIMOTION P350-2 Product Manual and Panels Manual 
● SIMOTION D4x5 Manual 
● SIMOTION D410 Product Manual 
● SIMOTION SCOUT Online Help 
 

5.1.4 Setting the time of day 
Proceed as follows:  
1. Select the SIMOTION device in the project navigator. 
2. Select the Target system > Set time of day menu. 

The current date and the time of day of the PG/PC and the SIMOTION device are 
displayed. 

3. Change the date and time of day of the SIMOTION device, if necessary: 
If you want to accept the values from the PG/PC: 
– Activate the Accept from PG/PC checkbox. 
If you want to enter values: 
– Deactivate the Accept from PG/PC checkbox. 
– Enter the values in the corresponding fields (Module). 

 
Figure 5-4 Setting the time of day 
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5.1.5 Changing configuration data 
You can also change the configuration data of a technology object offline and online in the 
RUN mode.  
You can change the configuration data in the expert list of the respective technology object, 
e.g. axis. 
Proceed as follows: 
1. Select the relevant technology object in the project navigator. 
2. Open Expert > Expert list in the shortcut menu. 

The expert list opens in the working area. 
3. In the expert list, open the Configuration data subtree and, if required, other subtrees. 

 
Figure 5-5 View of the expert list 
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Additional references 
 

 Note 
The detailed procedure for changing the configuration data is described in: 
SIMOTION Motion Control, Basic Functions, Function Manual 

 
For additional information, see 
● SIMOTION Lists Manuals 
● SIMOTION SCOUT Online Help 

5.1.6 Archive project data 
The Target system > Archive project on card... function archives the complete SCOUT 
project on the MMC / CompactFlash card or hard disk of the P350. 
The Target system > Load project from card... function loads the archived SCOUT project 
from the card or the hard disk. 
A zip file is archived. This function is only possible in online mode. In addition to the zip file, 
an info file is saved. This can be read with the Target system > Load project from card... 
function. The following contents are written to the info file:  
● The project name 
● The size of the zipped project file 
● The storage date 
For additional information, see 
● Handling Recommendations for Service with SCOUT V4.1 section 
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5.2 Using diagnostic functions 

5.2.1 Overview of the possible diagnostic functions 
A wide range of diagnostic functions can be used for the operation of SIMOTION devices in 
the online mode. These diagnostic options are summarized in the diagnostics overview.  
● The diagnostics overview is a tab in the detail view and is available by default in online 

mode. You can call up detail displays from here. 
● An Alarms tab is also available in the detail view. This provides a tabular overview of 

– Technological alarms (from technology objects) 
– Alarm_S messages (from user programs) 

The alarms can be acknowledged either individually or all together. 
● You can record signal charts with the trace tool. The values of system variables can be 

recorded during runtime for diagnostic purposes. 
● Program testing and debugging, e.g. variable control, program status, breakpoints 

References 
For more information, please refer to 
● SIMOTION ST (Structured Text), Programming Manual 
● SIMOTION MCC (Motion Control Chart), Programming Manual 
● SIMOTION LAD/FBD, Programming Manual 
● SIMOTION SCOUT Online Help 
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5.2.2 Using the diagnostics overview 
The diagnostics overview is available as a tab in the detail view when the project is in online 
mode.  
● In the detail view, select the Diagnostics overview tab. 

 
Figure 5-6 Diagnostics overview in the detail view (online mode) 

The following are displayed for each accessible SIMOTION device: 
● Operating mode 
● Memory used (absolute and percentage display) 

RAM disk, RAM, memory card, retentive data 
● CPU utilization (percentage display) 
The drive devices specified in the hardware configuration are also displayed. To obtain a 
detailed display of the individual devices, open the device diagnostics. 

5.2.3 Device diagnostics 
In online mode, the device diagnostics function enables you to obtain a comprehensive 
display of diagnostics results of the individual SIMOTION devices.  
Proceed as follows: 
1. Select the desired SIMOTION device in the project navigator. 
2. Select the Target system > Device diagnostics... menu. 
or 
1. Double-click the SIMOTION device in the Diagnostics overview tab in the detail view. 

 

  Note 
You may open the device diagnostics for several SIMOTION devices simultaneously. 
This allows you to compare different devices. 
You can also access these device diagnostics via the Accessible nodes function. 
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The Device Diagnostics window appears in the working area of the workbench. This window 
provides you with the following information: 
● General information 
● Diagnostics buffer 
● Slaves 
● Task runtimes 
● System utilization 
● User log file 
● Syslog file 
● Version overview 
You have the following options: 
● Print: 

Select the Project > Print menu. 
● Save it as a text file: 

Click Save. 
● Refresh:  

Click Refresh or press the <F5> function key. 
You can also monitor and change the operating mode: 
● Click Control operating mode. 
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5.2.4 Device diagnostics: General 
This provides general information on the SIMOTION device:  
● Select the General tab in the Device Diagnostics window. 
The following information will be displayed: 
● Name and system ID of the SIMOTION device 
● Operating mode of the SIMOTION device 
● MAC addresses 
● IP addresses 
● Subnet mask 
● Standard gateway 
● Order numbers and names of the components used,  

e.g. SIMOTION device, Motion Control technology package. 

 
Figure 5-7 Display of general information in the device diagnostics 
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5.2.5 Device diagnostics: Diagnostics buffer 
The diagnostics buffer is part of the system status list. It is possible to jump to the error 
position from the diagnostics buffer (as of V3.2). It logs important events (e.g. changes in 
module state) in the order in which they occur. These include the following:  
● Faults in a module 
● Faults in the process wiring 
● System errors in the CPU 
● CPU operating mode transitions 
● Drive alarms 
● Errors caused by the technology objects of SIMOTION 
● Errors in the user program that caused an operating state transition (a double-click on the 

error message causes the cursor to jump to the error location in the program) 
● User-defined entries with the _writeAndSendMessage function 
● PMC error messages (SIMOTION D4x5) 
● Compatibility errors, e.g. the drive software with SIMOTION (SIMOTION D4x5) 
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To work with the diagnostics buffer: 
1. In the Device Diagnostics window, select the diagnostics buffer tab. 

The saved events are displayed in tabular form. 
2. Select the event for which you want to obtain more information. 

Detailed information for the selected event is displayed in the lower pane of the window. 

 
Figure 5-8 Example of the diagnostics buffer display in the device diagnostics 
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5.2.6 Device diagnostics: Slaves 
The devices displayed in the Slaves tab of the device diagnostics are not identical to the 
display in the Accessible Nodes window.  

 

 Note 
When you open the Slaves tab, you must refresh the display. Press the F5 key on the 
keyboard. 

 
After refreshing the view, the following devices are displayed in the Slaves tab: 
● Devices configured in HW Config 
● All devices that are configured in the Slaves function 

 
Figure 5-9 Example of the Slaves tab display in the device diagnostics 
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5.2.7 Device diagnostics: Task runtime and task status 
You can display the task runtimes and the status of the tasks set up in the project if you are 
connected online with the unit. The resolution of the displayed task runtimes is performed in 
the servo cycle clock.  

 

 Note 
The task runtimes are calculated to the µs and indicate the effective level runtime of the 
respective task (including the interrupt times). These thus correspond to the values of the 
effectiveTaskruntime device variables. 
The following applies to SIMOTION Runtime versions < V4.1: 
The display is calculated in the servo cycle clock and has only the resolution of the servo 
cycle clock. As the task runtime can be less than the servo cycle clock, e.g., for the 
ServoSynchronousTask or IPOSynchronousTask, the value 0 ms is displayed in this case. 

 

 
Figure 5-10 Example of the task runtimes display in the device diagnostics 

The display is refreshed according to the refresh rate selected. The status and the following 
values are then displayed: 
● Current runtime (current):  

Value of last polling 
● Minimum runtime (min.):  

Minimum value since last transition from STOP to RUN 
● Maximum runtime (max.):  

Maximum value since last transition from STOP to RUN 
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● Mean runtime (mean value):  
Value averaged from the last 10 cycles 

The runtimes measured include the interruptions by higher-priority tasks. 

Meaning of the various status displays: 
● RUNNING (TASK_STATE_RUNNING) 

Task running, e.g.: 
– Via the _startTask function 
– As an active cyclic task 

● RUNNING_SCHEDULED (TASK_STATE_RUNNING_SCHEDULED) (as of V4.1) 
Task is interrupted by the system. 
If the task status RUNNING_SCHEDULED is pending for a long time, it identifies a long-
runner in the user task, e.g., a programmed continuous loop. 

● STOP_PENDING (TASK_STATE_STOP_PENDING) 
Task has received signal to stop; it is in a state between RUNNING and STOPPED. 
Actions may be performed until the task has stopped. 

● STOPPED (TASK_STATE_STOPPED) 
Task stopped (e.g. via the _resetTask function), completed or not yet started. 

● SUSPENDED (TASK_STATE_SUSPENDED) 
Task suspended by function _suspendTask. 
Use _resumeTask(name) to cancel this command. The task then resumes from the point 
at which it was interrupted. 

● WAITING (TASK_STATE_WAITING) 
Task is waiting due to function _waitTime or WAITFORCONDITION. 

● WAITING_FOR_NEXT_CYCLE (TASK_STATE_WAIT_NEXT_CYCLE) 
TimerInterruptTask waiting for start trigger. 

● WAITING_FOR_NEXT_INTERRUPT (TASK_STATE_WAIT_NEXT_INTERRUPT) 
SystemInterruptTask or UserInterruptTask is waiting for the triggering event to occur. 
When an interrupt occurs, the SystemInterruptTasks are started and executed once. Up 
to 8 incoming interrupts can be stored in the buffer. If another interrupt occurs, the buffer 
overflows and the CPU goes into STOP mode. 

● LOCKED (TASK_STATE_LOCKED) 
Task locked by function _disableScheduler. 
This status prevents the activation of all user tasks (except the IPOSynchronousTask and 
IPOSynchronousTask_2) until command _enableScheduler is called. It does not, 
however, affect system tasks. The time watchdog for cyclic tasks is not suspended.  

 

  Note 
The also prevents the activation of the SystemInterruptTasks and UserInterruptTasks. 
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5.2.8 Device diagnostics: Checking the system utilization 
To display the system utilization:  
● Select the System utilization tab in the device diagnostics. 

 
Figure 5-11 Example of the system utilization display in the device diagnostics 

The utilization of the following system resources is displayed: 

RAM disk 
After the download, the RAM disk contains the hardware and device configuration, 
technology packages, configuration data of the technology objects, and the program units. 
Use Copy RAM to ROM to copy the contents of the RAM disk to the memory card and 
release the memory on the RAM disk. During subsequent downloads, only modified data is 
loaded to the RAM disk.  
The RAM disk or the memory card also contains the user data that was created from the 
user program using file system functions. Copy RAM to ROM applies only to the project data 
from the download. 

RAM 
After the controller powers up, the RAM contains the code and the data of the technology 
objects (technology packages and data of the instanced technology objects) and the 
executable program units. 

Memory card 
Memory card (ROM) memory 



 Diagnostics 
 5.2 Using diagnostic functions 

SIMOTION SCOUT 
Configuration Manual, 03/2007 Edition 123 

Retentive files 
Non-volatile memory of the SIMOTION device 

CPU utilization due to system tasks 
Here, the utilization due to system tasks (servo, IPO, IPO2, TControl, DCC) and due to 
synchronous user tasks (ServoSynchronousTask, IPOsynchronousTask, 
IPOsynchronoursTask_2). 
Various problems arise with a CPU utilization of about 70% and higher, such as sporadic 
connection terminations with the PG. A utilization of 80% or higher is considered critical, as it 
can result in level overruns of important tasks (level overruns lead to CPU STOP with the 
operating mode transition or "BZU" blocked). 

 

 Note 
Do not operate the SIMOTION device at more than 60% utilization in order to maintain a 
reserve for load fluctuations and peak loads. 

 
The data listed above are displayed as:  
● Diagram 
● Absolute value for the maximum value 
● Utilization (KB or bytes) 
● Percentage value 

Free cycle of the background level 
The user cycle time for the background task is displayed in ms with the: 
● Minimum value 
● Maximum value 
● Current value 
The cycle time of the background task is a measure of one round of all active round-robin 
tasks (communication, motion tasks). 
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Utilization 
The display in the utilization area contains additional information on the system utilization: 
● I/O controller: 

For C2xx and P350: 
Displays the processor utilization of the integrated I/O controllers due to the cyclical and 
acyclical communication with the centralized and distributed peripherals as well as due to 
the communication with IBN and B&B devices. 
Values > 90% are critical and indicate problems, due to, for example, 
– the data volume of the configured process peripherals (centralized and distributed) 
– the types of modules on the central peripherals 
– the cycle times on the isochronous PROFIBUS segment 
– the dynamic load with acyclical orders from the user program (_read/writeRecord, 

_read/writeDriveParameter, etc.) 
– the dynamic load due to communication with IBN and B&B devices 

 
For D4x5: 
Displays the processor utilization of the integrated I/O controller. 
Values > 90% are critical and indicate problems, due to, for example, 
– the dynamic load with acyclical orders from the user program (_read/writeRecord, 

_read/writeDriveParameter, etc.) 
– the dynamic load due to communication with IBN and B&B devices 
– the drive regulation of the SINAMICS integrated (number of axes). 

 
For D410: 
Value has no relevance. The utilization due to cyclical and acyclical communication is 
included in the CPU utilization. 
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● Round robin: 
Shows the computing time of the SIMOTION processor in the round robin level, in which 
the background task, motion tasks and some system tasks run. 
Values > 90% are critical and indicate continuous loops in motion tasks or computing-
intensive portions in the background task. As a result, communication and diagnostic 
functions and the HMI connection become very slow. 
Solution:  
MotionTasks, which run endlessly with a WHILE / REPEAT loop, and thus cyclically, 
place a burden on the round robin level. Each MotionTask thus takes up the entire servo 
cycle clock.  
Alternatively, a _waitTime(0ms) should be inserted at the end of the loop. Then the 
MotionTask releases the computing time after one loop cycle to the next MotionTask or 
BackgroundTask and thus does not use it unnecessarily.  
The control statement WAITFORCONDITION and the step enabling conditions for 
"Delay program execution" likewise release the computing time to the next round robin 
task. 
The use of _waitTime (0 ms) can also be helpful with a computing-intensive background 
task. 

● Communication: 
The utilization of the communication buffer for the communication with IBN and B&B 
devices is displayed here, e.g., for SCOUT or HMI. 90% should not be exceeded here. 

● I/O copying time: 
For C2xx and P350: 
Here, the time portion of the copying actions of the integrated I/O controller for the 
cyclical communication (centralized and distributed) is displayed in relation to the 
configured servo cycle clock.  
The display value is calculated one time for each BZ transition and change in the 
peripheral arrangement (e.g., station failure/restore). For a value > 65% in operating 
mode RUN or 55% in operating mode STOP, a diagnostics buffer entry "cycle 
overload, reason n" is triggered (n=1: RUN, n=2: STOP). In these cases, the system 
should be relieved by increasing the servo cycle clock. 
For D4xx: 
Value has no relevance. 

● I/O cycle time: 
For C2xx and P350: 
The utilization of the I/O processor due to the cyclical communication is displayed and 
thus also the proportion of time of the configured PROFIBUS cycle clock required for a 
servo cycle clock cycle. This proportion of time includes the duration of the transfer of 
cyclical data (data exchange) on the synchronous PROFIBUS DP, the subsequent 
reading in of the input data, the runtime of the servo task in its regulating technology 
portion as well as the output of the output data (target values) to the peripheral interface 
and thus the preparation for the transport in the next DP cycle. 
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For D4xx: 
The maximum utilization of a cycle is due to cyclical system tasks since activation is 
displayed here. High values (e.g., > 90%) with low CPU utilization indicate only sporadic 
loads due to system tasks. An IPO overrun should therefore be tolerated. 
 
The following applies to all platforms: 
If the I/O cycle time is greater than the cycle time of the isochronous PROFIBUS DP, then 
a diagnostics buffer entry "Error in cyclical operation, reason 5, note n" is triggered.  
The indicating parameter n can have the values 1, 10, 100 and 1000 and thus signals the 
nth event of a cycle overrun. The frequency of the overruns can be calculated from the 
time interval of the entries. Isolated overruns in larger time intervals can be tolerated as 
long as they do not result in any negative effects on the technology.  
In principle, however, the system should be relieved by increasing the DP cycle time. 
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5.2.9 Device diagnostics: User log file 
With the Userlog file, you can store your own text strings in the RT system. This is 
necessary, for example, when changes, which are to be documented, are made in the 
SIMOTION system on a plant which has already been commissioned.  
Changes can be written in the SIMOTION SCOUT. These are loaded to the ROM of the 
target device. When required, the text strings can be read out again. The text editor for the 
Userlog file is integrated as a tab in the device diagnostics snap-in. This function is only 
available in online mode.  

 
Figure 5-12 Example of the Userlog file display in the device diagnostics 

How to work in the Userlog file 
● Select the Userlog tab in the device diagnostics. 

The editor is in editing mode, i.e., you can immediately type or delete. 
The system adds no further system contents, such as date/time.  
You enter all of the necessary information. 

● To save, click Save as... The Userlog file is stored as .txt. 
All text entries can be changed or deleted at any time.  
Access protection is not available. 

● The Userlog file can also be read without a project. 
The online mode is required for this. 

● The Userlog file remains after user data are deleted. 
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5.2.10 Device diagnostics: Syslog file 
In addition to the user-defined Userlog file, the SIMOTION device also has a Syslog file. The 
ROM actions entered therein facilitate a subsequent diagnosis. This function is only available 
in online mode. The information of the Syslog file can also be read without a project.  
The Syslog file logs the following actions: 
● RAM2ROM 
● Overall reset 
● Formatting of the card from SIMOTION SCOUT 

 
Figure 5-13 Example of the Syslog file display in the device diagnostics 
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5.2.11 Device diagnostics: Version overview 
The version overview tab displays the SIMOTION version and the data of the SIMOTION 
device stored in the CompactFlash card.  
The following data are displayed: 
● SIMOTION version 
● BIOS version 
● Components 

Versions of the SINAMICS components 
● Internal version / stamp 

Internal components 
This information is relevant for any questions to the hotline. 

 
Figure 5-14 Example of the version overview display in the device diagnostics 

5.2.12 Displaying and acknowledging alarms and messages 
In online mode, the pending alarms and configured messages are displayed in the Alarms 
tab of the detail view. Detailed information can be found in the SIMOTION online help. 
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5.2.13 Accessible nodes 
A list of the accessible SIMOTION devices is displayed via the Accessible nodes function in 
the working area of SIMOTION SCOUT.  
A SIMOTION project must not be open in order to use this function. 
Follow the steps outlined below: 
1. Select the Project > Accessible nodes menu. 
2. Select the corresponding node. 
3. Right-click and select the following functions in the context menu. 
● Operating mode ... 
● Device diagnostics ... 
● Copy from RAM to ROM ... 
● Licenses 
● Log files 
● Archived project 
● SINAMICS Upload 

5.2.14 Program testing and debugging 
Comprehensive program testing and debugging functions are available in SIMOTION 
 SCOUT. You can execute the following functions: 
● Control variable 
● Program status 
● Breakpoints 

Additional references 
Please refer to the following documents on this subject: 
● SIMOTION ST Structured Text, Programming Manual 
● SIMOTION MCC (Motion Control Chart), Programming Manual 
● SIMOTION LAD/FBD, Programming Manual 
● SINAMICS/SIMOTION DCC Editor Description, Programming and Operating Manual 
and the SIMOTION SCOUT online help. 
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FAQs 6
6.1 Handling Recommendations for Service with SCOUT V4.1 

6.1.1 Selecting the right project with SCOUT V4.1 
The observation of the following recommendations for the configuring simplifies maintenance 
work. 

Working with the right project 
In order to ensure that you are always working with the right project, save the revised and 
archived project as a zip file on the CF card.  
Each time you work with the project, use only this zip file.  
The project data can be archived on a memory card in SCOUT. 

 
Figure 6-1 Archive SIMOTION project to card 

The accessible nodes function can be used to determine on which CPU a Project.zip is 
stored. 
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Load the project from the memory card. 
The project data archived on the memory card can be transferred to "PROJEKT.ZIP" on the 
hard disk of the PG/PC in the Accessible Nodes view via context menu (right mouse button).  
Alternatively, the SCOUT function is also available in the context menu 
Load project from card... on the device. Next, the archive project transferred to the hard disk 
must be dearchived. 

Use routing 
The following must be considered in order to be able to use routing (e.g., for access to 
SINAMICS_Integrated with SIMOTION D4x5):  
● If the project should be generated on another computer, a  

PG/PC assignment is necessary. The PG/PC has the unique "computer name" of the 
creation system and this must be adapted to the current system. 

● This change can be made directly using the Assign PG/PC toolbar button. 

The Log Files as Further Help 
The Syslog file and the Userlog file are also available to help verify the project (as 
of Runtime V4.0). These files are stored on the memory card can can be read out, for 

example, without a project on the PG/PC using the SCOUT function 
Accessible Nodes.  
The log files on the memory card are directly accessible from the dialog box (via context 
menu). 

 
Figure 6-2 Log files via the context menu 

● user\simotion\hmi\syslog\syslog.000 
System logbook: The system makes an entry here when a RAM TO ROM, an overall 
reset or a reformatting of the memory card is carried out. 

● user\simotion\hmi\prjlog\userlog.txt 
Machine logbook: It is possible here to document the tasks carried out and the SCOUT 
version used for the next service worker. Call for editing from the SCOUT dialog box 
Device diagnostics. 
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Below are other data, which are stored on the memory card and can be accessed from this 
dialog box: 
● USER/SIMOTION/HMI/PRJLOG/info.txt  

is created with the archived ES project and contains the name, variable, save date. 
● USER/SIMOTION/HMI/PRJLOG/project.zip 

archived ES project. Max. 1 archived project can be archived on the memory card using 
SCOUT. 

The above-named files visible in the dialog box also remain on the memory card after 
Delete user data. 
For a detailed description, please refer to: 
● SCOUT Online Help -> Device diagnosis: Syslog / Userlog 
● Device Diagnosis section: User log file 
● Device Diagnosis section: Syslog file 

6.1.2 Project was created in Version V3.2 SP1 / V4.0 
If the project was created in Version V3.2 SP1 / V4.0, remember the following points:  
● When opening a project created in an older version of SCOUT using SCOUT V4.1, a 

conversion of the project to SCOUT's current internal data format is automatically 
requested. 
Only the data content of the SCOUT project is converted to V4.1, not the SIMOTION 
device version. 

● After the project conversion, the system asks whether the project should be opened write-
protected. 
If the project needs to be changed, the write protection can also be revoked later. 
– Select Project > Revoke write protection from the menu bar.  
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6.1.3 Project V3.2 SP1 / V4.0 was edited with SCOUT V4.1 
If the project of versions V3.2 SP1 / V4.0 was edited with SCOUT V4.1, remember the 
following points: 
● The project can be saved back in the original project version when closing the projects, 

exiting SCOUT or by selecting the SCOUT function Save in old project format.... This 
makes it possible to edit the project later using the corresponding SCOUT version again. 

 

  Note 
In case of a back-conversion to the V3.2 SP1 / V4.0 project format, the internal V4.1 
conversion results of the changed sources are deleted! 
This means that after the project has been opened again and the online connection 
made, the changed sources are inconsistent (shown in red). 
Only after the compilation and download are completed are the sources consistent again 
(shown in green). 
This is due to the editing with different SCOUT versions, which contain different compiler 
versions. 

● If the project was opened write-protected for diagnostic purposes or if no changes were 
made in non-write protected mode, then it need not be saved. 
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Recommendation 
After editing an old project version using SCOUT V4.1, the engineering project should 
remain in Version V4.1. This eliminates the need to back-saving in the old project format so 
that the project remains consistent at all times.  
The engineering project is then no longer available in the old project version. 
After the project changes are completed, they should be documented in the Userlog file. 
The Userlog file is edited in the device diagnostics dialog box. 

 
Figure 6-3 Example of the User log file display 
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6.1.4 Introduction of versioning with standard library and software components 
It is possible to introduce versioning for any standard library and any software component 
during configuration, i.e., each component then has its own version identifier.  
● For every unit and every library the version, author and a brief description in the 

comments field (offline version identifier) in the Properties dialog box in 
SIMOTION SCOUT. 

● Each library and each software component can disclose its version identifier during 
runtime (online version identifier identical to offline version identifier). 
– Version identifier as constant(s) or 
– Version identifier as function return value, e.g. FCGetVersion. 

● The version identifiers can be displayed separately on the available HMI systems, i.e., 
self-identification of all involved system components. 

● A simple variant for applying versioning is in a date identifier as a constant in the format 
yyyy-mm-dd. This can be assigned to a variable, which is then, for example, passed on to 
HMI systems for the version display. 
 
Example, date identifier: 

 
VAR_GLOBAL CONSTANT  
 APP_VERSION : UDINT := 20060612; // 12.06.2006 
END_VAR  
 
VAR_GLOBAL  
 G_uAppVersion : UDINT := APP_VERSION; 
END_VAR  
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6.2 Rules for the arrangement of the modules 

Slot rules 
Modules must be inserted in the rack without gaps.  
Exception:  
Slot 3 remains empty in the configuration table. This slot is reserved. 

 

 Note 
The actual arrangement has no gaps, as otherwise the bus on the backplane would be 
interrupted. 

 
 

Table 6-1 Slot rule for SIMOTION rack 0 

Slot 1:  Power supply only PS 307 xA 
(valid only for SIMOTION C2xx) 

Slot 2: CPU only (e.g. SIMOTION C2xx) 
Slot 3: Empty or interface module 
Slots 4 to 11: I/O modules or empty 

SIMOTION SCOUT provides the following support when you configure a station:  
● A message will appear if, for example, a module cannot be inserted into the desired slot. 
● Address areas are also checked to prevent dual allocation of addresses. 
● The status bar or messages displayed provide feedback, which you should pay attention 

to. Important information can also be found in the help. 
● Temporary rules, that is, rules that apply only to a specific version, are not considered 

(such as restriction of the useable slots due to a functional restriction for individual 
modules). 

Consult the documentation or the current product information for the modules. 
 

 Note 
Modules that are installed but not configured are repeatedly addressed via the PROFIBUS. 
This requires additional computing time.  
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6.3 Routing 

6.3.1 Operation of cross-subnet connections 

Introduction 
With SCOUT and STEP 7, it is possible to access SIMOTION, drives and S7 stations online 
via a PG/PC beyond the subnet boundaries, in order to, for example, load user programs or 
a hardware configuration or to perform test and diagnostics functions. You can connect this 
PG/PC to any position in the network and establish an online connection to all stations that 
can be reached via gateways. 
For more details on this topic, see the following document: 
● SIMOTION Communication, System Manual 

6.3.2 Human Machine Interface system (HMI) 
SIMOTION allows the end user to communicate with operating devices (Human Machine 
Interface systems) such as operator panels.  
The following constellation is possible, for example, with the SIMOTION C230-2:  
● HMI device is connected to the non-isochronous PROFIBUS of SIMOTION device 1. 
● Four other SIMOTION devices are connected to the PROFIBUS DP (isochronous) of 

SIMOTION device1. 
SIMOTION automatically also establishes connections between the HMI device and 
SIMOTION devices 2 to 5 (routing). Therefore, the HMI device can also display variables, 
messages, and alarms for these devices. 

 

 Note 
The number of routed connections depends on the device. Between 4 and 10 routed 
connections are possible. For more detailed information, see Data volume. 
A maximum of two gateways are possible. 
For more information, please contact your local Siemens representative. 
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Figure 6-4 Example for the connection of an HMI device to a group of SIMOTION devices 

 

 Note 
Routing via a controller, e.g. C2xx, P350 or D4x5, is only possible if the controller has been 
configured as active I-slave. However, please note that with an active I-slave, the 
PROFIBUS connection can no longer be operated isochronously. 
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6.3.3 Higher-level automation systems 
A SIMOTION device can be connected to a higher-level automation system. Communication 
takes place via the MPI interface of the SIMATIC STEP 7 device or the non-isochronous 
PROFIBUS interface of the SIMOTION device. 

 
Figure 6-5 Higher-level automation system with SIMOTION device  
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6.4 Inserting drives 

6.4.1 Drives with SIMOTION 

Note the following:  
Drives must be differentiated between: 
● Drives that are connected to PROFIBUS/PROFINET 
● Drives that are connected directly to the SIMOTION device 
The following applies to drives connected to PROFIBUS/PROFINET: 
● Only drives that meet the requirements of PROFIdrive profile V3.0 can be connected: 

– SINAMICS 
– MICROMASTER (PROFIBUS only) 
– COMBIMASTER 411 (PROFIBUS only) 
– MASTERDRIVES (MC, VC) (PROFIBUS only) 
– SIMODRIVE 611U (PROFIBUS only) 
– SIMODRIVE POSMO (CA, CD, SI) (PROFIBUS only) 
– ADI4 (analog drive interface for 4 axes) 
– IM 174 (Interface Module for 4 axes) 

● These drives are taken into the hardware configuration. 
● The drives of the SINAMICS and MICROMASTER drive families can be configured, 

assigned parameters, and commissioned with SIMOTION SCOUT. 
All analog drives can be connected via one of the four analog interfaces on the 
SIMOTION C2xx or via the ADI4 PROFIBUS module. 
● These drives are not taken into the hardware configuration. 
● The SIMOTION device requires only the actual values from the encoder at the input and 

issues the setpoints at the analog output. 
● The drives must be configured, assigned parameters, and commissioned directly on the 

corresponding device. 
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6.4.2 Inserting a SINAMICS drive on PROFIBUS DP 

Starting point 
● The SIMOTION device is created in SIMOTION SCOUT 
● A PROFIBUS subnet has been configured, for example, as PROFIBUS DP isochronous. 
● The subnet interface is the master on this subnet of the SIMOTION device 

Follow the steps outlined below: 
1. Open the PROFIBUS DP folder in the hardware catalog. 
2. Open the SINAMICS subfolder. 
3. Use drag-and-drop to drag an entry to the isochronous PROFIBUS subnet of the 

SIMOTION device. 

 
Figure 6-6 Inserting a SINAMICS drive 
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6.4.3 Inserting a SINAMICS drive on PROFINET IO 

Starting point 
● SIMATIC STEP 7 V5.4 SP2 is installed 
● The SIMOTION D4x5 device with Ethernet IE2/NET (X130) interface selection has been 

created in SIMOTION SCOUT 
● A PROFINET IO has been configured 

Follow the steps outlined below: 
1. Open the HW Config of the SIMOTION D4x5 device. 
2. Open the PROFINET IO/Drives/SINAMICS folder in the hardware catalog. 
3. Select the SINAMICS S120 CBE20 drive. 
4. Use drag-and-drop to drag the drive to the PROFINET IO subnet of the 

SIMOTION device. 

 
Figure 6-7 Inserting a SINAMICS drive with PROFINET 
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6.4.4 Inserting a MICROMASTER drive 

Initial situation:  
● The rack with the SIMOTION device has been inserted. 
● A PROFIBUS subnet has been configured, for example, as PROFIBUS DP isochronous. 
● The subnet interface is the master on this subnet of the SIMOTION device 

Follow the steps outlined below: 
1. Open the PROFIBUS DP folder in the hardware catalog. 
2. Open the SIMOVERT subfolder and then the MICROMASTER 4 subfolder. 
3. Use drag-and-drop to drag an entry (e.g. MICROMASTER 420) to the isochronous 

PROFIBUS subnet. 

 
Figure 6-8 Inserting a MICROMASTER 4 drive 

A window appears in which you can configure the PROFIBUS interface of the drive. 
 

 Note 
Although the MICROMASTER 420 does not support isochronous operation, it can be 
operated on the isochronous PROFIBUS subnet. Note that the drives of all synchronous 
axes have to be connected to the same PROFIBUS subnet. 
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6.4.5 Inserting a MASTERDRIVES drive 

Initial situation:  
● The rack with the SIMOTION device has been inserted. 
● A PROFIBUS subnet is configured as PROFIBUS DP isochronous. 
● The PROFIBUS interface is the master on this subnet of the SIMOTION device. 

Follow the steps outlined below: 
1. Open the PROFIBUS DP folder in the hardware catalog. 
2. Open the SIMOVERT subfolder. 
3. Use drag-and-drop to drag an entry to the isochronous PROFIBUS subnet of the 

SIMOTION device. 

 
Figure 6-9 Inserting a MASTERDRIVES drive 
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6.4.6 Inserting a SIMODRIVE drive 

Initial situation:  
● The rack with the SIMOTION device has been inserted. 
● A PROFIBUS subnet is configured as PROFIBUS DP isochronous. 
● The PROFIBUS interface is the master on this subnet of the SIMOTION device. 

Follow the steps outlined below: 
1. Open the PROFIBUS DP folder in the hardware catalog. 
2. Open the SIMODRIVE subfolder. 
3. Use drag-and-drop to drag an entry to the isochronous PROFIBUS subnet of the 

SIMOTION device: 
– SIMODRIVE 611 universal 
– SIMODRIVE POSMO xx 

 
Figure 6-10 Inserting a SIMODRIVE 611U drive 

A window appears in which you can configure the PROFIBUS interface of the drive. 
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6.4.7 Configuring an inserted drive as a slave on the PROFIBUS 

Follow the steps outlined below:  
Once you have inserted the drive, the following  
DP interface configuration window appears:  
1. Specify the address. 

 
Figure 6-11 Configuring the PROFIBUS interface on the drive 

2. Confirm with OK. 
A further window for configuring the drive as a DP slave appears. 

3. Make the necessary settings. 
4. Click OK to confirm. 

 
Figure 6-12 Configuring the SIMODRIVE 611U as a PROFIBUS slave 
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Figure 6-13 Example of a hardware configuration with 4 drives 
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6.5 Commissioning the drives 

Drives that can be commissioned with SIMOTION SCOUT 
You can use SIMOTION SCOUT to assign parameters to the following drives: 
● SINAMICS 
● MICROMASTER 
● COMBIMASTER 411 
For all other drives or for third-party drives, the appropriate commissioning program for the 
specific drive must be used (e.g. the SIMOCOM U program for SIMODRIVE 611U). If 
required, you must commission these drives directly on the drive. 

Table 6-2 Commissioning of various drives 

Drive Connection Commissioning 
SINAMICS S120, S150, 
G110 CPM100, G120, G130, 
G150, GM150 

PROFIBUS DP or analog 
interface 

With SIMOTION SCOUT or  
STARTER 

SINAMICS S120 PROFINET With SIMOTION SCOUT or  
STARTER 

MICROMASTER 410 Analog interface With SIMOTION SCOUT or  
DRIVE ES Basic or  
STARTER 

MICROMASTER 
420/430/440 

PROFIBUS DP or 
analog interface 

With SIMOTION SCOUT or  
DRIVE ES Basic or  
STARTER 

COMBIMASTER 411 PROFIBUS DP or 
analog interface 

With SIMOTION SCOUT or  
DRIVE ES Basic or  
STARTER 

SIMODRIVE 611U PROFIBUS DP or analog 
interface 

With SIMOCOM U or  
DRIVE ES Basic 

MASTERDRIVES MC, VC PROFIBUS DP or analog 
interface 

With SIMOVIS or  
DRIVE ES Basic 

SIMODRIVE POSMO  
CA; CD, SI 

PROFIBUS DP With SIMOCOM U or  
DRIVE ES Basic 

Third-party drives Analog interface or  
PROFIBUS DP 
according to PROFIdrive 
profile V3.02 

With commissioning tool supplied by the 
manufacturer 

 
 

 Note 
If the Drive-ES Basic commissioning program is installed, it can be called by SIMOTION 
SCOUT in the project navigator via Commissioning. 
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6.6 SINAMICS on SIMOTION 

6.6.1 SINAMICS S120 on SIMOTION 

STARTER functionality in SIMOTION SCOUT 
It is possible to parameterize drives directly with SIMOTION SCOUT. As an example, the 
following is a description of how a SINAMICS_Integrated drive is inserted in 
SIMOTION SCOUT. 

Prerequisites: 
● SIMOTION SCOUT has been installed on the PC/PG 
● A SIMOTION SCOUT has been created 

 

  Note 
You can create the SINAMICS drive with PROFIBUS or PROFINET. 

You must execute the following steps: 
● Insert SIMOTION device D4x5 or SIMOTION device D410 
● Configure SINAMICS_integrated 

Commissioning in SIMOTION SCOUT 
1. Open the SIMOTION project in SIMOTION SCOUT. 
2. Double-click Create new device. 
3. Select a SIMOTION D4xx device. 
4. Select the variant. 
5. Deactivate the Open HW Config box. 
6. Confirm withOK. 
7. Select the PROFIBUS interface or Ethernet. 

If you have selected Ethernet, select the interface parameterization of the PG/PC. 
8. Confirm withOK. 
9. Open the structure tree of the SIMOTION D4xx device in the project navigator. 
10. Open the structure tree of the SINAMICS_Integrated drive in the project navigator. 
11. Double-click Configure drive unit. 

The Configuration - SINAMICS_Integrated - Option Module window opens. 
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The STARTER functionality now starts in SIMOTION SCOUT.  
How to configure the SINAMICS_Integrated drive is described in detail in the following 
documents: 
● SIMOTION D4x5 Commissioning Manual 
● SIMOTION D4x5 Product Manual 
● SIMOTION D410, Commissioning Manual 

6.7 MICROMASTER on SIMOTION 

6.7.1 Commissioning a MICROMASTER 

STARTER functionality in the SIMOTION SCOUT 
Drive parameters can be assigned directly using SIMOTION SCOUT (starter functionality in 
SIMOTION SCOUT). The commissioning of the MICROMASTER 420 is described as an 
example.  

Requirements: 
● SIMOTION SCOUT installed on PC/PG. 
● PC/PG is connected to drive. 
● SIMOTION SCOUT is in online mode. 

 

CAUTION  
 

You can only commission the drive in online mode! 
All configuration data is stored in the drive RAM and is lost when the drive is switched 
off. You must therefore save this data to the drive ROM with Copy RAM to ROM. The 
appropriate drive must be selected. 
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6.7.2 Commissioning in SIMOTION SCOUT 

6.7.2.1 Drive navigator 
The drive navigator appears in the project navigator tree directly below the drive. It is 
designed as a snap-in. You can use the drive navigator for: 
● Configuration 
● Terminals/bus 
● Limits 
Proceed as follows: 
1. Open the structure tree of the MICROMASTER_420 device in the project navigator. 
2. Double-click drive navigator. 

The snap-in opens in the working area of SIMOTION SCOUT. 
3. Maximize the window view in the working area. 

 

  Note 
The content displayed for the individual drive versions is the same in offline and online 
mode. Any options not available in a certain mode are grayed out. This function is then 
not active in that mode. This means that you have a complete overview of the possible 
functions at all times. 

4. Configure the drive. 
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6.7.2.2 Configuring a drive 

Configuring a drive 
 

CAUTION  
Use the drive configuration wizard to directly edit the drive data. 
When you exit a window, the data is transferred to the drive immediately. A Cancel function 
is not available! 

 

Requirement: 
● You have inserted a drive into the project.  

Proceed as follows: 
1. Open the element (folder) for the drive unit in the project navigator. 
2. Open the drive element below the folder. 
3. Double-click the Configuration element. 

The most important configuration data is displayed in the window. 
4. Click Reconfigure drive. 

A prompt appears asking you to confirm that you wish to reconfigure the drive. 
5. Confirm the prompt with Yes. 

The wizard for configuring the drive is started. 
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Figure 6-14 Configuring the MICROMASTER 420 

You are now in the Drive Configuration - MICROMASTER 420 - Standard window: 
6. Select the appropriate standard. 

Default setting: Europe [kW], standard frequency 50 Hz (0). 
A message appears. 

7. Read this message and click OK to confirm. 
8. Click Next >. 

You are now in the Drive Configuration - MICROMASTER_420 - Motor window: 
9. Select the appropriate data. 
10. If required, activate the Additional motor data function. 
11. Click Next >. 

You are now in the Drive Configuration - MICROMASTER_420 - Motor Data window: 
12. Enter the appropriate data. 
13. Click Next >. 

You are now in the Drive Configuration - MICROMASTER_420 - Operating Mode window: 
14. Select the appropriate operating mode. 
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15. Click Next >. 
You are now in the Drive Configuration - MICROMASTER_420 - Command/Setpoint 
Source window: 
Several sources may be offered simultaneously for selection of the speed setpoint. The 
meaning of the entries is as follows: 
– First entry: Main setpoint 
– Second entry: Additional setpoint 

16. Select the appropriate data. 
17. Click Next >. 

A message appears. 
18. Read this message and click OK to confirm. 

You are now in the Drive Configuration - MICROMASTER_420 - Most Important 
Parameters window: 

19. Enter the appropriate data. 
20. Click Next >. 

You are now in the Drive Configuration - MICROMASTER 420 window for completing the 
drive configuration: 

21. Check the data entered. 
22. Click Finish. 

The drive configuration is completed. 
23. Click Close. 
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6.7.2.3 Configuring the drive terminals/bus 
Here you define the following:  
● The assignment of the input and output terminals to the parameters of the drive. 
● The calibration of the analog-digital converter and the digital-analog converter. 
● When BICO parameter assignment is enabled, the Digital inputs tab is only used to 

display the connections. The interconnection itself is made with the appropriate function. 
● In the Signal interconnection tab, assign the input parameters to the signal sources. 
Proceed as follows: 
1. Open the element (folder) for the drive unit in the project navigator. 
2. Open the drive element below the folder. 
3. Double-click Terminals/Bus. 
4. Configure the inputs and outputs. 
5. Configure the USS/PROFIBUS interface 

 

CAUTION  
 

The signal interconnection input window is intended only for use by experts who are 
familiar with BICO technology and the MM4 parameter assignment options. 
Parameter changes are not checked for plausibility. Incorrect entries may affect the 
functioning of the drive. 

6. Change the signal interconnection, if required. 
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Figure 6-15 Configuring the drive interfaces 

6.7.2.4 Configuring the USS and PROFIBUS interfaces 
Use this tab to configure the interfaces only. You do not define whether they are used for 
communication.  
Procedure for changing station addresses or baud rates. 
If you have changed the station address or the baud rate of the interface used for 
communicating, test the communications.  
Proceed as follows: 
1. Disconnect the SIMOTION SCOUT from the target system. 
2. If you: 

– Have changed the station address: 
Change the station address of the drive in the Properties dialog box of the drive unit or 
in the hardware configuration. 

– Have changed the baud rate: 
Select menu Options > Set PG/PC interface and configure the interface of your PC 
accordingly. 
If you want to use the USS interface, you must install this. 
In the PG/PC Interface window, click Select and install the PC COM-Port (USS) 
module. 

3. Reconnect SIMOTION SCOUT to the target system. 
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6.7.2.5 Parameterizing setpoints and limits 
The following submenus are used for the complete parameterization of setpoints and limits:  
● Limits 
● Extended 

– Motor potentiometer (MOP) 
– Fixed frequencies 
– PID controller 
– Setpoints 
– Shutdown functions 
– Start functions 
– Functions (slip compensation, programmable V/f characteristic) 

Parameterizing limits 
Deactivate the PID controller before parameterizing the ramp function generator. Otherwise 
this has no effect. 

6.7.3 Controlling drives 
You can use SIMOTION SCOUT to control the configured drive. Use the control panel for 
this purpose. This is displayed as a detail view tab. Drives can only be controlled in online 
mode.  

 

DANGER  
Before the motor turns for the first time, pay special attention to the following potential 
hazards:  
Make sure that the motor is connected correctly! 
Secure the surrounding area:  
Secure the motors! Do not release the magnetic motor brake of vertical axes without a 
safeguard! 
Set the limit values! Bring the axes to neutral position! Choose low velocities and speeds! 
Observe general accident prevention guidelines! 
The function is released exclusively for commissioning and service purposes. The safety 
shutdowns from the higher-level control have no effect. 
The function should only be used by authorized technicians. 
The "Emergency stop with space bar" function is not guaranteed in all operating modes. 
Therefore, there must be an EMERGENCY STOP circuit in the hardware. The appropriate 
measures must be taken by the user. 
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Follow the steps outlined below: 
1. Open the element (folder) for the drive unit in the project navigator. 
2. Open the drive element below the folder. 
3. Double-click the Control panel element. 

The control panel is displayed in the detail view. 
4. Select the drive that you want to control. 
5. Select the relevant checkbox: 

– Control: 
You switch the drive and control its speed. 

– Enables and actual value: 
You monitor setpoints and actual values as well as enables and alarms. 

– Links to status info:  
You can switch to the drive diagnostics. 

 
Figure 6-16 Controlling drives with SIMOTION SCOUT 
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Switching the drive and controlling its speed 
Follow the steps outlined below:  
1. Activate the Control checkbox. 
2. Click Assume control priority. 
3. Move the slider to the left. 
4. Activate the Enables (bit 1 to bit 6) checkbox. 
5. Switch on the drive: Click the I button. 
6. Use the slider to control the speed. 
To switch off the drive: 
● Click the O button. 
● Press the space bar. 

 

CAUTION  
 

Make sure that all windows in the working area are closed. Otherwise, delays may occur 
between the entry of the control command on the PC and its execution by the drive! 

Monitoring enables and actual values 
● The speed setpoint and actual speed value are displayed constantly.  
● Select two additional parameters for display. These parameters are displayed below the 

selection box. 
● The enables and alarms are displayed. 
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6.7.4 Using the drive diagnostics 

Diagnostics in SIMOTION SCOUT 
You can use the drive diagnostics to check the communication connection between 
SIMOTION SCOUT and the drive and to display individual control words and status words as 
well as the operating mode.  
You cannot change any system parameters. The display is only used for the diagnostics. 
Proceed as follows: 
1. Open the element (folder) for the drive unit in the project navigator. 
2. Open the drive element below the folder. 
3. Double-click Diagnostics. 
4. Select the relevant tab. 

 
Figure 6-17 Drive diagnostics with SIMOTION SCOUT - Control/status word tab 
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Table 6-3 Drive diagnostics tabs 

Tab Meaning 
Control/status word Bit allocation of: 

• Control word 1 
• Control word 2 
• Status word 1 
• Status word 2 

Operating conditions Important parameters and operating modes of the drive 
Status parameters Important system variables of the drive 
USS/PROFIBUS Define the communications interface in this tab; you can also monitor 

the values for the individual control words and status words. 

 
Figure 6-18 Drive diagnostics with SIMOTION SCOUT - Operating conditions tab 
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6.7.5 Using the expert list 

Expert list for experienced users 
 

CAUTION  
The expert mode is intended for experienced users. Incorrect entries may affect the 
functioning of the drive. 
The system does not carry out any plausibility checks. 

 
The expert list for drives is different from the expert list for technology objects. 
1. Open the element (folder) for the drive unit in the project navigator. 
2. Open the drive element below the folder. 
3. Select Expert > Expert list in the shortcut menu. 
4. Enter the required values. 

 
Figure 6-19 Expert list for drive commissioning - display of an array 
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6.8 MICROMASTER in Conjunction with a Positioning Axis 

6.8.1 MICROMASTER MM4 in connection with a position axis 

Introduction 
This section describes how to integrate the MICROMASTER MM4 as a drive in 
SIMOTION SCOUT. 
In the following example, the MICROMASTER MM4 is controlled via standard message 
frame 1. 
Communication from SIMOTION: 
● Word 1, Control word 
● Word 2, Speed setpoint 
Communication to SIMOTION: 
● Word 1, Status word 
● Word 2, Actual speed value 

6.8.2 Parameterization steps 
This section describes how to integrate the MICROMASTER MM4 as a drive in 
SIMOTION SCOUT. 
In the following example, the MICROMASTER MM4 is controlled via standard message 
frame 1. 
Communication from SIMOTION: 
● Word 1, Control word 
● Word 2, Speed setpoint 
Communication to SIMOTION: 
● Word 1, Status word 
● Word 2, Actual speed value 
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Integrating MICROMASTER MM4 in HW Config 
1. Select the SIMOTION device in the project navigator. 
2. Open HW Config. 
3. Insert a MICROMASTER MM4 into a PROFIBUS subnet. 
4. Once you have inserted the drive, select Standard message frame 1, PZD-2/2. 
5. Save and compile the hardware configuration. 
6. Download the hardware configuration to the SIMOTION device. 
7. Create a TO axis in SIMOTION SCOUT. 

Inserting a virtual axis 
1. Insert a virtual axis into the project navigator of SIMOTION SCOUT. This will be 

converted to a real axis via the expert list when the axis wizard is completed. 

Changes in the expert list 
1. Select the virtual axis in the project navigator. 
2. Open the expert list via the shortcut menu. 
3. Open the following directory in the expert list:  

ConfigurationData\TypeOfAxis 
4. Make the following setting: 
● TypeOfAxis = REAL_AXIS (0) 
 

 
Figure 6-20 Expert list: Setting a virtual axis 
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Assigning encoders 
● NumberOfEncoders/Encoder_1/encoderidentification = ONBOARD (1), set EncoderType, 

EncoderMode and EncoderSystem according to the encoder 
● NumberOfEncoders/Encoder_1/DriverInfo/LogAddressIn = 128 (or 160, 192, 224) 
● NumberOfEncoders/Encoder_1/DriverInfo/LogAddressOut = 128 (or 160, 192, 224) 
● NumberOfEncoders/Encoder_1/DriverInfo/TelegramType = NO_TELEGRAM (0) 
● NumberOfEncoders/Encoder_1/IncEncoder/incResolution = 1024 (or number of 

increments without pulse multiplication) 
 

 
Figure 6-21 Expert list: Assigning encoders 
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Assigning the setpoint output 
● SetPointDriverInfo/mode = DPMASTER (2) 
● SetPointDriverInfo/logAddressIn = 256 (or I address of DP slave) 
● SetPointDriverInfo/logAddressOut = 256 (or O address of DP slave) 
● SetPointDriverInfo/TelegramType = DP_TEL1_STANDARD (1) for 2 PZD words in input 

and output direction 
 

 
Figure 6-22 Expert list: Assigning the setpoint output 

1. Commission the MICROMASTER MM4. 
 

  Note 
The drive can now be addressed via SIMOTION SCOUT in conjunction with a positioning 
axis. 
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6.9 SIMOVERT MASTERDRIVES MC on SIMOTION 

6.9.1 Connecting the SIMOVERT MASTERDRIVES MC 

Converter requirements 
 

 Note 
Derating has to be taken into account for compact devices as of 75 kW. This means that if a 
converter is operated with a pulse frequency greater than 5 kHz, the permissible rated 
current is reduced and the device can no longer be operated at its maximum rated power. 

 

Software requirements 
Personal computer minimum requirements 
● Windows 2000 Professional Service Pack 3 or Windows XP Professional Service Pack 2 
● SIMATIC STEP 7 V5.4 SP1 
● Drive Monitor V5.4 HF1 or Drive ES V5.4 SP1 
● SIMOTION SCOUT V4.1 
Converter 
Motion Control / Motion Control Compact PLUS (Standard / Performance2): 
● Version V1.60 or higher; readable in the parameters r69.1 and r828.1 
You can find a description of how to upgrade the converter firmware in the Motion Control 
compendium (Section 7.4 in the AC Edition) 
PROFIBUS communication board (CBP2): 
● Version V2.23 or higher; readable in the parameters r69.x and r828.x 

PROFIBUS communication board (CBP2): 
A CBP2 communication board must be inserted. This can be read out on the converter in the 
monitoring parameter r826.x: 
If a CBP2 is connected, value 148 is output. 
If a CBP1 is connected, value 143 is output. 
Index x designates the slot in which the communication board is inserted: 
Index 1 means the basic unit module,  
Index 2, the module in slot A etc. 
Further information is available in the parameter list in the Motion Control compendium. 
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6.9.2 Upgrading option cards firmware 

Requirement 
 

 Note 
A bootstrap file, e.g. CBP2_DL.hex and a program file CBP2_V223.hex of Version 2.23 or 
higher is required for the upgrade. 
The Drive Monitor or Drive ES may access only the converter RAM for the upgrade of the 
firmware. 

 

To upgrade the firmware of the option card: 
The upgrade with the Drive Monitor software is described as an example. 
1. Open the Drive Monitor 

 
Figure 6-23 Drive Monitor accesses the RAM of the MC 

2. Click File > Download > Option card firmware. 
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Figure 6-24 Opening the Option Card Download window 

3. Enter the path for the bootstrap file, the program file and the slot in which the CBP2 is 
installed. 

4. Activate the Activate diagnostics checkbox. 

 
Figure 6-25 Settings in the Option Cards Download window 

5. Right-click a free area of the screen. The following window opens: 
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Figure 6-26 Additional settings for the download 

6. Enter a program length of 128 KB and 8 EEPROM blocks. 
7. Click the Check button. 
8. Click the Start download button. 

The following window opens: 

 
Figure 6-27 Start of the script file download 

9. Click the Start button. 
The download is started. 

After the download, you can read out the new firmware version of the CBP2 from parameters 
r69.x and r828.x. 
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6.9.3 Commissioning MASTERDRIVES MC 

6.9.3.1 Commissioning procedure 
 

 Note 
This guide only describes how to set up the connection between the SIMOVERT 
MASTERDRIVES Motion Control converter/inverter and SIMOTION. The guide does not 
describe how to optimize the controller; it is assumed that this has already been carried out. 

 
The commissioning procedure is divided into two parts: 
● In the first part, a SIMOTION project is created and the SIMOTION SCOUT program and 

the hardware manager HW Config are used to enter the settings for the SIMOTION 
system. Settings which have to be made both in SIMOTION and in MASTERDRIVES MC 
are highlighted. 

● In the second part of the commissioning procedure, the MASTERDRIVES MC is 
parameterized. The guided basic unit commissioning procedure and a preprogrammed 
script file for connection to SIMOTION are used for this purpose. After the commissioning 
of SIMOTION and MASTERDRIVES MC, a sample program is set up for an axis 
positioning. 

Various parameter settings for MASTERDRIVES MC are derived from the SIMOTION 
settings. The following table contains an overview of the functions and settings which have to 
be entered in both SIMOTION and MASTERDRIVES MC. These settings are described 
separately in the following sections for the SIMOTION and MASTERDRIVES MC. 

Table 6-4 Settings required in SIMOTION and MASTERDRIVES MC 

Required setting Value 
DP cycle 3 ms 
Pulse frequency 5.3 kHz 
Encoder type Select 

(incremental encoder / absolute encoder) 
Homing mode Select 
Measurement Set 

(yes/no) 
Select encoder resolution In bits 
Enter rated motor speed 6000 rpm 
Ratio of  
position control cycle clock: DP cycle 
clock 

 
1:2:2 
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 Note 
The script file for the connection of SIMOVERT MASTERDRIVES Motion Control to 
SIMOTION with standard message frame 5 is provided at no cost. It may be copied, 
modified and used or passed on to third-parties. However, in the case of it being passed on 
to a third party, it must be in its full and unmodified form, and all copyright conditions must be 
observed. The commercial distribution to a third party, for example, in share/freeware 
distribution is only permitted with the previous written agreement of the Siemens AG. 
As this script file is provided free-of-charge, the authors and copyright holders cannot accept 
any liability for this file. Its use is the sole risk and responsibility of the user. The liability of 
the authors and copyright holders is restricted to damages arising from gross negligence or 
intent. All other claims are excluded. In particular, the authors and copyright holders cannot 
accept liability from any damages arising from defects or consequences arising from such 
defects. 

 
 

6.9.3.2 Creating a SIMOTION project 

Hardware configuration 
In this step, the SIMOTION device, the bus system and the MASTERDRIVES MC are 
created and parameterized via SIMOTION SCOUT and HW Config. 
1. Start SIMOTION SCOUT. 
2. Click Project > New. 
3. Enter a name, e.g. DSC_MCP_3ms. 
4. Click OK. 

A project is created. 

 
Figure 6-28 Creating a project 

5. Double-click Create new device. 
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Figure 6-29 Open HW Config (example) 

6. Select the desired SIMOTION device. 
7. Click OK. 
8. Select the interface at the C230-2 V4.1 in the PG/PC for a connection between the 

PG/PC and the C230-2. 

 
Figure 6-30 Selecting the interface 

9. Click OK in the Selection of the Interface - C230 window. 
The HW Config application starts.  
The rack with the SIMOTION C230 device is displayed. 
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Figure 6-31 Rack with PROFIBUS DP Mastersystem 

To create a PROFIBUS chain in the rack, proceed as follows: 
10. Double-click X8_DP1. 
11. Click the Properties button in the Properties -DP1 - (R0/S2.1) window in the General tab. 
12. Click the New button in the Parameters tab. 
13. Select the Network Settings tab. 
14. Set 2 as the highest PROFIBUS address. 
15. Select a transmission rate of 12 Mbit/s on the bus and DP as profile. 
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Figure 6-32 Configuration of PROFIBUS lines 

16. Click the Options button. 
17. Activate the Activate isochronous bus cycle checkbox in the Isochronous mode tab. 
18. Enter the desired cycle time, e.g. 3 ms in the Equidistant DP cycle field.  

The possible times can be taken from the DP cycle time table. 
19. Confirm the settings by clicking OK four times. 

All property windows are closed A PROFIBUS DP master system has been created. 
The other described settings are all shown for a DP cycle of 3 ms.  
For 1.5 ms or 2 ms, the setting must be modified according to the DP cycle and setting 
DP cycle time, pulse frequency, task tables. 

 

  Note 
The X9-DP2 interface in the rack is not networked for this example. It is set by default for 
PROFIBUS communication at 1.5 Mbaud. 

20. Open the PROFIBUS DP \ SIMOVERT \ MASTERDRIVES CBP2 directories in the 
hardware catalog. 

21. Click the PROFIBUS line. This is displayed in black. 
22. Double-click the type: Motion Control Plus. 

The Properties - PROFIBUS Interface MASTERDRIVES CBP2 window appears. 
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Figure 6-33 Attaching a MASTERDRIVES Motion Control Plus to the PROFIBUS 

23. Click OK. 
The Properties - Drive window appears. 

24. Click OK. 
25. In the Configuration tab of the DP Slave Properties window, select the Standard message 

frame 5 PZD-9/9 as default. 
26. In the Clock Synchronization tab, activate the Synchronize drive with equidistant DP cycle 

setting. 
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Figure 6-34 Selecting isochronous operation 

Table 6-5 DP cycle time 

DP cycle time Motion Control Motion Control Performance 2 
1.5 ms - Possible setting 
2 ms Possible setting Possible setting 
3 ms Possible setting Possible setting 

The DP cycle must be set in SIMOTION and in the MASTERDRIVES MC. 

Special settings: SIMOTION  
1. Enter the value 5.3 in the Pulse frequency (P340) field. 
2. Click the Alignment button. 

A message appears. 
3. Click Yes. 
4. In the DP cycle > Time frame/time base field, enter the value 3.0. 
5. Click the Alignment button. 
6. Click OK to confirm the changes. 
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Special settings: SIMOVERT MASTERDRIVES MC 

Parameters:  
P340 (pulse frequency) 

Meaning: 
The pulse frequency must be matched to the DP cycle so that the converter/inverter can be 
synchronized with this. Frequencies from 5 to 8 kHz can be set. 
The following relationships between DP cycle time, pulse frequency and task result: 

Table 6-6 Settings of DP cycle time, pulse frequency, task 

DP cycle time Pulse frequency Task 
1.5 ms 5.3 kHz 3 (only possible with Motion Control 

Performance 2) 
2 ms 8 kHz 4 
3 ms 5.3 kHz 4 

1. Save and compile the project with Station > Save and compile. 
2. Click Station > Check consistency. 
3. Click OK to confirm the message. 
4. Click Target system > Load to module. 

The hardware configuration is completed. 
5. Close HW Config. 

 

  Note 
After loading the hardware configuration, the red BUS1F LED on the C230 may still flash. 
The keyswitch is in position STOP. This bus error occurs if the PROFIBUS address and 
pulse frequency configured in the HW Config have not yet been set on the 
MASTERDRIVES MC. 
If communication between the two devices is to be tested at this point, the basic functions 
of the MASTERDRIVES MC should be commissioned and the connection to 
MASTERDRIVES MC established. 
If the settings in SIMOTION and MASTERDRIVES MC match, the BUS2F error does not 
occur and the LEDs on the PROFIBUS module of the MASTERDRIVES MC flash in 
synchronism. 
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6.9.3.3 Creating an axis in SIMOTION SCOUT 
1. Open the Axes folder in the project navigator under C230. 
2. Double click Insert axis. 

The axis assistant opens and guides you through the configuration of the axis. 

 
Figure 6-35 Inserting an axis 

3. Enter a name for the axis. 
4. Select the technology.  

Speed regulation and positioning are already preset. 
5. Click OK. 

The Axis configuration - Axis Name - Axis type window is opened. 
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Figure 6-36 Axis configuration: Axis type 

6. Specify the axis type.  
In the example, the set linear axis remains selected. 
Set mode and motor type are also transferred. 

7. Click Continue. 
The Axis configuration - Axis name - Units window is opened. 

8. Click Continue. 
The Axis configuration - Axis name - Modulo window is opened. 

9. Click Continue. 
The HW Config data is read out. The Axis configuration - Axis name - Drive assignment 
window is opened. 

 
Figure 6-37 Axis configuration: Drive assignment 
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10. Select the MASTERDRIVES CBP2 as drive unit. The standard message frame 5 is set 
automatically. If this is not the case, select standard message frame 5 in the field for the 
message frame type. 

11. Enter the value 6000 in the Rated speed field. 
12. Click Continue. 

The Axis - Drive Relationship window is opened. 
13. Read the note and click OK. 

The online help is opened. 
The Axis configuration - Axis name - Encoder assignment window is opened. 

14. Select the appropriate properties. 
In the example, Incremental encoder in the Encoder type field and SINE in the Encoder 
mode field are selected. 
The encoder data settings required for SIMOTION are listed in the encoder settings table. 
Only the input values listed in the tables are evaluated for the respective encoder. 
The encoder and resolution must be specified in SIMOTION and in 
MASTERDRIVES MC. 

15. Click Continue. 
The Axis configuration - Axis name - Encoder - Data window is opened. 

You can find the encoder settings tables: 
● in the online help or 
● on the CD Utilities&Application under 2_FAQ\ENCODER_PARAMETERIZATION 

 
Figure 6-38 Example: Axis configuration - selecting the encoder type for an absolute encoder 
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Figure 6-39 Example: Axis configuration - input of the resolution for an absolute encoder 

Pulse encoders, resolvers and encoders must be configured according to the encoder 
settings tables. This results in the following settings, for example, for the encoder. 

 
Figure 6-40 Example: Axis configuration - selecting the encoder type for an incremental encoder 
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Figure 6-41 Example: Axis configuration - input of the resolution for an incremental encoder 

Special settings: SIMOTION 
The settings in SIMOTION are specified with the name of the configuration data and can be 
shown using the expert list. The following assignments apply to the axis configuration 
windows: 

Encoder type 
● TypeOfAxis.NumberOfEncoders.Encoder_1.encoderType 

Encoder mode 
● TypeOfAxis.NumberOfEncoders.Encoder_1.encoderMode 

Resolution 
● TypeOfAxis.NumberOfEncoders.Encoder_1.IncEncoder.IncResolution 
● TypeOfAxis.NumberOfEncoders.Encoder_1.AbsEncoder.AbsResolution 
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Data width of absolute value without fine resolution 
● TypeOfAxis.NumberOfEncoders.Encoder_1.AbsEncoder.AbsDataLength 

Fine resolution 
● TypeOfAxis.NumberOfEncoders.Encoder_1.IncEncoder.IncResolution 
● MultiplierCyclic 
● TypeOfAxis.NumberOfEncoders.Encoder_1.AbsEncoder.AbsResolution 
● MultiplierCyclic 

Fine resolution for absolute value in Gn_XIST2 
● TypeOfAxis.NumberOfEncoders.Encoder_1.AbsEncoder.AbsResolution 
● MultiplierAbsolute 

Special settings: SIMOVERT MASTERDRIVES MC 
The required settings of the parameters can be found in the following tables. 

Parameters:  
U922 index 1 (encoder actual values) 

Meaning: 
The actual position value is connected to the encoder interface via U922.i001. With an 
absolute encoder, the absolute value from the encoder is specified as the actual position 
value. Please note that it takes a moment to read this value after initialization of the Motion 
Control system. 

 

 Note 
If a resolver or encoder is used, the connector KK120 (actual  
position value) is set in U922.i001(actual position value of the encoder interface). 
If, however, a multiturn encoder is used, the connector KK100  
(absolute position) is set in U922.i001(actual position value of the encoder interface). 

 

Parameters:  
P183 index 1 (position measurement configuration) 
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Meaning: 
The configuration of the position measurement is entered via this parameter. 
The last digit enables the position measurement. 
xxx1 = resolver/encoder enabled 
xxx2 = multiturn encoder enabled (x means not relevant) 

Parameters:  
P171 (position resolution) 

Meaning: 
In MASTERDRIVES, the position resolution, including a fine resolution (multiplication factor), 
is specified. The resolution is specified with a power of two. 
The position resolution must be set as follows: 
2P171 = number of increments * multiplication factor of the cyclic encoder actual value 
i.e. for incremental encoders: IncResolution * IncResolutionMultiplierCyclic 
i.e. for absolute encoders: AbsResolution * AbsResolutionMultiplierCyclic 

Differences between ABS and CYCLE_ABS: 
● In the case of ABS, the absolute actual position of the encoder is assumed after switching 

on the C230 or following an encoder error. 
● In the case of CYCL_ABS, overflows of the encoder areas are carried over in the NVRAM 

and taken into account when the cycle is resumed. With this setting, an overall reset must 
be carried out on the controller prior to initial loading of the project. Then, the encoder 
must be readjusted. If the settings for the absolute encoder are modified, the encoder 
must likewise be  
readjusted.  
With the controller switched off, the encoder may only be moved a maximum  
distance ≤ "half the encoder range" in both traversing directions in order to still be able to 
detect the exact position. 
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Completing the axis configuration 
1. Click Next. The set data is displayed. 

 
Figure 6-42 Last window of the axis configuration 

2. Click Finish. 
The settings are saved. An information window opens; read the information and confirm 
the window. 
After creating the axis, several settings must still be made in order to optimize the 
interaction between SIMOTION and MASTERDRIVES MC. 
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6.9.3.4 Deactivating following error monitoring in SIMOTION SCOUT 
To prevent the following error monitoring interrupting an axis motion, it can be set to a higher 
value or deactivated.  
A high following error can occur, for example, as a result of a missing drive optimization. 
1. In the project navigator, open the folder of the created axis. 
2. Double-click Monitoring. 
3. Click the Following error monitoring tab in the working area. 
4. Deactivate the Dynamic following error monitoring active checkbox. 
5. Click Close. 
The following error monitoring must be matched to the requirements and mechanical system 
of the plant when commissioning an application. 

 

WARNING  
If the following error monitoring is increased or deactivated, larger incorrect motions can 
also occur on the axis in the case of an error (e.g. incorrect position control direction). This 
is particularly important, for example, when the axis only has a limited traversing range. 

 

 
Figure 6-43 Deactivating the following error monitoring 
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6.9.3.5 Setting the position control configuration in SIMOTION SCOUT 
1. In the project navigator, double-click Control under Axis. 
2. Set the following data in the working area: 

Kv factor: Enter 
Speed precontrol: Activate 
Fine interpolator: Select constant velocity interpolation 
Dynamic drive control (DSC): Leave activated 

 
Figure 6-44 Position control configuration 

3. Click Close. 
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6.9.3.6 Setting system cycle clocks in SIMOTION SCOUT 
1. In the project navigator, right-click Execution system and select Expert > Set system 

cycle clocks. 
2. Set the values. 
3. Click OK. 

A message appears, read the information and confirm with OK. 

 
Figure 6-45 Set system cycle clocks 

Specifying the system cycle clocks 
The system cycle clock settings in SIMOTION affects the position setpoint adaptation in 
MASTERDRIVES MC. 

Special settings: SIMOTION 
The ratio of DP cycle clock to position control cycle clock and to interpolator cycle clock is 
set to 1:2:2, for example. This represents a DP cycle clock of 3 ms, a position controller 
cycle clock of 6 ms and an interpolator cycle clock of 12 ms. 
For instructions on how to activate and use interpolator cycle clock 2, see the online 
documentation in SIMOTION SCOUT. 
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Special settings: SIMOVERT MASTERDRIVES MC 

Parameters:  
P770 (time slice interpolator) 

Meaning: 
The transition from the position control cycle clock (SIMOTION) to the sampling time of the 
position controller (Motion Control) is controlled by an interpolator which compensates for the 
transformation ratio. 
● Up to MASTERDRIVES software Version V2.2 

The transformation ratio can only be specified in the form position control cycle clock / DP 
cycle = 2(P770-1). 
I.e. if the DP cycle and the position control cycle clock are the same, then you must enter 
the value 1 in P770. If the position control cycle is double the DP cycle, you must set the 
value to 2. 

● As of MASTERDRIVES software Version V2.2 
The transformation ratio can only be specified in the form position control cycle clock / DP 
cycle = 2(P770-3). 
I.e. if the DP cycle and the position control cycle clock are the same, then you must enter 
the value 3 in P770. If the position control cycle is double the DP cycle, you must set the 
value to 4. 
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6.9.3.7 Correction of system-related dead times in SIMOTION SCOUT 
1. Right-click the axis. 
2. Right-click and select Expert > Expert List. 

The expert list opens in the working area. 
3. Click the Configuration data tab. 
4. Open the structure under typeOfAxis > SystemDeadTimeData. 
5. Enter the appropriate value in additionalTime. 

In our example, the value 0.002625. 
6. Confirm the input by pressing the Enter key. 

Table 6-7 Values of system-related dead times 

DP cycle time Motion control up to SW V2.2 Motion control as of SW V2.2 
1.5 ms 0.003 s (only possible with Motion 

Control 
Performance 2) 

0.001875 s 

2 ms 0.002 s 0.001750 s 
3 ms 0.003 s 0.002625 s 

 

 
Figure 6-46 Input window for correction of the system-related dead time 
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6.9.3.8 Specify Homing Mode 
 

 Note 
The statements with respect to the homing modes in this section and the screenshots only 
refer to the homing settings for axes on a C2xx in connection with a SIMOVERT 
MASTERDRIVES MC. The homing options depend on the respective drive. 

 
If the connected axis is to be homed, the homing mode must be specified in both SIMOTION 
and SIMOVERT MASTERDRIVES MC. 
1. In the project navigator, double-click Homing under Axis. 
2. Enter the required homing mode and the appropriate data. 
3. Click Close. 

Additional references 
Please refer to the following document on this subject 
● SIMOTION Motion Control, TO axis, TO externalEncoder, Description of Functions 

Homing mode "External zero mark only" 
When a defined edge of the external zero mark is crossed, the position is accepted. 

 
Figure 6-47 Hardware configuration: Homing (External zero mark only) 
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Special settings: SIMOTION 
If External zero mark only is selected as the homing mode, the approach direction can be 
selected by means of homing direction. 
Signal control and BERO edge are not significant, as the positive edge is always evaluated 
in Motion Control with the parameterization of the script file (e.g. "STDTLG5_T4_V21.ssc"). 
The homing external zero mark for Motion Control must be connected to digital input 4 
(interrupt-capable inputs / terminal X101/6).  
With the script file, the digital inputs 4 or 5 are configured as measuring input 1 and 
measuring input 2 and can be addressed via SIMOTION.  
Digital input 4 can be used as external zero mark and as measuring input.  
Digital input 5 can be used as measuring input. 
The parameterization of U922.i005 and U923.i001 in Motion Control should be set to KK122 
and B212 for SIMOVERT MASTERDRIVES MC in accordance with the description below. 
As the zero position is of no significance here, the parameterization of the 2nd position of 
P183.i001 has no effect. 

 
Figure 6-48 Axis homing in SIMOTION (homing mode External zero mark only) 

Homing mode "Encoder zero mark only" 
An external zero mark signal is not necessary. The position is accepted at the next zero 
mark of the encoder. 
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Special settings: SIMOTION 
If encoder zero mark only is selected as the homing mode, the approach direction can be 
selected by means of homing direction. 
This must be compatible with the parameterization of the 2nd digit of P183.i001 in the Motion 
Control.  
If Zero mark in negative direction ... is selected in the window, P183.i001=xx2x must be 
entered in the Motion Control.  
If Zero mark in positive direction ... is selected, P183.i001 = xx1x must be set in the Motion 
Control. 

 
Figure 6-49 Axis homing in SIMOTION (homing mode Encoder zero mark only) 
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Homing mode "Homing output cam and encoder zero mark" 
The axis traverses in the specified homing direction. Once the BERO signal is reached, the 
velocity of the axis switches from the homing approach velocity to the homing reduced 
velocity. Once the BERO is left, the axis is homed at the next detected zero mark of the 
encoder. 
The homing BERO is connected to an unassigned SIMOTION I/O input.  

 
Figure 6-50 Hardware configuration: Homing (Homing output cam and encoder zero mark) 

If Homing output cam and encoder zero mark is selected as the homing mode, the 
evaluation position of the zero mark and the approach direction as the homing direction can 
be selected via zero mark. 
These must be compatible with the parameterization of the 2nd digit of P183.i001 in the 
Motion Control.  
This means: If the negative direction is chosen as the homing direction in the window and 
the zero mark is "behind the home position switch", the setting P183.i001=xx2x must be 
configured in the Motion Control; if negative direction is selected and zero mark is "before 
the home position switch", the setting P183.i001=xx1x must be configured in the Motion 
Control.  
If, however, the positive direction is chosen as the homing direction in the window and the 
zero mark is "behind the home position switch", the setting P183.i001=xx1x must be 
configured in the Motion Control; if positive direction is selected and zero mark is "before the 
home position switch", the setting P183.i001=xx2x must be configured in the Motion Control. 
The homing external zero mark must be connected to a freely selectable digital input of 
SIMOTION which has been configured in the Home Axis window. When the external zero 
mark is reached, homing is enabled in the drive. 
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Figure 6-51 Axis homing in SIMOTION (homing mode Homing output cam and encoder zero mark) 

Special settings: SIMOVERT MASTERDRIVES MC 

Parameters: 
U922 index 5 (encoder actual values) 

Meaning: 
The homing value is connected to the encoder interface via U922.i005. If Homing output cam 
and encoder zero mark or Zero mark only are used for homing, the homing procedure is 
performed via the home position detection in the Motion Control. However, if External zero 
mark only is used for homing, the position measured value memory in Motion Control is used 
for the homing procedure. 
If Homing output cam and encoder zero mark or Encoder zero mark only are used for 
homing, connector KK124 (home position measured value) should be set in U922.i005 
(encoder interface homing value). 
If External zero mark only is used for homing, connector KK122 (position measured value 
memory) should be set in U922.i005 (encoder interface homing value). 

Parameters:  
U923 index 1 (encoder checkback signal) 
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Meaning: 
The "Reference point detected" feedback signal (acknowledgement) is connected to the 
encoder interface via U923.i001. If Homing output cam and encoder zero mark or Zero mark 
only are used for homing, the homing procedure is performed via the home position 
detection in the Motion Control. However, if External zero mark only is used for homing, the 
position measured value memory in Motion Control is used for the homing procedure. 
If Home position switch and zero mark or Encoder zero mark only are used for homing, 
binector B210 (home position detected acknowledgement) should be set in U923.i001 
(homing value detected checkback signal, encoder interface). 
If, however, External zero mark only is used for homing, binector B212 (measured value 
valid acknowledgement) should be set in U923.i001 (homing value detected checkback 
signal, encoder interface). 

Parameters:  
P183 index 1 (position measurement configuration) 

Meaning: 
The position detection configuration is entered in this parameter.  
xx1x=The 1st zero position to the right of the coarse pulse (external zero mark) is evaluated 
xx2x=The 1st zero position to the left of the coarse pulse (external zero mark) is evaluated 
(x means not relevant) 
The SIMOTION project is now configured. The MASTERDRIVES MC is set in the next step. 
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6.9.3.9 "Measuring" function 
You can use the "measuring" function to acquire the actual position of an axis at any time. A 
typical application is the acquisition of a print mark for the purpose of synchronizing the axis 
to this mark. 
The measuring input must be connected to fast input X101/6 or X101/7. The input is isolated. 
This enables more than one input to be switched in parallel, whereby the reference potential 
of the 24 V supply of the measuring input (for example, from the network supply) must also 
be wired. 

 
Figure 6-52 Hardware configuration: Measurement 

Inserting a measuring input in SIMOTION SCOUT 
1. Open the Measuring inputs folder in the project navigator. 
2. Double-click Insert measuring input. 
3. Enter a name for the measuring input. 
4. Click OK. 
5. Click Close. 
Two measuring inputs can be connected to the MASTERDRIVES: 
● Measuring input 1 to X101/6 
● Measuring input 2 to X101/7 
Only one measuring input can be activated at any time. For example, before you activate 
Measuring input 2, you must make sure that Measuring input 1 is not active. 
The measuring input number is assigned as follows: 
● Measuring input 1 ⇒ "1" 
● Measuring input 2 ⇒ "2" 



FAQs  
6.9 SIMOVERT MASTERDRIVES MC on SIMOTION 

 SIMOTION SCOUT 
200 Configuration Manual, 03/2007 Edition 

SIMOVERT MASTERDRIVES Motion Control 
Settings in the Edge field (SIMOTION; calling the measuring function in the user program): 
● Rising edge or 
● Falling edge 
If you select another setting, the last valid value is taken over (rising or falling). 

Response times for the measuring function 
In SIMOTION, measuring can be used in various configurations. Depending on the 
connection of the axis (via PROFIBUS DP) and the processing level (position control cycle 
clock or IPO cycle clock), you must take different response times for the measuring function 
into account in the application. 
In the user program, measuring is started with the function call  
_enableMeasuringInput. You can specify when the measuring function is to be active during 
the call: 
● Immediately (without measuring window) 

MeasuringRangeMode = WITHOUT_SPECIFIC_AREA 
● Within a position-dependent measuring window  

MeasuringRangeMode = WITH_SPECIFIC_AREA 
When measuring without measuring window, the measuring input is immediately activated 
with _enableMeasuringInput. 
Before the measuring edge is evaluated at the hardware input, there is a  
configuration-dependent runtime. To be certain to detect the measuring edge, you must 
ensure that _enableMeasuringInput is executed earlier by this amount of runtime in the user 
program. 
When measuring with measuring window, the job is first only registered in the system with 
_enableMeasuringInput. Only when the axis has reached the start of the measuring window 
is the measuring input activated. 
From the time of reaching the start position of the measuring window on the axis 
(mechanical) until the evaluation of the measuring edge at the hardware input, there is a 
configuration-dependent runtime. In order that the measuring input is active when the start 
position of the measuring window on the axis is reached, you must move the start of the 
measuring window forward depending on the axis velocity and the response time during the 
function call. 
This is also valid for the end of the measuring window. It is important that the measuring 
input is no longer active when the end of the measuring window on the axis (mechanical) is 
passed. 
These runtimes can be compensated with the MeasuringRange.activationTime configuration 
data item. 

 

 Note 
The runtimes are only compensated without error for constant axis velocity. 

 
The offset of the measuring window only functions reliably when the axis velocity 
● within the measuring window is constant and 
● known before the function call. 
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You can determine the response times for your configuration using the following tables. The 
values in the tables refer to set system cycle clocks. By using the actual times, you can 
calculate the response time in milliseconds. 
The following abbreviations are used in the tables: 
● (IS) IPO cycle clock or position control cycle clock 

(is dependent on whether the measuring input is processed in the IPO or position control 
cycle clock; can be selected during the configuration of the measuring input) 

● (DP) Cycle time on the PROFIBUS DP 
● (DR) Cycle time in the drive (time slice in which the measuring function is evaluated) 
Tool calculates the anticipated response and rate times when using measuring inputs on 
different hardware More at: 
● 4_TOOLS\MEASURING_INPUT_CALCULATION 

Table 6-8 Measuring without measuring window 

 MASTERDRIVES MC 
_enableMeasuringInput 
Ready to detect the measuring edge 

2 (IS) + 3 (DP) + 3 (DR) 

Detection of the measuring edge 
Result in SIMOTION for further processing 

2 (IS) + 8 (DP) 

Total 
Minimum time between two measurements 
In addition, the restrictions of the respective system must be taken into 
account. 

5 (IS) + 11 (DP) + 2 (DR) 

 

Table 6-9 Measuring with measuring window: Measuring edge is detected in the window 

 MASTERDRIVES MC 
_enableMeasuringInput 
Ready for the evaluation of the measuring range (start of the measuring 
window) 

2 (IS) 

Start of the measuring window on the axis (mechanical) reached 
Ready to detect the measuring edge 

2 (IS) + 3 (DP) + 2 (DR) 

Detection of the measuring edge 
Result in SIMOTION for further processing 

2 (IS) + 8 (DP) 

Total 
Minimum time between two measurements 
In addition, the restrictions of the respective system must be taken into 
account. 

5 (IS) + 11 (DP) + 2 (DR) 

 

Table 6-10 Measuring with measuring window: No measuring edge in the window 

 MASTERDRIVES MC 
_enableMeasuringInput 
Ready for the evaluation of the measuring range (start of the measuring 
window) 

2 (IS) 
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 MASTERDRIVES MC 
Start of the measuring window on the axis (mechanical) reached 
Ready to detect the measuring edge 

2 (IS) + 3 (DP) + 2 (DR) 

Start of the measuring window on the axis (mechanical) reached 
Reset: "Ready to detect the measuring edge" 

2 (IS) + 3 (DP) + 2 (DR) 

Resetting of the ready to measure 
Checkback signal in SIMOTION for further processing 

2 (IS) + 8 (DP) 

Total 
Minimum time between two measurements 
In addition, the restrictions of the respective system must be taken into 
account. 

7 (IS) + 14 (DP) + 4 (DR) 

 

6.9.4 Basic commissioning of MASTERDRIVES MC 

What has to be observed? 
One of the commissioning tools, Drive Monitor or Drive ES, is used to commission the 
Masterdrives MC. If the connection is made via the serial interface USS, the bus address in 
Parameter P700 and the baud rate in Parameter P701  
● 6 → 9600 baud 
● 7 → 19200 baud 
● 8 → 38400 baud 
must match the settings in the commissioning tool used. 
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Setting the basic functions 
The initial step in a guided commissioning procedure is to configure the hardware (used 
power unit, motor, encoder, etc.), the interfaces, etc. This is performed with one of the 
commissioning tools, Drive Monitor or Drive ES, by calling up the Parameter > Guided 
commissioning > Basic functions menu item. 
1. Open the Configuration window. 
2. Select for 

– Motion Control devices, the power unit according to the order no. of the converter and 
enter the supply voltage. 

– Motion Control Compact Plus devices, the supply voltage. The power unit of this 
device cannot be changed, it is automatically detected and displayed with a gray 
background (like the individual slot assignments). 

 
Figure 6-53 Guided commissioning of the basic device: Configuration window 

3. Click Next. 
4. Select the connected motor in the Motor window. 
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Figure 6-54 Guided commissioning of the basic device: Motor window 

5. Click Next. 
6. Select the connected motor encoder in the Motor Encoder window. 

 
Figure 6-55 Guided commissioning of the basic device: Motor Encoder window 
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7. Click Next. 
8. In the Setpoints, Control Type window, select the setting PROFIBUS DP and terminal 

strip. 

 
Figure 6-56 Guided commissioning of the basic device: Setpoints and Control Type window 

9. Click Next. 
10. In the Closed-loop Control window, enter the optimized speed controller parameters 

(Kp and Tn), torque limits, etc. 
11. Click Next. 

Do not make any settings in the following window. 
12. Click Next. 
13. Set the bus address in the Communication window. 
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Figure 6-57 Guided commissioning of the basic device: Communication window 

14. Click Next. 
At the end of the guided commissioning, a summary of the parameterization is displayed. 

 
Figure 6-58 Guided commissioning of the basic device: Summary 
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15. When you click Accept configuration and confirm your entries with OK and Next, the 
parameterization is loaded to the converter. 
A message window confirms that the parameterization has been successfully loaded. 

16. Click OK to confirm the message. 
The guided commissioning of the basic device is completed. You must now connect 
MASTERDRIVES MC to SIMOTION. 

Connecting MASTERDRIVES MC to SIMOTION 
In this step, the parameterization is performed for the connection of the Motion Control to 
SIMOTION for standard message frame type 5. This is performed with a script file in 
accordance with the DP cycle time. The script files are stored on the Add-On CD in folder 
4_Accessories. 

Table 6-11 DP cycle times and associated script files 

DP cycle time Script file 
1.5 ms STDTLG5_T3_V21.ssc 

(only possible with Motion Control Performance 2) 
2 ms 
3 ms 

STDTLG5_T4_V21.ssc 

The appropriate script file implements the following parameter assignments / functionalities 
on the Motion Control converter/inverter: 
● All digital outputs and speed setpoint interconnections are reset. 
● Instructions for setting application-dependent parameters are provided initially in a 

message box. The settings are configured in the next dialog box that is displayed. 
All application-dependent parameters have already been described in the "Creating a 
SIMOTION project" section. Examples are parameters U922 and U923 (encoder 
interface), which have to be modified etc. depending on the application (e.g. homing with 
zero mark or with External zero mark only). 

● Errors occurring after Power On are acknowledged automatically. 
● The SST1 interface is located in the T6 time slice. 
● Motor potentiometer functionality is excluded from the time slice. 
● The DSC kernel function is implemented with free blocks. 
● Interconnection of free modules for the implementation of the functionalities homing with 

External zero mark only and measuring. 
● Wiring of the standard message frame 5 process data in the converter/inverter. 
● Wiring of the motor encoder interface. A wiring of the external encoder interface is not 

implemented. 
The following section describes the procedure for the execution of script file 
STDTLG5_T4_V21.ssc. The procedure is the same for script file STDTLG5_T3_V21.ssc: 
1. Open the Drive Monitor or Drive ES commissioning tool. 
2. Click File > Execute script file... in the menu bar. 
3. Select the STDTLG5_T4_V21.ssc script file for the standard message frame 5 and open 

it. 
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  Note 
The 6SE70MC converter/inverter must not be in the "RUN" mode (r001=14). 
The settings for the sources of the digital outputs which are possible via the menu 
Parameters > Guided commissioning > Basic functions are reset at the next Execute 
script file...! 

You are now guided online via Windows windows.  
4. Click the Start button. 

 
Figure 6-59 Starting the script file STDTLG5_T4_V21.ssc 

5. Accept the exclusion of liability. 
6. Confirm the connection of the Motion Control to SIMOTION for the standard message 

frame 5. 
 

  Note 
You can stop the execution of the script file by clicking the Cancel button. 

7. Read the contents of the message box with the setting information for the application-
dependent parameter P340 (pulse frequency). 

8. Click OK to confirm the message. 

 
Figure 6-60 Message box with setting information for P340 

9. Set the required value for the application-dependent parameter P340 (pulse frequency). 
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Figure 6-61 Dialog box for setting P340 

10. Read the contents of the message box with the setting information for the application-
dependent parameter U922.i001 (actual position value of the encoder interface). 

11. Click OK to confirm the message. 

 
Figure 6-62 Message box with setting information for U922.i001 

12. Set the required value for the application-dependent parameter U922.i001 (actual 
position value of the encoder interface). 

 
Figure 6-63 Dialog box for setting U922.i001 

13. Read the contents of the message box with the setting information for the application-
dependent parameter U922.i005 (homing value of the encoder interface). 

14. Click OK to confirm the message. 
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Figure 6-64 Message box with setting information for U922.i005 

15. Set the required value for the application-dependent parameter U922.i005 (homing value 
of the encoder interface). 

 
Figure 6-65 Dialog box for setting U922.i005 

16. Read the contents of the message box with the setting information for the application-
dependent parameter U923.i001 (home position checkback signal of the encoder 
interface). 

17. Click OK to confirm the message. 

 
Figure 6-66 Message box with setting information for U923.i001 

18. Set the required value for the application-dependent parameter U923.i001 (home position 
checkback signal of the encoder interface). 
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Figure 6-67 Dialog box for setting U923.i001 

19. Read the contents of the message box with the setting information for the application-
dependent parameter P171 (position resolution). 

20. Click OK to confirm the message. 

 
Figure 6-68 Message box with setting information for P171 

21. Set the required value for the application-dependent parameter P171 (position 
resolution). 

 
Figure 6-69 Dialog box for setting P171 

22. Read the contents of the message box with the setting information for the application-
dependent parameter P183.i001 (position measurement configuration). 
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23. Click OK to confirm the message. 

 
Figure 6-70 Message box with setting information for P183.i001 

24. Set the required value in the dialog box for the application-dependent parameter 
P183.i001 (position measurement configuration): 

 
Figure 6-71 Dialog box for setting P183.i001 

25. Read the contents of the message box with the setting information for the application-
dependent parameter P205 (rated velocity). 

26. Click OK to confirm the message. 

 
Figure 6-72 Message box with setting information for P205 

27. Set the required value for the application-dependent parameter P205 (rated velocity). 
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Figure 6-73 Dialog box for setting P205 

28. Read the contents of the message box with the setting information for the application-
dependent parameter P770 (interpolator). 

29. Click OK to confirm the message. 

 
Figure 6-74 Message box with setting information for P770 

30. Set the required value for the application-dependent parameter P770 (interpolator). 

 
Figure 6-75 Dialog box for setting P770 

31. Click OK. 
A message appears after the successful commissioning. Confirm this with OK. 

 

  Note 
If an "Error" message is also to appear, then open the associated LOG file (name the 
same as the script file but with the extension .LOG) either with the Log button or an editor 
for the troubleshooting. You can find the LOG file in the commissioning tool in the same 
directory as the script file. 
After configuration, the green 5 VDC LED and the yellow STOP LED light up on the 
SIMOTION. The keyswitch is in the STOP position. 
The 3 LEDs of the PROFIBUS module flash in synchronism on the MASTERDRIVES MC.
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6.9.5 MASTERDRIVES MC commissioning tool 

Commissioning tool 
This section explains how to establish a connection to the MASTERDRIVES MC via a serial 
interface using the Drive Monitor or Drive ES commissioning tools. 
The serial interface of the MASTERDRIVES MC is set to 9600 baud and the bus address is 
set to 0 at the factory. The bus address can be read out via parameter P700 on the PMU 
operator panel of the converter. 
The baud rate is in parameter P701, whereby: 
● 6 → means 9600 baud 
● 7 → means 19200 baud 
● 8 → means 38400 baud. 

Communication via DRIVE ES 
1. Open the SIMATIC Manager. 
2. Insert a drive in the project directory via Insert > Drive. 
3. Insert a MASTERDRIVES MC Plus with Version 01.6 and bus address 0. 
4. Click OK. 
5. Right-click the inserted drive and select Target system > Drive > Overview in the context 

menu. 
6. Select Options > Interface settings. 
7. Select USS in the Bus type tab. 
8. Set 9600 baud in the COM interface used in the Interface tab. 
9. Close the window. 
10. In the menu bar, click Target systems > Drive > Parameterization. 
11. Parameterize the drive. 

Communication via Drive Monitor 
1. Start the Drive Monitor. 
2. Create a parameter set via the menu File > New > Empty parameter set. 
3. Insert a MASTERDRIVES MC with Version 01.6 and bus address 0. 
4. Click OK. 

The file is saved and the parameter set is opened offline. 
5. In the menu bar, click View > Online (EEPROM). 

The connection to the drive is established. If a connection cannot be established, you 
must set the interface via Options > ONLINE settings. 
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6.9.6 MASTERDRIVES VC in connection with an axis 

Introduction 
This section describes how to integrate the MASTERDRIVES Vector Control converter unit 
as a drive in the SIMOTION SCOUT program. This description is valid for the 
MASTERDRIVES VC connection to a drive axis or a position axis. With a position axis, you 
must also assign the encoders. This is noted at the appropriate position in this description. 
In the following example, the converter unit is controlled via standard message frame 1. 

Inserting a MASTERDRIVES VC in HW Config 
1. In the project navigator, double-click the SIMOTION device. 

HW Config opens. 
2. Insert the converter unit used from the HW catalog into the PROFIBUS subnet. To do 

this, use the following components from the HW catalog: 
 

  Note 
The SIMOVERT/MASTERDRIVES CBP2/Vector Control CUVC has a front panel that can 
be swung open and behind this there is a plug-in card drawer unit with at least one plug-
in card.  

– SIMOVERT/MASTERDRIVES CBP2/Vector Control CUVC or 
– SIMOVERT/MASTERDRIVES CBP2/Vector Control Plus 

3. Select the standard message frame 1, PZD-2/2. 
4. Click the Save and compile button. 
5. Click the Load to module button. 
6. Close HW Config. 
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Inserting and modifying a virtual axis in SIMOTION SCOUT 
1. Insert a virtual axis into the project navigator of SIMOTION SCOUT. 
2. Call the expert list. 
3. Convert the virtual axis into a real axis. 
4. Select the virtual axis in the project navigator. 
5. Open the expert list via the shortcut menu. 
6. Open the following directory in the expert list: ConfigurationData\TypeOfAxis. 
7. Make the following setting: 
● typeOfAxis = REAL_AXIS (0) 

 
Figure 6-76 TypeOfAxis configuration data 
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Assigning encoders 
● NumberOfEncoders/Encoder_1/encoderIdentification = ONBOARD (1), set EncoderType, 

EncoderMode and EncoderSystem according to the encoder installed 
● NumberOfEncoders/Encoder_1/DriverInfo/logAddressIn = 128 (or 160, 192, 224) 
● NumberOfEncoders/Encoder_1/DriverInfo/logAddressOut = 128 (or 160, 192, 224) 
● NumberOfEncoders/Encoder_1/DriverInfo/telegramType = NO_TELEGRAM (0) 
● NumberOfEncoders/Encoder_1/IncEncoder/incResolution = 1024 (or number of 

increments without pulse multiplication) 

 
Figure 6-77 Encoder configuration data 
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Assigning the setpoint output 
● SetPointDriverInfo/mode = DP MASTER (2) 
● SetPointDriverInfo/logAddressIn = 256 (or I address of DP slave) 
● SetPointDriverInfo/logAddressOut = 256 (or O address of DP slave) 
● SetPointDriverInfo/telegramType = standard message frame 1 (1) 

 
Figure 6-78 Setpoint output configuration data 

Commissioning the MASTERDRIVES VC 
The converter unit is commissioned with the Drive Monitor or Drive ES Basic program.  
1. Establish an online connection to the converter unit. 
2. Start the guided basic device commissioning via the menu item Parameter > Basic device 

commissioning. 
With the guided basic device commissioning, you should have selected the following 
settings: 
– PROFIBUS DP and terminal strip selection, parameterize all digital inputs without 

function 
– Without motor encoder: 

Speed control without tachometer (F control) 
– With motor encoder connected to the Vector Control: 

Speed control with tachometer (n control) 
– Setting the PROFIBUS address 
– Set the ramp-function generator according to the dynamic requirements (please make 

sure you have the correct units) 
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3. Adapt the following parameters. You can then address MASTERDRIVES Vector Control 
from SIMOTION via a PROFIBUS connection: 
– P571 = P572 = 1 (pos. and neg. direction of rotation) 
– P573 = P574 = 0 (motor potentiometer higher/lower) 
– P575 = 1 (external error, low-active) 

6.10 SIMODRIVE 611U to SIMOTION 

6.10.1 Connecting SIMODRIVE 611U to SIMOTION 

Standard options when using the SIMODRIVE 611U 
This section describes the most important standard options when using the 
SIMODRIVE 611U on SIMOTION. Although additional functions can be executed with the 
SIMODRIVE 611U, these must be examined on an individual basis.  
This description does not replace the device documentation for the SIMODRIVE 611U. A 
complete functional description of the SIMODRIVE 611U can be found in the Description of 
Functions for SIMODRIVE 611 Universal "Closed-Loop Control Components for Closed-
Loop Speed Control and Positioning". 

POSMO C and POSMO S 
POSMO C and POSMO S drives can also be used on SIMOTION. These drives belong to 
the SIMODRIVE 611U family and are parameterized with the same commissioning tools. 
The adaptation to SIMOTION is comparable to the approach described for the 
SIMODRIVE 611U. However, the functional scope is different and is contained in the 
corresponding device description. 

 

 Note 
The following sections refer only to the SIMODRIVE 611U. The described approach also 
applies to POSMO S and POSMO C. 

 

Restrictions 
The data exchange broadcast function of the SIMODRIVE 611U cannot yet be used in 
connection with SIMOTION. 
If a double-axis module is used, either both axes must be created as a technology object 
(TO) or both axes must be addressed from the user program via the PZD interface. A mixed 
operation, in which one axis is operated as a TO axis and the other axis from the user 
program via the process data interface, is not possible. 
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Requirements of the 611U converter 
● SIMODRIVE 611U closed-loop control module 
● PROFIBUS DP3 option module for isochronous PROFIBUS DP 
Closed-loop control module options: 
2-axis for encoder sin/cos 1 Vpp n-set 6SN1 118-0NH0_-0AA_ 
2-axis for encoder sin/cos 1 Vpp positioning 6SN1 118-1NH0_-0AA_ 
2-axis for resolver n-set 6SN1 118-0NK0_-0AA_ 
2-axis for resolver positioning 6SN1 118-1NK0_-0AA_ 
1-axis for resolver n-set 6SN1 118-0NJ0_-0AA_ 
1-axis for resolver positioning 6SN1 118-1NJ0_-0AA_ 
PROFIBUS DP3 option module 6SN1 114-0NB01-0AA0 

 

 Note 
As a general principle, a closed-loop control card for speed setpoint operation is sufficient for 
operation with SIMOTION. This is also the case when DSC is used. 
If you want to use an external encoder on the axis, you must select a 2-axis closed-loop 
control module, whereby the second axis cannot be used to control a motor. 

 

Software requirements 

Personal computer minimum requirements 
● Windows 2000 Professional Service Pack 3 or Windows XP Professional Service Pack 2 
● SIMATIC STEP 7 V5.3 Service Pack 3 
● SimoCom U V4.x 

(depends on the firmware version of the SIMODRIVE 611U) 
● SIMOTION SCOUT V3.0 

Minimum converter requirements 
● SIMODRIVE 611U firmware Version V4.x; can be read out in parameter P1799 
● PROFIBUS V4.x option module; can be read out in parameter P1795 
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6.10.2 Upgrading the firmware 

Proceed as follows: 
1. Connect SimoCom U to the drive via the RS-232-C. 

 

  Note 
SimoCom U may not be connected via PROFIBUS DP!  
Do not cancel the downloading operation or interrupt the online connection to the 
SIMODRIVE 611U under any circumstances. 

 
Figure 6-79 Firmware upgrade: Interface window 

2. Open the commissioning tool. 
3. In the menu bar, click Options >Service > . . . 

If you want to upgrade the drive, select Firmware upgrade. 
If you want to upgrade the PROFIBUS module, select Firmware upgrade of PROFIBUS 
option module. 
You are guided through the upgrade. 

 

  Note 
This example shows the procedure for upgrading the firmware of the drive.  
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Figure 6-80 SimoCom U firmware upgrade 

4. Confirm the information message with OK. 

 
Figure 6-81 Firmware upgrade: Message window 

5. Select the file with the desired firmware and confirm your input with Open. 
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Figure 6-82 Firmware upgrade: Select file 

 
Figure 6-83 Firmware upgrade: Load window 

 
Figure 6-84 Firmware upgrade: SimoCom U window 

6. Confirm the prompt with Yes. The drive executes a RESET. 
7. The firmware upgrade for the drive is completed. If required, you can now perform the 

firmware upgrade for the PROFIBUS module. 
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6.10.3 Commissioning SIMODRIVE 611U 

6.10.3.1 Commissioning procedure 

Introduction 
This section describes the standard commissioning procedure using a sample configuration. 
The settings required in SIMOTION and in the SIMODRIVE 611U are explained. The sample 
configuration is based on the control of two position-controlled axes with DSC. Control is via 
PROFIBUS message frame 105, and a SIMODRIVE611U double-axis module is used as 
drive. 
If you use another axis or message frame type or another SIMODRIVE 611U closed-loop 
control module, the structure of the input windows may differ from those described below. 
However, the principle approach remains the same. 
Moreover, you can use additional functions of the SIMODRIVE 611U in the user program (for 
example, reading of operating modes, etc.). Information on this can be found in the "Expert 
functions" section 

 

 Note 
These instructions ensure only the connection of the SIMODRIVE 611U converter to 
SIMOTION. The guide does not describe how to optimize the controller; it is assumed that 
this has already been carried out. 

 

Commissioning procedure 
The commissioning procedure is divided into two parts:  
● In the first part, a SIMOTION project is created and the SIMOTION SCOUT program and 

the hardware manager HW Config are used to enter the settings for the SIMOTION 
system. The settings that have to be made both in SIMOTION and in the 
SIMODRIVE 611U are given special attention. 

● In the second part, the SIMODRIVE 611U is parameterized. The basic device 
commissioning for connection to SIMOTION is used for this. 

After commissioning SIMOTION and the SIMODRIVE 611U, a sample program is set up for 
axis positioning. 
Various parameter settings for the SIMODRIVE 611U are derived from the SIMOTION 
settings. The following table contains an overview of the functions and settings which have to 
be entered in both SIMOTION and in the SIMODRIVE 611U. These settings are described 
separately in the following sections for SIMOTION and the SIMODRIVE 611U. 

Table 6-12 Settings required in SIMOTION and SIMODRIVE 611U 

Required setting Sample values 
DP cycle 2 ms 
Pulse frequency 5.3 kHz 
Select encoder type Incremental encoder 
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Required setting Sample values 
Select homing mode Homing output cam and encoder zero mark 

Encoder zero mark only 
External zero mark only 

Measurement Yes 
No 

Rated motor speed / 
max. axis speed 

6000 rpm 

Master application cycle / 
position control cycle clock 

Factor 1 

Message frame type 
see selection table 

2 axes, message frame 105, PZD-10/10 

PROFIBUS address ... 

By default, the SIMODRIVE 611U is connected to SIMOTION via PROFIBUS DP. 
Depending on the desired axis functionality, this connection can be made using various 
device-specific message frames. The following selection table shows the options for the 
individual message frame types: 

Table 6-13 Selection table 

 Sign-of-life 
monitoring 

1. 
encoder 
________
__ 
Measure
ment 

2. 
Encoders

Dynamic 
Servo  
Control (DSC)

Torque  
reduction 
(Mred) 

Required 
message 
frame 

     1 
x     2 

Speed- 
controlled 
axis 

x    x 101 
x x    3 
x x x   4 
x x  x  5 
x x x x  6 
x x   x 102 
x x x  x 103 
x x  x x 105 

Position- 
controlled 
axis / 
following 
axis 

x x x x x 106 
 
 

 Note 
The message frame types < 100 are standard message frames. These are standardized via 
the PROFIdrive V3 profile. The message frame types > 100 are device-specific message 
frame types for the SIMODRIVE 611U. 
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6.10.3.2 Creating a SIMOTION project 

Hardware configuration 
In this step, the SIMOTION device, the bus system and the SIMODRIVE 611U are created 
and parameterized via SIMOTION SCOUT and HW Config. 
1. Start SIMOTION SCOUT. 
2. Click Project > New. 
3. Enter a name, e.g. DSC_SIMODRIVE. 
4. Click OK. 

A project is created. 

 
Figure 6-85 Project: Creating DSC_SIMODRIVE 

5. Double-click Create new device. 

 
Figure 6-86 Open HW Config (example) 

6. Select the desired SIMOTION device. 
7. Click OK. 
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8. Click Cancel twice. 
The scanning of the PROFIBUS interface properties can be skipped first of all as these 
are described in the following. 

9. Click OK in the Selection of the Interface - C230 window. 
The HW Config application starts. The rack with the SIMOTION C230 device is displayed. 

 
Figure 6-87 Rack 

10. Double-click X8_DP. 
The PROFIBUS line is created in the rack. 

11. Click the Properties button in the Properties -DP- (R0/S2.1) window. 
12. Click New. 
13. Then select the Network settings tab. 
14. Set a transmission rate of 12 Mbit/s on the bus and DP as profile. 
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Figure 6-88 Configuration of PROFIBUS lines 

15. Click the Options button. 
16. Activate the Activate isochronous bus cycle checkbox in the Isochronous mode tab. 
17. Enter the desired cycle time, e.g. 2 ms in the Isochronous DP cycle field. 
18. Confirm the settings by clicking OK four times. 

All property windows are closed. A PROFIBUS master system has been created. 
 

  Note 
The X9-DP interface in the rack is not networked for this example. It is set by default for 
PROFIBUS communication at 1.5 Mbaud. 

19. Open the PROFIBUS DP / SIMODRIVE directory in the hardware catalog. 
20. Click the PROFIBUS line. This is displayed in black. 
21. Double-click the type: SIMODRIVE 611 universal. 
22. Enter the address ≥ 3. 
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Figure 6-89 Attaching a SIMODRIVE 611U to the PROFIBUS 

23. Click OK. 
24. In the Configuration tab of the DP Slave Properties window, select the required 

PROFIBUS message frame for the connection. In this example, a 611U double-axis 
module connected via message frame 105 is selected. The subsequent axis motion will 
be position-controlled. 
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Figure 6-90 Setting standard message frame 105 on the slave 

Special settings: SIMOTION 
The message frame selected here is specified again when the axis is subsequently created. 
The setting is automatically taken over from the hardware configuration when the axis is 
created. 
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Special settings: SIMODRIVE 611U 
The PROFIBUS address must be set in the 611U in parameter P918. The message frame 
selected here must be specified in parameter P922 in the SIMODRIVE 611U. With 
SimoCom U, the entry can be made in the PROFIBUS Parameterization window. 
1. Click the Isochronous operation tab. 
2. Activate Synchronize drive with equidistant DP cycle. 
3. Enter the following settings. 

 
Figure 6-91 Selecting isochronous operation for SIMODRIVE 611U 

– Master application cycle: 
Here, you specify the cycle clock in which the master is to supply new values to the 
SIMODRIVE 611U. For SIMOTION, this is the position control cycle clock (servo). You 
must note this value and enter it later when configuring the execution system as 
position control cycle clock in SIMOTION SCOUT. 

 

  Note 
It is mandatory that the master application cycle match the position control cycle clock 
of the CPU! 

– DP cycle: 
Bus cycle clock: It depends on the number of slaves  
(minimum of 1 ms for P350 and 1.5 ms for C230). 
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– Actual value acquisition: 
Measured value is latched in the SIMODRIVE 611U as soon as possible before the 
DP cycle clock (Input 1: → 0.125 ms before the next DP cycle clock). 

– Setpoint acceptance: 
Setpoint is output in the SIMODRIVE 611U as soon as possible after the DP clock 
cycle. The time depends on the number of isochronous slaves. It must be ensured 
 that the last slave has also received the setpoint values in the current DP cycle. 
Otherwise, the drive signals it is "not isochronous with the master". 

– With several axis modules on the PROFIBUS, click Align. 
4. Click OK to confirm the changes. 
5. Save and compile the project with Station > Save and compile. 
6. Click Station > Check consistency. 
7. Click OK to confirm the message. 
8. Click Target system > Load to module. 

The hardware configuration is completed. 
9. Close HW Config. 

 

  Note 
After loading the hardware configuration, the red BUS1F LED on the C230 may still flash. 
The keyswitch is in position STOP. The bus error occurs if the PROFIBUS address 
configured in HW Config and the selected message frame type have not yet been set in 
the SIMODRIVE 611U. 
If communication between the two devices is to be checked at this point, then the basic 
functions of the SIMODRIVE 611U must have been commissioned. 
If the settings in SIMOTION and the SIMODRIVE 611U match, the BUS1F error does not 
occur and the LED on the PROFIBUS module of the SIMODRIVE 611U is green. 
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6.10.3.3 Creating an axis in SIMOTION SCOUT 

Creating an axis in SIMOTION SCOUT 
1. Open the Axes folder in the project navigator under C230. 

The axis wizard opens when you create an axis. This guides you through the 
configuration of the axis and cannot be aborted. 

 
Figure 6-92 Inserting an axis 

2. Double-click Insert axis. 
3. Enter a name for the axis. 
4. Click OK. 

The Axis configuration - Axis name - Axis type window is opened. 
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Figure 6-93 Axis configuration: Axis type 

5. Specify the axis type.  
In the example, the linear axis setting is retained. 

6. Click Continue. 
The Axis configuration - Axis name - Units window is opened. 

7. Click Continue. 
The Axis configuration - Axis name - Modulo window is opened. 

8. Click Continue. 
The HW Config data is read out. The Axis configuration - Axis name - Drive assignment 
window is opened. 

 
Figure 6-94 Axis configuration: Drive assignment 
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9. Select the SIMODRIVE_611U_DP2_DP3 as drive unit. The message frame 105 should 
be set automatically. If this is not the case, select message frame 105 in the field for the 
message frame type. 

10. Enter the value 6000 in the Rated speed field. 
11. Click Continue. 

The Axis - Drive Relationship window is opened. 
12. Read the note and click OK. 

The online help is opened. 
The Axis configuration - Axis name - Encoder assignment window is opened. 

13. Select the appropriate properties. 
In the example, Incremental encoder in the Encoder type field and Endat in the Encoder 
mode field. 
The encoder data settings required for SIMOTION are listed in the following table. Only 
the input values listed in the tables are evaluated for the respective encoder. 
– The encoder and resolution must be specified in SIMOTION and in 

MASTERDRIVES MC. 

The encoder settings tables can be found 
● in the online help or 
● on the CD Utilities&Application under 2_FAQ\ENCODER_PARAMETERIZATION 

 
Figure 6-95 Example: Axis configuration - selecting the encoder type for an absolute encoder 
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Figure 6-96 Example: Axis configuration - input of the resolution for an absolute encoder 

Pulse encoders, resolvers and encoders must be configured according to the tables under 
"Encoder settings". This results in the following settings, for example, for the encoder. 

 
Figure 6-97 Example: Axis configuration - selecting the encoder type for an incremental encoder 
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Figure 6-98 Example: Axis configuration - input of the resolution for an incremental encoder 

The settings in SIMOTION are specified with the name of the configuration data and can be 
shown using the expert list.  
The following assignments apply to the axis configuration windows: 
Encoder type 
 TypeOfAxis.NumberOfEncoders.Encoder_1.encoderType 
Encoder mode 
 TypeOfAxis.NumberOfEncoders.Encoder_1.encoderMode 
Resolution 
 TypeOfAxis.NumberOfEncoders.Encoder_1.IncEncoder.IncResolution 
 TypeOfAxis.NumberOfEncoders.Encoder_1.AbsEncoder.AbsResolution 
Number of data bits 
 TypeOfAxis.NumberOfEncoders.Encoder_1.AbsEncoder.AbsDataLength 
Multiplication factor of the cyclical encoder actual value 
 TypeOfAxis.NumberOfEncoders.Encoder_1.IncEncoder.IncResolution 
 MultiplierCyclic 
 TypeOfAxis.NumberOfEncoders.Encoder_1.AbsEncoder.AbsResolution 
 MultiplierCyclic 
Multiplication factor of the absolute encoder actual value 
 TypeOfAxis.NumberOfEncoders.Encoder_1.AbsEncoder.AbsResolution 
 MultiplierAbsolute 
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SIMODRIVE parameter bit P1011.2 = 0 

Table 6-14 SIMOTION settings 

TypeOfAxis.NumberOfEncoders.Encoder_1.encoderType=INC 
TypeOfAxis.NumberOfEncoders.Encoder_1.encoderMode=RESOLVER 
TypeOfAxis.NumberOfEncoders.Encoder_1.IncEncoder.IncResolution =1024 (Resolver 2p) 
 =2048 (Resolver 4p) 
 =3072 (Resolver 6p) 
 =4096 (Resolver 8p) 
TypeOfAxis.NumberOfEncoders.Encoder_1.IncEncoder.IncResolutionMultiplierCyclic=2048 (0) 

SIMODRIVE parameter bit P1011.2 = 1 

Table 6-15 SIMOTION settings 

TypeOfAxis.NumberOfEncoders.Encoder_1.encoderType=INC 
TypeOfAxis.NumberOfEncoders.Encoder_1.encoderMode=RESOLVER 
TypeOfAxis.NumberOfEncoders.Encoder_1.IncEncoder.IncResolution =4096 (Resolver 2p) 
 =8192 (Resolver 4p) 
 =12288 (Resolver 6p) 
 =16384 (Resolver 8p) 
TypeOfAxis.NumberOfEncoders.Encoder_1.IncEncoder.IncResolutionMultiplierCyclic=2048 (0) 

Comment: 
For the encoders, a fine resolution of 0 (default value) 
● in parameter TypeOfAxis.NumberOfEncoders.Encoder_1.IncEncoder. 

IncResolutionMultiplierCyclic means a fine resolution of 211 = 2048 
● in parameter TypeOfAxis.NumberOfEncoders.Encoder_1.IncEncoder. 

IncResolutionMultiplierAbsolute means a fine resolution of 29 = 512 

Differences between ABS and CYCLE_ABS:  
● In the case of ABS, the absolute actual position of the encoder is assumed after switching 

on the C230 or following an encoder error. 
● In the case of CYCL_ABS, overflows of the encoder areas are carried over in the NVRAM 

and taken into account when the cycle is resumed. With this setting, an overall reset must 
be carried out on the controller prior to initial loading of the project. Then, the encoder 
must be readjusted. If changes are made to the settings of the absolute encoder, the 
encoder must also be adjusted. 
With the controller switched off, the encoder may only be moved a maximum distance  
â‰¤ "half the encoder range" in both traversing directions in order to still be able to 
detect the exact position. 
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Completing the axis configuration 
 
14. Click Next .  
The set data is displayed. 

 

 

 
Figure 6-99 Last window of the axis configuration 

 
15. Click Finish. 
The settings are saved. A message appears, read the information and confirm this window. 
After the axis is created, a few more settings have to be made to optimize the interaction between SIMOTION and 
SIMODRIVE 611U. 
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6.10.3.4 Deactivating following error monitoring in SIMOTION SCOUT 
To prevent the following error monitoring interrupting an axis motion, it can be set to a higher 
value or deactivated.  
A high following error can occur, for example, as a result of a missing drive optimization. 
1. In the project navigator, open the folder of the created axis. 
2. Double-click Monitoring. 
3. Click the Following error monitoring tab in the working area. 
4. Deactivate the Dynamic following error monitoring active checkbox. 
5. Click Close. 
The following error monitoring must be matched to the requirements and mechanical system 
of the plant when commissioning an application. 

 

WARNING  
If the following error monitoring is increased or deactivated, larger incorrect motions can 
also occur on the axis in the case of an error (e.g. incorrect position control direction). This 
is particularly important, for example, when the axis only has a limited traversing range. 

 

 
Figure 6-100 Deactivating the following error monitoring 
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6.10.3.5 Setting the position control configuration in SIMOTION SCOUT 
1. In the project navigator, double-click Control under Axis. 
2. Set the following data in the working area: 

Kv factor: Enter 
Speed precontrol: Activate 
Fine interpolator: Select constant velocity interpolation 
Dynamic drive control (DSC): Leave activated 

 
Figure 6-101 Position control configuration 

3. Click Close. 
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6.10.3.6 Setting system cycle clocks in SIMOTION SCOUT 
1. In the project navigator, right-click Execution system and select Expert > Set system 

cycle clocks. 
2. Set the values. 
3. Click OK. 

A message appears, read the information and confirm with OK. 

 
Figure 6-102 Setting system cycle clocks - SIMODRIVE 611U 

Specifying the system cycle clocks 
The specifications for system cycle clocks in SIMOTION affect the position setpoint 
adjustment in the SIMODRIVE 611U. 

Special settings: SIMOTION 
The ratio of DP cycle clock to position control cycle clock and to interpolator cycle clock is 
set to 1:2:2, for example. This represents a DP cycle clock of 2 ms, a position controller 
cycle clock of 4 ms and an interpolator cycle clock of 8 ms. 

 

 Note 
Important: The position control cycle clock entered here must match the master application 
cycle in the HW Config! 

 
For instructions on how to activate and use interpolator cycle clock 2, see the online 
documentation in SIMOTION SCOUT.  
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6.10.3.7 Specify Homing Mode 
 

 Note 
The statements with respect to the homing modes in this section and the screenshots only 
refer to the homing settings for axes on a C2xx in connection with a SIMODRIVE 611U. The 
homing options depend on the respective drive. 

 
If the connected axis is to be homed, the homing mode must be specified in 
SIMOTION SCOUT. Depending on the mode selected, settings may also be necessary in 
the SIMODRIVE 611U. 

Additional references 
Please refer to the following document on this subject 
● SIMOTION Motion Control, TO axis, TO externalEncoder, Description of Functions 
Follow the steps outlined below: 
1. In the project navigator, double-click Homing under Axis. 
2. Enter the required homing mode and the appropriate data. 
3. Click Close. 

Homing mode "External zero mark only" 
When a defined edge of the external zero mark is crossed, the position is accepted. 

 
Figure 6-103 Homing (External zero mark only) 
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Special settings: SIMOTION 
If External zero mark only is selected as the homing mode, the approach direction can be 
selected by means of Homing direction. 

 
Figure 6-104 Axis homing in SIMOTION (homing mode External zero mark only) 

Special settings: SIMODRIVE 611U 
The homing external zero mark must be connected to input I0.x (x: Drive A or B) on the 
SIMODRIVE 611U. 
Parameterize input I0.x with the Equivalent zero mark function. You must enable the 
equivalent zero mark via parameter P879 Bit 13. 
Follow the procedure outlined in the section below on "Standard commissioning of 
SIMODRIVE 611U" for the parameterization of input I0.x. 
Comment on the internal 611U edge detection: 
For travel in the positive direction, only the signal change 1 → 0 is recognized as an 
equivalent zero mark. For travel in the negative direction, only the 0 → 1 edge is recognized 
as an equivalent zero mark. As a result, not all of the approach directions that can be 
selected in SIMOTION in combination with SIMODRIVE 611U can be used. 

Homing mode "Encoder zero mark only" 
An external zero mark signal is not necessary. The position is accepted at the next zero 
mark of the encoder. 
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SIMOTION 
If the encoder zero mark only is selected as the homing mode, the approach direction can be 
selected by means of the homing direction. 

 
Figure 6-105 Axis homing in SIMOTION (homing mode Encoder zero mark only) 

Special settings: SIMODRIVE 611U 
With this mode, a motor with an incremental encoder or resolver must be connected on the 
SIMODRIVE 611U. Otherwise, no additional settings are necessary. 
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Homing mode "Homing output cam and encoder zero mark" 
The axis traverses in the specified homing direction. Once the external zero mark signal is 
reached, the velocity of the axis switches from the homing approach velocity to the homing 
reduced velocity. Once the external zero mark is left, the axis is homed at the next detected 
zero mark of the encoder. 
The homing external zero mark is connected to an unassigned SIMOTION I/O input. 

 
Figure 6-106 Homing (Homing output cam and encoder zero mark) 
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Special settings: SIMOTION 
If "Homing output cam and encoder zero mark" is selected as the homing mode, the 
evaluation position of the zero mark can be selected via zero mark and the approach 
direction via homing direction. 
The homing external zero mark must be connected to a freely selectable digital input of 
SIMOTION which has been configured in the Home Axis window. When the external zero 
mark is reached, homing is enabled in the drive. 

 
Figure 6-107 Axis homing in SIMOTION (homing mode Homing output cam and encoder zero mark) 

Special settings: SIMODRIVE 611U 
With this mode, a motor with an incremental encoder or resolver must be connected on the 
SIMODRIVE 611U. Otherwise, no additional settings are necessary. 
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6.10.3.8 "Measuring" function 
You can use the "measuring" function to record the actual position of an axis at any time. A 
typical application is the acquisition of a print mark for the purpose of synchronizing the axis 
to this mark. 
The measuring input must be connected to the fast input I0.x. The input is isolated. This 
enables more than one input to be switched in parallel, whereby the reference potential of 
the 24 V supply of the measuring input (for example, from the network supply) must also be 
wired. 

SIMOTION C230-2

 
Figure 6-108 Measurement 

Inserting a measuring input in SIMOTION SCOUT 
1. Open the Measuring inputs folder in the project navigator. 
2. Double-click Insert measuring input. 
3. Enter a name for the measuring input. 
4. Click OK. 
5. Click Close. 
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SIMODRIVE 611U 
Parameterize the SIMODRIVE 611U with SimoCom U so that input I0.x addresses the 
measuring input. 
Comment on 611U-internal edge detection in HW versions up to 6SN 118-xxxxx--xxx1: 
For travel in the positive direction, only the 1 → 0 signal change is detected as a measuring 
signal.  
For travel in the negative direction, only the 0 → 1 edge is recognized as a measuring signal.  
You must take this into account when activating the measuring input. 
Settings in the Edge field (→ SIMOTION; calling the measuring function in the user program): 
● Rising edge or 
● Falling edge 
If you select another setting, the last valid value is taken over (rising or falling). 

Response times for the measuring function 
In SIMOTION, measuring can be used in various configurations. Depending on the 
connection of the axis (via PROFIBUS DP) and the processing level (position control cycle 
clock or IPO cycle clock), you must take different response times for the measuring function 
into account in the application. 
In the user program, measuring is started with the function call  
_enableMeasuringInput. You can specify when the measuring function is to be active during 
the call: 
● Immediately (without measuring window) 

MeasuringRangeMode = WITHOUT_SPECIFIC_AREA 
● Within a position-dependent measuring window 

MeasuringRangeMode = WITH_SPECIFIC_AREA 
When measuring without measuring window, the measuring input is immediately activated 
with _enableMeasuringInput. 
Before the measuring edge is evaluated at the hardware input, there is a configuration-
dependent runtime. To be certain to detect the measuring edge, you must ensure that 
_enableMeasuringInput is executed earlier by this amount of runtime in the user program. 
When measuring with measuring window, the job is first only registered in the system with 
_enableMeasuringInput. Only when the axis has reached the start of the measuring window 
is the measuring input activated. 
From the time of reaching the start position of the measuring window on the axis 
(mechanical) until the evaluation of the measuring edge at the hardware input, there is a 
configuration-dependent runtime. In order that the measuring input is active when the start 
position of the measuring window on the axis is reached, you must move the start of the 
measuring window forward depending on the axis velocity and the response time during the 
function call. 
This is also valid for the end of the measuring window. It is important that the measuring 
input is no longer active when the end of the measuring window on the axis (mechanical) is 
passed. 
These runtimes can be compensated with the MeasuringRange.activation 
Time configuration data item. 
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 Note 
The runtimes are only compensated without error for constant axis velocity. 

 
The offset of the measuring window only functions reliably when the axis velocity 
● within the measuring window is constant and 
● known before the function call. 
You can determine the response times for your configuration using the following tables. The 
values in the tables refer to set system cycle clocks. By using the actual times, you can 
calculate the response time in milliseconds. 
The following abbreviations are used in the tables: 
● (IS) IPO cycle clock or position control cycle clock 

(is dependent on whether the measuring input is processed in the IPO or position control 
cycle clock; can be selected during the configuration of the measuring input) 

● (DP) Cycle time on the PROFIBUS DP 
Tool calculates the anticipated response and rate times when using measuring inputs on 
different hardware More at: 
● 4_TOOLS\MEASURING_INPUT_CALCULATION 

Table 6-16 Activate measuring immediately 

 SIMODRIVE 611U 
_enableMeasuringInput 
→ Ready to detect the measuring edge 

3 (IS) + 7 (DP) 

Detection of the measuring edge 
→ Result in SIMOTION for further processing 

2 (IS) + 10 (DP) 

Total 
Minimum time between two measurements *) 

5 (IS) + 17 (DP) 

 

Table 6-17 Measuring in the measuring window: Measuring edge is detected in the window 

 SIMODRIVE 611U 
_enableMeasuringInput 
→ Ready for the evaluation of the measuring range (start of the 
measuring window) 

2 (IS) 

Start of the measuring window on the axis (mechanical) reached 
→ Ready to detect the measuring edge 

2 (IS) + 7 (DP) 

Detection of the measuring edge 
→ Result in SIMOTION for further processing 

2 (IS) + 10 (DP) 

Total 
Minimum time between two measurements *) 

5 (IS) + 17 (DP) 
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Table 6-18 Measuring in the measuring window: No measuring edge in the window 

 SIMODRIVE 611U 
_enableMeasuringInput 
→ Ready for the evaluation of the measuring range (start of the 
measuring window) 

2 (IS) 

Start of the measuring window on the axis (mechanical) reached 
→ Ready to detect the measuring edge 

2 (IS) + 7 (DP) 

Start of the measuring window on the axis (mechanical) reached 
→ Reset: "Ready to detect the measuring edge" 

2 (IS) + 7 (DP) 

Resetting of the ready to measure 
→ Checkback signal in SIMOTION for further processing 

2 (IS) + 10 (DP) 

Total 
Minimum time between two measurements *) 

7 (IS) + 24 (DP) 

*) In addition, the restrictions of the respective system must be taken into account. 
 

6.10.3.9 Drive configuration for SIMODRIVE 611U 
The commissioning tool SimoCom U is used for commissioning the SIMODRIVE 611U. This 
SimoCom U commissioning tool is intuitive for the most part. You are guided through the 
individual steps. 
The connection to the drive can either be made via a serial interface or PROFIBUS DP. 
1. Start SimoCom U. 
2. A window appears in which you are asked whether you want to change the data for the 

drive. 
3. Establish a serial connection (PROFIBUS DP) between SimoCom U and the drive. 
4. Select Find online drives.... 

The advantage of this is that you do not have to enter the data for the controller card and 
the PROFIBUS module. This data is read out and displayed by SimoCom U. 

 
Figure 6-109 Drive configuration for SIMODRIVE 611U 
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Figure 6-110 Drive configuration for SIMODRIVE 611U with SimoCom U 

5. Click Configuration under Drive A. 
6. Click the Reconfigure drive button in the working area. 

 

  Note 
If you use a double axis module, you must perform the following procedure twice, for 
Drive A and Drive B. You must make sure that the PROFIBUS address setting is 
applicable to both drives. The same PROFIBUS message frame must be used for both 
drives. 

7. Enter a name for the drive. 
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Figure 6-111 SimoCom U: Drive Configuration window 

8. Click Next. 
In the Select SIMODRIVE window, the order numbers of the controller module and the 
PROFIBUS module are displayed with a gray background, as you are connected online 
with the SIMODRIVE 611U. These input values cannot be changed. 

 
Figure 6-112 SimoCom U: SIMODRIVE Selection window 

9. Enter the PROFIBUS address. 
The address must agree with the bus address specified in the SIMOTION hardware 
configuration. 
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Figure 6-113 SimoCom U: Motor Selection window 

10. Select the connected motor. You can find the data on the type plate of the motor. 
11. Click Next. 

 
Figure 6-114 SimoCom U: Measuring System / Encoder window 

12. Select the measuring system. 
13. Click Next. 

You require this data in SIMOTION to adjust the encoder when you commission the axis. 
Use this number to find the corresponding input values for the SIMOTION axis 
configuration in the "List of encoder data". 
– In the Operating Mode window, you must select the speed/torque setpoint. This option 

is only available for the 611U closed-loop control modules that are also capable of 
positioning operation. 
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Figure 6-115 SimoCom U: Operating Mode window 

14. Select the operating mode. 
15. Click Next. 

 
Figure 6-116 SimoCom U: Direct Measuring System / Encoder window 

16. If desired, select the direct measuring system. 
This encoder can only be measured on a double-axis module via the measuring input for 
Axis B. As a result, Axis B is no longer available for controlling an axis. 
If you use the direct measuring system, you must select a PROFIBUS message frame 
that contains a second encoder. In SIMOTION, you can assign this encoder for the 
position control or create an external encoder that accesses this actual value. 

17. Click Next. 
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Figure 6-117 SimoCom U: Completion of the Drive Configuration window 

The Completion of the Drive Configuration window displays a summary of the inputs. 
18. Click Calculate controller data, save, reset. 
19. Select the PROFIBUS Parameterization window. Here you can select the PROFIBUS 

address of the drive, 3 in this example, and the message frame, 105 in this example. 
In SIMOTION, specify this data during the hardware configuration to adjust the drive. 

 

 Note 
Error message for the drive enable. 
If a TO alarm appears for the axis enable with absolute encoder, the encoder data is not yet 
valid on the drive interface. The status of the encoder system must be queried before calling 
the enable command. The enable command can be issued when the axis system variable 
sensordata[1].state displays the status VALID. 
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Figure 6-118 SimoCom U - Drive A 

● Optional: Select the Digital Inputs window. Here you can define the function of input I0.x. 
If you want to use the "measuring function" in SIMOTION, you must select the "Flying 
measurement / length measurement" function here. 
If you want to use the "External zero mark only homing" function in SIMOTION, you must 
select the "Equivalent zero mark" function here. In addition, you must enable the 
equivalent zero mark function via parameter P879 Bit 13. 

 

  Note 
You cannot have "measuring" and "equivalent zero mark" active on a drive at the same 
time, because you may only select the functions on input I0.x. If you need both functions 
on a drive, you must switch the function. The section on "Expert functions" describes how 
you can write (switch) parameters in the drive from the user program. 
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Figure 6-119 SimoCom U - Drive A digital inputs 

Not all of the parameters for the SIMODRIVE 611U can be specified by means of technology 
screen forms. To enter parameters directly (e.g. parameter P879), open the expert list. Here 
you can select and modify the relevant parameters. 
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Figure 6-120 SimoCom U - Drive A expert list 

Parameters to be entered directly: 
● P879 Bit 13: 

Enabling of the equivalent zero mark function. This setting is necessary if you use the 
"External zero mark only homing" function. In addition, you must select the Equivalent 
zero mark function for input I0.x. 

● P880: 
The scaling of the PROFIBUS speed value is specified here. For the maximum motor 
speed, a setpoint NSET = 4000 0000hex is transferred to the drive via the PROFIBUS. 
The P880 parameter is used to inform the SIMODRIVE 611U which speed should be set 
when NSET = 4000 0000 hex. This speed must agree with the "maximum motor speed" 
value specified when the axis was created (SIMOTION SCOUT: Axis Configuration - 
Drive window). 

This concludes the drive configuration. If there are no errors, the green 5 VDC LED and the 
yellow STOP LED are now illuminated on the SIMOTION. The keyswitch is in the STOP 
position. The LED on the PROFIBUS module of the SIMODRIVE 611U is illuminated green. 
The standard commissioning is now completed. You can continue with the section Creating 
a sample program for positioning in SIMOTION SCOUT. 
If you would like to use special functions of the SIMODRIVE 611U from the user program, 
you should also read the Expert functions section. 
 



FAQs  
6.10 SIMODRIVE 611U to SIMOTION 

 SIMOTION SCOUT 
260 Configuration Manual, 03/2007 Edition 

6.10.4 Expert functions 
This section explains functions that can be used in conjunction with the SIMODRIVE 611U 
and that go beyond the standard connection. 
These functions primarily involve evaluating or influencing data (parameters) of the 
SIMODRIVE 611U in the user program. Several options are available for this: 
● If the desired value is already contained in the message frame used for the axis 

connection, you can poll the value directly (cyclically). 
● If the desired value is not contained in the used message frame, but can be provided 

cyclically by the SIMODRIVE 611U, it is possible to lengthen the message frame. 
● If the value is not available cyclically, you can expand the message frame to include the 

parameter identifier value (PIV) mechanism and access the parameters of the 
SIMODRIVE 611U acyclically. 

Furthermore, you can make certain operational settings on the SIMODRIVE 611U such as 
control of just one axis with the double-axis module, or utilize functions such as using 
unassigned analog inputs and outputs in the user program. 

 

 Note 
This section assumes that you are well-acquainted with the functions of the SIMODRIVE 
611U. The function options are only briefly presented. For more information, refer to the 
Description of Functions for SIMODRIVE 611 universal "Closed-Loop Control Components 
for Closed-Loop Speed Control and Positioning". 

 

Important parameters on the SIMODRIVE 611U 
The table lists the parameters of the SIMODRIVE 611U that are evaluated in connection with 
SIMOTION or must be taken into account during adaptation to SIMOTION. 
Some of the listed parameters are entered during the standard commissioning. 

Table 6-19 Selection of some parameters and their meaning 

Parameter Meaning 
P 660 Function selection for input I0.x 

79 Equivalent zero mark 
If the zero mark of the encoder cannot be evaluated during homing, a signal  
supplied by an appropriately mounted encoder can be fed in as  
"equivalent zero mark" via this input. 
80 Measuring input 
Maximum number of measuring inputs for SIMODRIVE 611U = 1;  
Caution: Measuring can only be performed via this input (I0.x). 

P 700 Operating mode 
For 2-axis module only: Axis B can be deselected. 

P 875 Expected optional module type 
PROFIBUS communication for Drive B can be deactivated here, if only one axis is 
operated on the 2-axis module. 
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Parameter Meaning 
P 879 Sign-of-life monitoring in the drive is active  

Bit 0,1,2: Permissible sign-of-life errors 
Bit 8: Deselect sign-of-life monitoring 
Bit 12: Activate direct measuring system 
Bit 13: Use incremental measuring system with equivalent zero mark 

P 880 Specifies scaling of the speed for motion with PROFIBUS DP. Here you specify the 
maximum speed of the motor. You must also specify this speed when creating the axis 
in SIMOTION SCOUT. 

P 881 Specifies scaling of torque reduction for motion with PROFIBUS DP. 
P 915 PZD setpoint assignment for PROFIBUS 
P 916 PZD actual value assignment for PROFIBUS 
P 918 DP slave address as specified in the project with HW Config. 
P 922 Message frame type as specified in the project on the axis. 
P 1001 Speed controller cycle clock 

Input value 4 → 4 x 31.25 ∝s = 125 ∝s for sin/cos 1 Vpp drives 
Input value 16 → 16 x 31.25 ∝s = 500 ∝s for resolver drives 

P 1042 
P 1044 

Fine resolution of absolute track G1_XIST1 → fixed input value: 11 
Fine resolution of absolute track G2_XIST1 → fixed input value: 11 

P 1043 
P 1045 

Fine resolution of absolute track G1_XIST2 → fixed input value: 9 
Fine resolution of absolute track G2_XIST2 → fixed input value: 9 

P 1795 Firmware for option module 
P 1799 Firmware for closed-loop controller 

PROFIBUS message frame 
Your application may require that certain drive data be evaluated in the user program. Using 
the message frame structure, you can see which data are available by default for evaluation 
with the respective message frame. You may read, but not modify the data in the user 
program as this data is supplied by the axis. 
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Figure 6-121 Message frame structure 
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Table 6-20 Signal list assignment 

SIMODRIVE 611U signal 
number 

Designation Short designation Signal length 

50001 Control word 1 STW1 16 bit 
50003 Control word 2 STW2 16 bit 
50005 Speed setpoint A  

(nset–h) 
NSET_A 16 bit 

50007 Speed setpoint B  
 (n-set (h + l)) 

NSET_B 32 bit 

50009 Encoder 1 control word G1_STW 16 bit 
50013 Encoder 2 control word G2_STW 16 bit 
50017 Encoder 3 control word G3_STW 16 bit 
50025 System deviation (DSC) XERR 32 bit 
50026 Position controller gain factor 

(DSC) 
KPC 32 bit 

    
50002 Status word 1 ZSW1 16 bit 
50004 Status word 2 ZSW2 16 bit 
50006 Actual speed value A  

(nact-h) 
NACT_A 16 bit 

50008 Actual speed value B  
(n-act (h + l)) 

NACT_B 32 bit 

50010 Encoder 1 status word G1_ZSW 16 bit 
50011 Encoder 1 actual position 

value 1 
G1_XIST1 32 bit 

50012 Encoder 1 actual position 
value 2 

G1_XIST2 32 bit 

50014 Encoder 2 status word G2_ZSW 16 bit 
    
Device-specific signals for "SIMODRIVE 611 universal": 
50015 Encoder 2 actual position 

value 1 
G2_XIST1 32 bit 

50016 Encoder 2 actual position 
value 2 

G2_XIST2 32 bit 

50101 Torque reduction MomRed 16 bit 
50103 Analog output  

Terminal 75.x/15 
DAC1 16 bit 

50105 Analog output  
Terminal 16.x/15 

DAC2 16 bit 

50107 Digital outputs  
Terminals O0.x to O3.x 

DIG_OUT 16 bit 

50111 Distributed inputs DezEing 16 bit 
50113 Torque setpoint  

external 
MsetExt 16 bit 

50102 Message word MeldW 16 bit 
50104 Analog input  

Terminal 56.x/14 
ADC1 16 bit 
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SIMODRIVE 611U signal 
number 

Designation Short designation Signal length 

50106 Analog input  
Terminal 24.x/20 

ADC2 16 bit 

50108 Digital inputs  
Terminals I0.x to I3.x 

DIG_IN 16 bit 

50110 Utilization Ausl 16 bit 
50112 Active power Pactive 16 bit 
50114 Smoothed torque setpoint Mset 16 bit 
50116 Smoothed torque-producing 

current Iq 
IqGl 16 bit 

Adapting message frames individually 
The drive may require additional functions, beyond the predefined message frames, for an 
application. It is possible to expand the predefined message frame for this purpose. These 
additional words can be addressed via the I/O interface of SIMOTION. The technology object 
does not access this data. 
To adapt a message frame individually: 
1. Find the message frame type required for your axis type from the table above. 
2. In HW Config, append the desired number of additional words after the last word of the 

selected message frame. 
Note: As the message frame structure no longer corresponds to the selected message 
frame type, another message frame or "no message frame" is displayed. 

3. When creating the TO in SIMOTION, you must specify the originally selected message 
frame type. The TO evaluates only the number of words corresponding to the specified 
message frame type. The additional words can be processed in the user program. 

4. In the SIMODRIVE 611U, you must generate the desired message frame structure 
manually using the signal numbers. To do this, set parameter P922 to 0. You can use 
parameter P915 Index 1 to 16 and parameter P916 Index 1 to 16 to enter the signal 
numbers corresponding to the message frame. 

A maximum of 16 PZD words can be read or written. 
Furthermore, an expansion to include the PIV area is possible. This enables parameter 
contents to be read or written by means of a job mechanism. 
The following procedure must be followed: 
1. Find the message frame type required for your axis type in the table. 
2. In HW Config, select the PIV area. 

Comment: As the message frame structure no longer corresponds to the selected 
message frame type, another message frame or "no message frame" is displayed. 

The step-by-step procedure for the expansion of the message frame is described using two 
examples. 
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Example 1: Expanding the process data area 
The signals of the process data area are updated in the PROFIBUS cycle clock. The 
evaluation takes place on the SIMODRIVE 611U in the speed control cycle clock (default 
125 �s). 

Task 
Based on the desired axis functionality, message frame 102 is to be used to connect the 
SIMODRIVE 611U. 
Both of the analog inputs of the SIMODRIVE 611U are to be read in the user program. 
An analog value of 0 to 10 V is to be output via the two analog outputs. 
The actual torque value of the drive is to be evaluated in the user program. 

 

 Note 
The analog channels on the SIMODRIVE 611U are not required for the PROFIBUS 
connection, and the user can make use of these as desired. 

 
In order to utilize the functions, message frame 102 must be expanded as follows: 

 
Figure 6-122 Message frame 102 
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Adaptations for SIMODRIVE 611U with SimoCom U 
Settings differ from those described in the section on "Commissioning" as follows: 
1. Call up the Analog outputs menu item in the SimoCom U. 
2. Parameterize  

the function Signal DAC1 from PROFIBUS PP0 for the first output, 
the function Signal DAC2 from PROFIBUS PP0 for the second output. 

3. Expand the PROFIBUS message frame via the expert list as follows. 
Approach: 
– P922 = 102 

This results in a standard assignment of the P915 and P916 parameters 
corresponding to message frame 102. 

– P922 = 0 
This setting enables you to freely set up the message frame using the P915 and P916 
parameters. The standard assignment (step 1) is still available, i.e. you only have to 
enter the additional signals. 

P915:1 to P915:6 → standard assignment corresponding to message frame 102 setpoints 
P915:7 = 50103 → analog output 1 (DAC1) 
P915:8 = 50105 → analog output 2 (DAC2) 
P916:1 to P916:10 → standard assignment corresponding to message frame 102 actual 
values 
P916:11 = 50104 → analog input 1 (ADC1) 
P916:12 = 50106 → analog input 2 (ADC2) 
P916:13 = 50114 → smoothed torque setpoint (Mset) 

Settings via SIMOTION SCOUT 
Settings differ from those described in the section on "Commissioning" as follows: 

Configuring the hardware: 
● Message frame selection: 

Select message frame 102. 
● Change the length from 6 to 8 in the Setpoint line  

(2 additional words DAC1 and DAC2) 
● Change the length from 10 to 13 in the Actual value line  

(3 additional words ADC1, ADC2 and Mset) 
Note the I/O start address for both areas, for example, 256. 

 

 Note 
Due to this change, the message frame structure no longer corresponds to message frame 
102. For this reason, either "No message frame" or another message frame type is displayed 
after the change, which you can ignore. You address the drive using the originally intended 
message frame type, 102 in our example. 
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Creating the TO axis 
● Axis configuration: 

The drives created in the HW configuration can be selected here. Select the required 
drive. 

● Message frame:  
Specify message frame type 102. The part of the message frame relevant for the 
TO axis, corresponds to message frame 102. 

Creating the I/O area 
Create two I/O output words and three I/O input words for the additional functions in the I/O 
container. The addresses are calculated are follows: 
● Address = message frame start address + (PZD number - 1) x 2 
● Example for ADC2: 
Message frame start address: 256 
ADC2 is on PZD12: 12 
I/O input address for ADC2 = 256 + (12 - 1) x 2= 278 

Activating the PIV area 
You can perform the following tasks via the PIV area (PIV = parameter identifier value): 
● Request parameter value (reading of parameters) 
● Change parameter value (writing of parameters) 
The PIV area consists of 8 bytes.  

Table 6-21 PIV area 

Bit 0-10 = PNU 
Bit 12-15 = AK 

Reserved IND PWE 

Byte 1 Byte 2 Byte 3 Byte 4 Byte 5 Byte 6 Byte 7 Byte 8 

PNU: parameter number 
AK: request or response ID 
IND: subindex, subparameter number, array index 
PWE: parameter value 
The exact structure and handling of the area is contained in the Description of Functions for 
SIMODRIVE 611U. 

Task in example 2 
● Based on the desired axis functionality, message frame 102 is to be used to connect the 

SIMODRIVE 611U. 
● The motor temperature is to be read out from parameter P603 in the user program. 
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Adaptations for SIMODRIVE 611U with SimoCom U 
Settings differ from those described in the section on "Commissioning" as follows: None 

Settings via SIMOTION SCOUT 
Settings differ from those described in the section on "Commissioning" as follows: 

Configuring the hardware 
● Message frame selection: Select message frame 102 
● Click the "No PIV area" cell and select the "PIV area" setting. 
Note the I/O start address for the PIV area, for example, 256.  

 

 Note 
Due to this change, the message frame structure no longer corresponds to message frame 
102. For this reason, either "No message frame" or another message frame type is displayed 
after the change, which you can ignore. You address the drive using the originally intended 
message frame type (102 in our example). 

 

Creating the TO axis 
● Axis configuration: 

The drives created in the HW configuration can be selected here. Select the required 
drive. 

● Message frame:  
Specify message frame type 102. The message frame structure relevant for the TO axis, 
corresponds to message frame 102. 

Creating the I/O area 
Create one I/O input byte array for the response area and one I/O output byte array for the 
request area in the I/O container, with each array having a length of 8 bytes. The start is on 
the I/O address you noted for the PIV area (hardware configuration).  
Example for requesting the P603 parameter (motor temperature): 
Request ID: 6 → (request parameter value (array); refer to SIMODRIVE 611U - Description) 
Parameter number: 603 = 16#25B 
Index: 0 

Table 6-22 PIV area 

 Bit 0-10 = PNU 
Bit 12-15 = AK 

Reserved IND PWE 

 Byte 1 Byte 2 Byte 3 Byte 4 Byte 5 Byte 6 Byte 7 Byte 8 
Request 
area  

16#62 16#5B 0 0 0 0 0 0 
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 Bit 0-10 = PNU 
Bit 12-15 = AK 

Reserved IND PWE 

Respons
e area 

16#42 16#5B 0 0 Data 4 Data 3 Data 2 Data 1 

 
 

 Note 
The entered response identifier (4) corresponds to the positive request transaction. 

 

Deactivating the sign-of-life monitoring 
The PROFIBUS connection between SIMOTION and the SIMODRIVE 611U is monitored 
using the sign-of-life. As a general principle, sign-of-life monitoring must be active during 
operation. Sign-of-life monitoring is automatically selected when the axis is created. In case 
of problems (for example, alarm 832 on the SIMODRIVE 611U), the sign-of-life monitoring 
can be deactivated temporarily for diagnostic purposes. 
In SIMOTION, parameters for the sign-of-life monitoring can be selected or deselected on 
the TO axis via Expert list > Configuration data ....lifeSignCheck. 
The sign-of-life monitoring can be deactivated in the SIMODRIVE 611U via parameter 
P879 Bit 8. 

2. Activating the second encoder 
In SIMOTION, you can use the second encoder input on the SIMODRIVE 611U double-axis 
module for the actual value acquisition. Axis B of the SIMODRIVE 611U cannot then be used 
to control a motor. 
A PROFIBUS message frame must be used for the second encoder in SIMOTION. 
When creating Axis A in the SIMODRIVE 611U:  
Create the second encoder by specifying Which direct measuring system are you using? > 
Enter data. Then enter the required encoder type. Depending on the configuration of the 
SIMODRIVE 611U, it is necessary to adapt the following parameters: 
Parameter P879 Bit 12 = 1 → Enable direct measuring system (Axis A) 
Parameter P922 → PROFIBUS message frame type (Axis A) 
Parameter P700 = 0 → Deselect Axis B (Axis B) 
Parameter P875 = 0 → Expected option module type (Axis B) 
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6.10.5 Commissioning the 611U with DSC 
To operate SIMOTION with DSC (dynamic servo control) on the SIMODRIVE 611U via the 
PROFIBUS, you must enter special settings in three places when you assign parameters. 

Hardware configuration 
For SIMODRIVE 611U, you must select a PROFIBUS message frame type that supports 
DSC. Here they are the message frames 5, 6, 105 and 106.  

 
Figure 6-123 Message frame type in the HW Config 
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Activating DSC in SIMOTION SCOUT 
You must activate a parameter in SIMOTION SCOUT in order to use the DSC function. DSC 
can be activated individually for each axis. This means that mixed operation is also possible. 
DSC is activated via: 
● Axis/Expert/Expert list/Configuration 

data/TypeOfAxis/NumberOfDataSets/DataSet_1/ControllerStruct/PV_Controller/enableD
SC=YES 

 
Figure 6-124 Activating DSC in SIMOTION SCOUT 
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Setting in the SIMODRIVE 611U 
In the SIMODRIVE 611U, DSC is automatically activated when the PROFIBUS message 
frame type is set, i.e. the drive internal position controller is active as soon as Xerr (following 
error) and Kpc (position controller gain) are sent to the drive.  
You should set the same message frame type selected in HW Config under PROFIBUS 
parameterization / message frame selection (corresponds to P922 in the expert list). 

 
Figure 6-125 Setting during operation 
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6.11 Creating a sample program for positioning in SIMOTION SCOUT 

Program overview 
In this section, a program for positioning the connected axis is created in the MCC (Motion 
Control Chart) editor. 

Inserting the programs 
Set four programs with MCC. 
● motion_1 
● backgr 
● perfault 
● tecfault 

Creating a program with MCC 
1. Open the Programs folder under the created SIMOTION device in the project navigator. 
2. Double-click Insert MCC unit. 
3. Enter the name motion_1 for the MCC unit. 
4. Click the Compiler tab. 
5. Activate the required settings. 
6. Click OK. An MCC unit is created in the project navigator. 
7. Double-click the MCC unit motion_1 in the project navigator. 
8. Double-click Insert MCC chart. 
9. Enter the name motion_1 for the MCC. 
10. Click OK. The MCC is opened. 
11. Click the Single-axis commands > Switch axis enable icon. 

The command is inserted. 
12. Click the Single-axis commands > Position axis icon. 

The command is inserted. 
13. Click the Single-axis commands > Remove axis enable icon. The command is inserted. 
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Figure 6-126 Menu bar of the single-axis commands 

 
Figure 6-127 Opened command: Position axis 

14. Double-click the Switch axis enable command. 
15. Click OK. 
16. Double-click the Position axis command. 
17. Enter the value 2000 at Position. 
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18. Select Relative in the Type field. 

 
Figure 6-128 Arrangement of the single-axis commands in MCC motion_1 

19. Click OK. 
20. Double-click the Remove axis enable command. 
21. Click OK. 
22. Compile using the menu command MCC chart > Apply and compile. 



FAQs  
6.11 Creating a sample program for positioning in SIMOTION SCOUT 

 SIMOTION SCOUT 
276 Configuration Manual, 03/2007 Edition 

Creating the backgr program 
1. Double-click Insert MCC unit. 
2. Enter the name backgr for the MCC unit. 
3. Click the Compiler tab. 
4. Activate the required settings. 
5. Click OK. An MCC unit is created in the project navigator. 
6. Double-click the MCC unit backgr in the project navigator. 
7. Double-click Insert MCC chart. 
8. Enter the name backgr for the MCC. 
9. Click OK. The MCC is opened. 
10. Enter the following variable data in the MCC unit backgr. 

– In the Name field: Run 
– As the variable type, select: VAR_GLOBAL 
– As the data type, select: BOOL 
– In the Initial value field: False 

 
Figure 6-129 Entering a global variable 

11. Switch to the MCC Chart backgr tab. 
12. In the Program structures command bar, click on the  

IF program branch icon. 
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Figure 6-130 IF program branch under basic commands 

13. Double-click the IF program branch command. 
14. Select Formula and enter the condition Run=true. 

 
Figure 6-131 Configuration of the IF program branch 

15. Confirm the input with OK. 
16. In the Task commands command bar, select the command Start task. 

This inserts the command. 
17. In the Important commands command bar, select the command Variable assignment. 

This inserts the command. 
18. Double-click the Start task command. 
19. Click OK to confirm. 
20. Double-click the Variable assignment command. 
21. Enter the statement Run:=false. 
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Figure 6-132 Configuration of the variable assignment 

22. Confirm withOK. 

 
Figure 6-133 Completed program of the BackgroundTask 

23. Select from the menu bar MCC Chart > Apply and compile. 
The detail display in the Compile/Check output tab displays the progress and completion 
of the compilation. 
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Creating the perfault program 
1. Double-click Insert MCC unit. 
2. Enter the name perfault for the MCC unit. 
3. Click the Compiler tab. 
4. Activate the required settings. 
5. Click OK. An MCC unit is created in the project navigator. 
6. Double-click the MCC unit perfault in the project navigator. 
7. Double-click Insert MCC chart. 
8. Enter the name perfault for the MCC. 
9. Click OK. The MCC is opened. 
10. Select from the menu bar MCC chart > Apply and compile. 

Creating the tecfault program 
The procedure for creating the tecfault program is exactly the same as for the perfault 
program. 
In the MCC unit and MCC chart, enter tecfault as the name. 
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Assigning programs to the execution system 
1. In the project navigator, double-click Execution system under the SIMOTION device. The 

execution system is opened in the working area. 

 
Figure 6-134 Execution system of the SIMOTION device 

2. Click the MotionTasks button. 
3. Assign the motion_1 program to MotionTask_1. 
4. Assign the backgr program to the BackgroundTask. 
5. Assign the perfault program to the PeripheralFaultTask. 
6. Assign the tecfault program to the TechnologicalFaultTask. 
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Figure 6-135 Assignment of the tasks in the task system 

7. Click the Save project and compile all button. 

Loading the programs to the SIMOTION device and switching to RUN 
The keyswitch of the C230 is still set to STOP.  
1. Establish an online connection. Click the Connect to target system button. 
2. Click the  Download project to target system button. 

This can take several minutes. 
3. Switch the SIMOTION device to RUN via the keyswitch after the project has been 

downloaded to the target system. Two LEDs, the green 5 VDC and the RUN LED, light 
up. 
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Monitoring and controlling in SIMOTION SCOUT 
1. Click the Connect to target system button. 
2. Select the backgr program. 
3. Select the Symbol browser tab. 
4. As control value, enter the variable Run "TRUE". 
5. Activate the setting in Status value. 
6. Click Start status. The value FALSE is displayed. 
7. Activate the setting in Control value. 
8. Click Control immediately. 

 
Figure 6-136 Monitoring and controlling the variable in the BackgroundTask 

The motor now rotates at 6000 rpm and approaches the position 2000 mm. You can 
check this by selecting Axis_1 under Axes, opening positioningstate in the symbol 
browser, and noting the actualposition. 

9. Select the variable to be monitored. 
10. Click Start status. 
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Figure 6-137 Checking the positioning motion in the symbol browser of Axis_1 

When the axis has finished positioning, a value of 2000 mm appears here. If the positioning 
is restarted, the actual position value increases by 2000 mm for each motion. 
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6.12 Advanced Diagnostics on SCOUT crash 
In the rare event of a SCOUT crash, important diagnostics data can be stored. This data is 
important for the reproducibility of the error in order to determine the cause. Contact the 
hotline straightaway and forward the diagnostics data.  
The following dialog "Siemens Automation Diagnostics" would open: 

 
Figure 6-138 Siemens Automation Diagnostics 

Please note the following: 
1. Click on the Create report button to generate the diagnostics data. 

Another dialog opens. 
 

  Note 
If you close the dialog by pressing Cancel, the diagnostics data is not saved! 

 
Figure 6-139 Generate Diagnostics Data 

2. Click Detailsbutton. Another "Siemens Automation Diagnostics" dialog is displayed. 
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Figure 6-140 Siemens Automation Diagnostics - Details 

In this window, there is more detailed information in the Details and Common data tabs. 
● Add File(s) button 

Here, you can add more user-specific files to the diagnostics directory. 
● View Report button 

The problem details are displayed in plain text. 
● Close button 

The dialog closes. The diagnostics data is saved in the following default directory: 
– U7umc/data/AdvancedDiagnostic/<files> 

● Save As button 
You can select a user-defined directory to save the diagnostics data to. 

● Discard button 
Corresponds to 'Cancel', the diagnostics data is not saved. 
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Technical data 7
7.1 Quantity framework 

Technical data 

Table 7-1 Quantity framework for SIMOTION devices 

SIMOTION devices C2xx; P350-3; D4xx 
Execution system 
- task structure / program 
execution 

BackgroundTask 1 
(adjustable monitoring time) 

 TimerInterruptTasks (as of 1 ms) 5 
 MotionTasks 32  

(for C2xx = 20) 
 ServoSynchronousTasks 

(synchronous with the position control 
cycle clock) 

1 

 IPOSynchronousTasks 
(synchronous with the interpolation 
cycle clock) 

2 

 InterruptTasks (for user) 2 
 TControlTasks 5 
 StartupTask 1 
 ShutdownTask 1 
Execution system 
- task structure / error 
processing 
(SystemInterruptTasks) 

ExecutionFaultTask 1 

 TechnologicalFaultTask 1 
 PeripheralFaultTask 1 
 TimeFaultTask 1 
 TimeFaultBackgroundTask 1 
Communication Guaranteed engineering system 

connections 
1 

 Guaranteed HMI connections 5 
 Number of connection points 16 
 Number of routed connections 10 
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SIMOTION devices C2xx; P350-3; D4xx 
PROFIBUS DP Equidistance Possible 
 Baud rates 1.5; 3; 6; 12 Mbaud 
 Number of slaves 64 max. per DP line 
PROFINET 
(not C2xx) 

Number of devices Max. 64 

Diagnostics and alarms Diagnostics buffer 200 entries 
 Technological alarms 160 entries 
 Alarm_S (buffer) 40 entries 
Cycle clocks and times Ratio of position control cycle clock to 

DP cycle clock 
1:1 to 1:4 (for C2xx = 1:1, 2:1) 

 Ratio of position control cycle clock to 
PN cycle clock 

1:1 ... 16:1 

 Ratio of IPO1 cycle clock to position 
control cycle clock 

1:1 ... 1:6 

 Ratio of IPO2 cycle clock to IPO1 
cycle clock 

2:1 to 64:1 
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Table 7-2 Quantity framework for SIMOTION C2xx 

SIMOTION device C230-2 C240 
User memory RAM disk for user data 16 MB 20 MB 
 Main memory (user RAM) 16 MB 21 MB 
 Retentive user variables  

(retain variables) 
12 KB 100 KB 

Memory medium for retentive user data on the MMC 
(Micro Memory Card) 

32 MB 64 MB 

Memory space available to the user on the memory medium 
(persistent memory) 

26 MB 58 MB 

Address space Permanent process image for 
BackgroundTask (I/O variables) 

64 bytes 

 Additional configurable process image for 
cyclic task (I/O variables) 

Yes 

 Logical I/O address space 2 KB 4 KB 
 Physical I/O address space for 

PROFIBUS 
(max. per line for inputs and outputs 
respectively) 

1 KB 

 Address space for each PROFIBUS DP 
station 

244 bytes 

Technology objects Maximum number of axes 32 
 Number of measuring inputs 

(measurement on onboard encoder) 
2 2+4 

 Onboard outputs for output cams 8 max. (140 µs) 8 max. (70 µs) 
Cycle clocks and 
times 

PROFIBUS DP cycle clock 1.5 ... 8 ms 1 ... 8 ms 

 Minimum position control cycle clock 1.5 ms 1 ms 

 

Table 7-3 Quantity framework for SIMOTION P350 

SIMOTION device P350-3 
User memory RAM disk for user data 16 MB 
 Main memory (user RAM) 14 MB 
 Retentive user variables  

(retain variables) 
15 KB 
(up to 256 KB with UPS) 

Memory medium for retentive user data:  File on hard disk 
Memory space available to the user on the memory medium 
(persistent memory) 

Any 

Address space Permanent process image for 
BackgroundTask (I/O variables) 

64 bytes 

 Additional configurable process image for 
cyclic task (I/O variables) 

Yes 

 Logical I/O address space 4 KB 
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SIMOTION device P350-3 
 Physical I/O address space for 

PROFIBUS 
(max. per line for inputs and outputs 
respectively) 

1 KB 

 Physical I/O address space for PROFINET 
(max. per line for inputs and outputs 
respectively) 

4 KB 

 Address space for each PROFIBUS DP 
station 

244 bytes 

 Address space for each PROFINET 
device station 

1400 bytes 

Technology objects Maximum number of axes 64 
 Number of measuring inputs – 
 Onboard outputs for output cams - 
Cycle clocks and 
times 

PROFIBUS DP cycle clock 1 ... 8 ms 

 PROFINET cycle clock In 0.125 ms increments: 0.25 ... 4 ms 
 Minimum position control cycle clock 0.25 ms 

 

Table 7-4 Quantity framework for SIMOTION D4xx 

SIMOTION device D410 D425 / D435 D445 
User memory RAM disk for user data 17 MB 11 MB 23 MB 
 Main memory (user RAM) 25 MB 15 MB 30 MB 
 Retentive user variables  

(retain variables) 
7 KB 320 KB 

Memory medium for retentive user data: 
CompactFlash card (CF card) 

512 MB 

Memory space available to the user on the memory medium 
(persistent memory) 

300 MB 

Address space Permanent process image for 
BackgroundTask (I/O variables) 

64 bytes 

 Additional configurable process image for 
cyclic task (I/O variables) 

Yes 

 Logical I/O address space 16 KB 
 Physical I/O address space for PROFIBUS

(max. per ext. line for inputs and outputs 
respectively) 

1 KB 

 Physical I/O address space for PROFINET 
(max. per line for inputs and outputs 
respectively) 

4 KB 

 Address space for each PROFIBUS DP 
station 

244 bytes 

 Address space for each PROFINET device 
station 

1400 bytes 
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SIMOTION device D410 D425 / D435 D445 
Technology objects Maximum number of axes 1 D425 = 16 

D435 = 32 
64 

 Integrated drive control (in combination 
with SINAMICS S120); 
further axes are possible via CX32 for 
D435 and D445 

1 
(Servo/vector) 

1 ... 6 (servo) 
1 ... 4 (vector) 

 Number of measuring inputs (onboard 
measuring inputs - for integrated drives) 

3 6 

 Onboard outputs for output cams 4 8 
Cycle clocks and 
times 

PROFIBUS DP cycle clock 2 ... 8 ms D425 = 2 ... 8 
D435 = 1 ... 8 

1 ... 8 ms 

 PROFINET cycle clock In 0.125 ms increments: 0.5 ... 4 ms 
 Minimum position control cycle clock 2 ms D425 = 2 ms 

D435 = 1 ms 
0.5 ms 
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7.2 Memory requirement 

Memory requirement 

Table 7-5 Memory requirement for each instance of a technology object 

Technology object Memory requirement / KB 
Drive axis 180 
Position axis 200 
Following axis with following object 350 
External encoder 150 
Output cam 100 
Measuring input 100 
Cam 
In addition for each interpolation point pair 

100 
1 

TController: Heating controller 85 
TController: Cooling controller 70 
TController: Heating/cooling controller 100 
Position axis path interpolation  250 
Path object (for 4 axes, 1 cam) 200 
Cam track 450 
Addition object 50 
Formula object 150 
Fixed gear 100 
Controller 100 
Sensor 100 

 

Table 7-6 Memory requirement of technology packages 

Technology package Memory requirement / KB 
TP TControl 1.700 
TP CAM 7.700 
TP PATH 8.500 
TP CAM_EXT 9.500 
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SIMOTION SCOUT Standalone, 31 

Installing 
Interface card, 23 

Interface, 26 
Interface card 

Configuring, 24 
Installing, 23 

K 
Keyboard action, 40 

L 
LAD/FBD, 20 
Ladder Logic / Function Block Diagram, 20 
Libraries 

Upgrade, 80 
License key, 72 

Changing, 76 
Entering, 75 
Saving, 33 
Transferring, 33 

Licenses 
Determining, 73 
Displaying, 74 

Licensing, 71 
Accessible nodes, 74 
Hardware replacement, 76 
Performing, 75 
Underlicensing, 77 

Limits, 158 

M 
Main menu, 39 
MCC, 19 
Memory media, 90 
Memory requirement 

Technology object, 292 
Technology packages, 292 

Menu 
Context menu, 45 
Main menu, 39 
Menu structure, 39 

Menu bar, 38 
Menu items, 41 
MICROMASTER 420 

Commissioning, 151 
Configuring, 153 
Expert list, 163 
Insert, 144 
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Motion Control Chart, 19 
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